Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

ppp multilink problem

Multilink PPP question

I have a Cisco 2811 with 8 serial interfaces.  Three of them are in multilink1 which is our active connection to AT&T MPLS.  I have the other 5 in multilink3 which will be an upgrade to a new MPLS.  The two multilinks have different ip addresses.  AT&T cannot get the multilnik3 (the new one) to come up.  The serial links are clean with no errors. 

Cisco TAC looked at the config and ran some debugs.  Their conclusion was that the far end AT&T router keeps dropping the multilink.

Here is a debug of what it does (this shows only one serial interface in the multilink - for testing purposes).

Any thoughts on this would be appreciated.

Feb  3 19:58:47.325: Se0/2/0:0 PPP: Phase is ESTABLISHING, Passive Open
Feb  3 19:58:47.325: Se0/2/0:0 LCP: State is Listen
Feb  3 19:58:47.333: Se0/2/0:0 LCP: I CONFREQ [Listen] id 36 len 28
Feb  3 19:58:47.333: Se0/2/0:0 LCP:    MagicNumber 0xB4B32784 (0x0506B4B32784)
Feb  3 19:58:47.333: Se0/2/0:0 LCP:    MRRU 1500 (0x110405DC)
Feb  3 19:58:47.333: Se0/2/0:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:47.333: Se0/2/0:0 MLP: Peer MRRU (1500) less than group Mu3 MTU (1524)
Feb  3 19:58:47.337: Se0/2/0:0 LCP: O CONFREQ [Listen] id 87 len 28
Feb  3 19:58:47.337: Se0/2/0:0 LCP:    MagicNumber 0x494755CA (0x0506494755CA)
Feb  3 19:58:47.337: Se0/2/0:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:47.337: Se0/2/0:0 LCP:    EndpointDisc 1 Ply2811MPLS (0x130E01506C79323831314D504C53)
Feb  3 19:58:47.337: Se0/2/0:0 LCP: O CONFNAK [Listen] id 36 len 8
Feb  3 19:58:47.337: Se0/2/0:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:47.341: Se0/2/0:0 LCP: I CONFACK [REQsent] id 87 len 28
Feb  3 19:58:47.341: Se0/2/0:0 LCP:    MagicNumber 0x494755CA (0x0506494755CA)
Feb  3 19:58:47.341: Se0/2/0:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:47.341: Se0/2/0:0 LCP:    EndpointDisc 1 Ply2811MPLS (0x130E01506C79323831314D504C53)
Feb  3 19:58:47.341: Se0/2/0:0 LCP: I CONFREQ [ACKrcvd] id 37 len 28
Feb  3 19:58:47.341: Se0/2/0:0 LCP:    MagicNumber 0xB4B32784 (0x0506B4B32784)
Feb  3 19:58:47.341: Se0/2/0:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:47.341: Se0/2/0:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:47.341: Se0/2/0:0 LCP: O CONFACK [ACKrcvd] id 37 len 28
Feb  3 19:58:47.341: Se0/2/0:0 LCP:    MagicNumber 0xB4B32784 (0x0506B4B32784)
Feb  3 19:58:47.341: Se0/2/0:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:47.345: Se0/2/0:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:47.345: Se0/2/0:0 LCP: State is Open
Feb  3 19:58:47.345: Se0/2/0:0 PPP: Phase is FORWARDING, Attempting Forward
Feb  3 19:58:47.349: Se0/2/0:0 LCP: I TERMREQ [Open] id 38 len 4
Feb  3 19:58:47.349: Se0/2/0:0 LCP: Discard packet in FORWARDING phase
Feb  3 19:58:47.353: Se0/2/0:0 PPP: Phase is ESTABLISHING, Finish LCP
Feb  3 19:58:47.353: Se0/2/0:0 MLP: Request add link to bundle
Feb  3 19:58:47.353: Se0/2/0:0 PPP: Phase is VIRTUALIZED
Feb  3 19:58:47.353: Se0/2/0:0 MLP: Adding link to bundle
Feb  3 19:58:47.353: Mu3 Debug: Condition 1, interface Se0/2/0:0 triggered, count 1
Feb  3 19:58:47.357: Se0/2/0:0 MLP: Computed frag size 5752 exceeds configured value, changed to 1496
Feb  3 19:58:47.357: Mu3 MLP: Added first link Se0/2/0:0 to bundle group147520
Feb  3 19:58:47.357: Se0/3/0:0 MLP: Computed frag size 5752 exceeds MTU, changed to 1496
Feb  3 19:58:47.357: Mu3 MLP: Added link Se0/3/0:0 to bundle group147520
Feb  3 19:58:47.361: Mu3 MLP: Removing link Se0/3/0:0 from bundle group147520
Feb  3 19:58:47.361: Mu3 MLP: Dropped link Se0/3/0:0 from bundle group147520
Feb  3 13:58:47.365 CST: %LINK-3-UPDOWN: Interface Multilink3, changed state to up
Feb  3 19:58:47.365: Mu3 PPP: Outbound cdp packet dropped
Feb  3 19:58:47.369: Mu3 PPP: Phase is UP
Feb  3 19:58:47.369: Mu3 IPCP: O CONFREQ [Closed] id 1 len 10
Feb  3 19:58:47.369: Mu3 IPCP:    Address 12.84.188.222 (0x03060C54BCDE)
Feb  3 19:58:47.369: Mu3 CDPCP: O CONFREQ [Closed] id 1 len 4
Feb  3 19:58:47.369: Mu3 PPP: Process pending ncp packets
Feb  3 19:58:47.369: Se0/2/0:0 PPP: Process pending ncp packets
Feb  3 19:58:47.369: Mu3 PPP: Process pending ncp packets
Feb  3 19:58:48.125: Se0/0/1:0 LCP: Timeout: State Listen
Feb  3 19:58:48.129: Se0/0/1:0 LCP: O CONFREQ [Listen] id 148 len 28
Feb  3 19:58:48.129: Se0/0/1:0 LCP:    MagicNumber 0x494758E5 (0x0506494758E5)
Feb  3 19:58:48.129: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:48.129: Se0/0/1:0 LCP:    EndpointDisc 1 Ply2811MPLS (0x130E01506C79323831314D504C53)
Feb  3 19:58:48.137: Se0/0/1:0 LCP: I CONFREQ [REQsent] id 103 len 28
Feb  3 19:58:48.137: Se0/0/1:0 LCP:    MagicNumber 0xB4B3202C (0x0506B4B3202C)
Feb  3 19:58:48.137: Se0/0/1:0 LCP:    MRRU 1500 (0x110405DC)
Feb  3 19:58:48.137: Se0/0/1:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:48.137: Se0/0/1:0 MLP: Peer MRRU (1500) less than group Mu3 MTU (1524)
Feb  3 19:58:48.137: Se0/0/1:0 LCP: O CONFNAK [REQsent] id 103 len 8
Feb  3 19:58:48.137: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:48.137: Se0/0/1:0 LCP: I CONFACK [REQsent] id 148 len 28
Feb  3 19:58:48.137: Se0/0/1:0 LCP:    MagicNumber 0x494758E5 (0x0506494758E5)
Feb  3 19:58:48.137: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:48.137: Se0/0/1:0 LCP:    EndpointDisc 1 Ply2811MPLS (0x130E01506C79323831314D504C53)
Feb  3 19:58:48.277: Se0/0/1:0 LCP: I CONFREQ [ACKrcvd] id 104 len 28
Feb  3 19:58:48.277: Se0/0/1:0 LCP:    MagicNumber 0xB4B3202C (0x0506B4B3202C)
Feb  3 19:58:48.281: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:48.281: Se0/0/1:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:48.281: Se0/0/1:0 LCP: O CONFACK [ACKrcvd] id 104 len 28
Feb  3 19:58:48.281: Se0/0/1:0 LCP:    MagicNumber 0xB4B3202C (0x0506B4B3202C)
Feb  3 19:58:48.281: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:48.281: Se0/0/1:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:48.281: Se0/0/1:0 LCP: State is Open
Feb  3 19:58:48.281: Se0/0/1:0 PPP: Phase is FORWARDING, Attempting Forward
Feb  3 19:58:48.281: Se0/0/1:0 PPP: Outbound cdp packet dropped
Feb  3 19:58:48.313: Se0/0/1:0 PPP: Phase is ESTABLISHING, Finish LCP
Feb  3 19:58:48.313: Se0/0/1:0 MLP: Request add link to bundle
Feb  3 19:58:48.313: Se0/0/1:0 PPP: Phase is VIRTUALIZED
Feb  3 19:58:48.313: Se0/0/1:0 LCP: I TERMREQ [Open] id 105 len 4
Feb  3 19:58:48.313: Se0/0/1:0 LCP: O TERMACK [Open] id 105 len 4
Feb  3 19:58:48.313: Se0/0/1:0 PPP: Sending Acct Event[Down] id[863F8]
Feb  3 19:58:48.313: Se0/0/1:0 PPP: Phase is TERMINATING
Feb  3 19:58:48.313: Se0/0/1:0 MLP: Can't add link to bundle, interface renegotiated without MP
Feb  3 19:58:48.317: Se0/2/1:0 MLP: Computed frag size 5752 exceeds MTU, changed to 1496
Feb  3 19:58:48.317: Mu3 MLP: Added link Se0/2/1:0 to bundle group147520
Feb  3 13:58:48.365 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink3, changed state to up
Feb  3 19:58:49.513: Se0/0/1:0 PPP: Outbound cdp packet dropped
Feb  3 19:58:49.513: Se0/2/0:0 LCP: I TERMREQ [Open] id 39 len 4
Feb  3 19:58:49.513: Se0/2/0:0 LCP: O TERMACK [Open] id 39 len 4
Feb  3 19:58:49.513: Se0/2/0:0 PPP: Sending Acct Event[Down] id[863F5]
Feb  3 19:58:49.513: Se0/2/0:0 MLP: Request drop link from bundle Mu3
Feb  3 19:58:49.517: Se0/2/0:0 PPP: Phase is TERMINATING
Feb  3 19:58:49.517: Mu3 MLP: Removing link Se0/2/0:0 from bundle group147520
Feb  3 19:58:49.517: Mu3 MLP: Dropped link Se0/2/0:0 from bundle group147520
Feb  3 19:58:49.517: Mu3 Debug: Condition 1, interface Se0/2/0:0 cleared, count 0
Feb  3 13:58:49.533 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/1:0, changed state to up
Feb  3 19:58:50.589: Se0/0/1:0 LCP: Timeout: State TERMsent
Feb  3 19:58:50.589: Se0/0/1:0 LCP: State is Closed
Feb  3 19:58:50.589: Se0/0/1:0 PPP: Phase is DOWN
Feb  3 19:58:50.593: Se0/0/1:0 PPP: Phase is ESTABLISHING, Passive Open
Feb  3 19:58:50.593: Se0/0/1:0 LCP: State is Listen
Feb  3 13:58:50.605 CST: %LINK-3-UPDOWN: Interface Multilink3, changed state to down
Feb  3 19:58:51.505: Se0/2/0:0 LCP: Timeout: State TERMsent
Feb  3 19:58:51.505: Se0/2/0:0 LCP: State is Closed
Feb  3 19:58:51.505: Se0/2/0:0 PPP: Phase is DOWN
Feb  3 19:58:51.505: Se0/2/0:0 PPP: Phase is ESTABLISHING, Passive Open
Feb  3 19:58:51.505: Se0/2/0:0 LCP: State is Listen
Feb  3 19:58:52.177: Se0/2/0:0 LCP: I CONFREQ [Listen] id 40 len 28
Feb  3 19:58:52.177: Se0/2/0:0 LCP:    MagicNumber 0xB4B337F0 (0x0506B4B337F0)
Feb  3 19:58:52.177: Se0/2/0:0 LCP:    MRRU 1500 (0x110405DC)
Feb  3 19:58:52.177: Se0/2/0:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:52.177: Se0/2/0:0 MLP: Peer MRRU (1500) less than group Mu3 MTU (1524)
Feb  3 19:58:52.177: Se0/2/0:0 LCP: O CONFREQ [Listen] id 88 len 28
Feb  3 19:58:52.177: Se0/2/0:0 LCP:    MagicNumber 0x494768BD (0x0506494768BD)
Feb  3 19:58:52.177: Se0/2/0:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:52.177: Se0/2/0:0 LCP:    EndpointDisc 1 Ply2811MPLS (0x130E01506C79323831314D504C53)
Feb  3 19:58:52.177: Se0/2/0:0 LCP: O CONFNAK [Listen] id 40 len 8
Feb  3 19:58:52.177: Se0/2/0:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 13:58:52.181 CST: %LINK-3-UPDOWN: Interface Multilink3, changed state to up
Feb  3 13:58:52.185 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/1:0, changed state to down
Feb  3 19:58:52.201: Se0/2/0:0 LCP: I CONFACK [REQsent] id 88 len 28
Feb  3 19:58:52.201: Se0/2/0:0 LCP:    MagicNumber 0x494768BD (0x0506494768BD)
Feb  3 19:58:52.201: Se0/2/0:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:52.201: Se0/2/0:0 LCP:    EndpointDisc 1 Ply2811MPLS (0x130E01506C79323831314D504C53)
Feb  3 19:58:52.201: Se0/2/0:0 LCP: I CONFREQ [ACKrcvd] id 41 len 28
Feb  3 19:58:52.201: Se0/2/0:0 LCP:    MagicNumber 0xB4B337F0 (0x0506B4B337F0)
Feb  3 19:58:52.201: Se0/2/0:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:52.205: Se0/2/0:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:52.205: Se0/2/0:0 LCP: O CONFACK [ACKrcvd] id 41 len 28
Feb  3 19:58:52.205: Se0/2/0:0 LCP:    MagicNumber 0xB4B337F0 (0x0506B4B337F0)
Feb  3 19:58:52.205: Se0/2/0:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:52.205: Se0/2/0:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:52.205: Se0/2/0:0 LCP: State is Open
Feb  3 19:58:52.205: Se0/2/0:0 PPP: Phase is FORWARDING, Attempting Forward
Feb  3 19:58:52.213: Se0/2/0:0 LCP: I TERMREQ [Open] id 42 len 4
Feb  3 19:58:52.213: Se0/2/0:0 LCP: Discard packet in FORWARDING phase
Feb  3 19:58:52.213: Se0/2/0:0 PPP: Phase is ESTABLISHING, Finish LCP
Feb  3 19:58:52.213: Se0/2/0:0 MLP: Request add link to bundle
Feb  3 19:58:52.213: Se0/2/0:0 PPP: Phase is VIRTUALIZED
Feb  3 19:58:52.213: Se0/2/0:0 MLP: Adding link to bundle
Feb  3 19:58:52.213: Mu3 Debug: Condition 1, interface Se0/2/0:0 triggered, count 1
Feb  3 19:58:52.217: Se0/2/0:0 MLP: Computed frag size 5752 exceeds configured value, changed to 1496
Feb  3 19:58:52.217: Mu3 MLP: Added first link Se0/2/0:0 to bundle group147520
Feb  3 13:58:52.217 CST: %LINK-3-UPDOWN: Interface Multilink3, changed state to up
Feb  3 19:58:52.217: Mu3 PPP: Phase is UP
Feb  3 19:58:52.221: Mu3 IPCP: O CONFREQ [Closed] id 1 len 10
Feb  3 19:58:52.221: Mu3 IPCP:    Address 12.84.188.222 (0x03060C54BCDE)
Feb  3 19:58:52.221: Mu3 CDPCP: O CONFREQ [Closed] id 1 len 4
Feb  3 19:58:52.221: Mu3 PPP: Process pending ncp packets
Feb  3 19:58:52.221: Se0/2/0:0 PPP: Process pending ncp packets
Feb  3 19:58:52.221: Mu3 PPP: Process pending ncp packets
Feb  3 19:58:53.713: Se0/0/1:0 LCP: Timeout: State Listen
Feb  3 19:58:53.717: Se0/0/1:0 LCP: O CONFREQ [Listen] id 149 len 28
Feb  3 19:58:53.717: Se0/0/1:0 LCP:    MagicNumber 0x49476EBE (0x050649476EBE)
Feb  3 19:58:53.717: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:53.717: Se0/0/1:0 LCP:    EndpointDisc 1 Ply2811MPLS (0x130E01506C79323831314D504C53)
Feb  3 19:58:53.717: Se0/2/0:0 MLP: cdp packet forwarded to wrong interface
Feb  3 19:58:53.745: Mu3 PPP: Outbound cdp packet dropped
Feb  3 19:58:53.749: Se0/0/1:0 LCP: I CONFREQ [REQsent] id 107 len 28
Feb  3 19:58:53.749: Se0/0/1:0 LCP:    MagicNumber 0xB4B33337 (0x0506B4B33337)
Feb  3 19:58:53.749: Se0/0/1:0 LCP:    MRRU 1500 (0x110405DC)
Feb  3 19:58:53.749: Se0/0/1:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:53.749: Se0/0/1:0 MLP: Peer MRRU (1500) less than group Mu3 MTU (1524)
Feb  3 19:58:53.749: Se0/0/1:0 LCP: O CONFNAK [REQsent] id 107 len 8
Feb  3 19:58:53.749: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:53.753: Se0/0/1:0 LCP: I CONFACK [REQsent] id 149 len 28
Feb  3 19:58:53.753: Se0/0/1:0 LCP:    MagicNumber 0x49476EBE (0x050649476EBE)
Feb  3 19:58:53.753: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:53.757: Se0/0/1:0 LCP:    EndpointDisc 1 Ply2811MPLS (0x130E01506C79323831314D504C53)
Feb  3 19:58:53.757: Se0/0/1:0 LCP: I CONFREQ [ACKrcvd] id 108 len 28
Feb  3 19:58:53.757: Se0/0/1:0 LCP:    MagicNumber 0xB4B33337 (0x0506B4B33337)
Feb  3 19:58:53.757: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:53.757: Se0/0/1:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:53.757: Se0/0/1:0 LCP: O CONFACK [ACKrcvd] id 108 len 28
Feb  3 19:58:53.757: Se0/0/1:0 LCP:    MagicNumber 0xB4B33337 (0x0506B4B33337)
Feb  3 19:58:53.757: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:53.757: Se0/0/1:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:53.757: Se0/0/1:0 LCP: State is Open
Feb  3 19:58:53.757: Se0/0/1:0 PPP: Phase is FORWARDING, Attempting Forward
Feb  3 19:58:53.761: Se0/0/1:0 PPP: Phase is ESTABLISHING, Finish LCP
Feb  3 19:58:53.761: Se0/0/1:0 MLP: Request add link to bundle
Feb  3 19:58:53.761: Se0/0/1:0 PPP: Phase is VIRTUALIZED
Feb  3 19:58:53.761: Se0/0/1:0 MLP: Adding link to bundle
Feb  3 19:58:53.761: Mu3 Debug: Condition 2, interface Se0/0/1:0 triggered, count 2
Feb  3 19:58:53.761: Se0/0/1:0 MLP: Computed frag size 5752 exceeds MTU, changed to 1496
Feb  3 19:58:53.765: Mu3 MLP: Added link Se0/0/1:0 to bundle group147520
Feb  3 19:58:53.765: Se0/0/1:0 LCP: I TERMREQ [Open] id 109 len 4
Feb  3 19:58:53.765: Se0/0/1:0 LCP: O TERMACK [Open] id 109 len 4
Feb  3 19:58:53.765: Se0/0/1:0 PPP: Sending Acct Event[Down] id[863FF]
Feb  3 19:58:53.765: Se0/0/1:0 MLP: Request drop link from bundle Mu3
Feb  3 19:58:53.765: Se0/0/1:0 PPP: Phase is TERMINATING
Feb  3 19:58:53.765: Mu3 MLP: Removing link Se0/0/1:0 from bundle group147520
Feb  3 19:58:53.765: Mu3 MLP: Dropped link Se0/0/1:0 from bundle group147520
Feb  3 19:58:53.765: Mu3 Debug: Condition 2, interface Se0/0/1:0 cleared, count 1
Feb  3 19:58:54.921: Mu3 IPCP: Timeout: State REQsent
Feb  3 19:58:54.921: Mu3 IPCP: O CONFREQ [REQsent] id 2 len 10
Feb  3 19:58:54.921: Mu3 IPCP:    Address 12.84.188.222 (0x03060C54BCDE)
Feb  3 13:58:54.925 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0:0, changed state to up
Feb  3 19:58:54.945: Mu3 PPP: Outbound cdp packet dropped
Feb  3 19:58:54.945: Mu3 CDPCP: Timeout: State REQsent
Feb  3 19:58:54.945: Mu3 CDPCP: O CONFREQ [REQsent] id 2 len 4
Feb  3 19:58:54.949: Se0/2/0:0 LCP: I TERMREQ [Open] id 43 len 4
Feb  3 19:58:54.949: Mu3 MLP: No previous member for idle link in 'group147520'
Feb  3 19:58:54.949: Se0/2/0:0 LCP: O TERMACK [Open] id 43 len 4
Feb  3 19:58:54.949: Se0/2/0:0 PPP: Sending Acct Event[Down] id[863FD]
Feb  3 19:58:54.949: Se0/2/0:0 MLP: Request drop link from bundle Mu3
Feb  3 19:58:54.949: Se0/2/0:0 PPP: Phase is TERMINATING
Feb  3 19:58:54.953: Mu3 MLP: Removing link Se0/2/0:0 from bundle group147520
Feb  3 19:58:54.953: Mu3 MLP: Dropped link Se0/2/0:0 from bundle group147520
Feb  3 19:58:54.953: Mu3 Debug: Condition 1, interface Se0/2/0:0 cleared, count 0
Feb  3 13:58:54.961 CST: %LINK-3-UPDOWN: Interface Multilink3, changed state to down
Feb  3 13:58:54.973 CST: %LINK-3-UPDOWN: Interface Multilink3, changed state to up
Feb  3 19:58:56.081: Se0/0/1:0 LCP: I CONFREQ [TERMsent] id 110 len 28
Feb  3 19:58:56.081: Se0/0/1:0 LCP:    MagicNumber 0xB4B34899 (0x0506B4B34899)
Feb  3 19:58:56.081: Se0/0/1:0 LCP:    MRRU 1500 (0x110405DC)
Feb  3 19:58:56.081: Se0/0/1:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:56.081: Se0/0/1:0 LCP: Dropping packet, state is TERMsent
Feb  3 13:58:56.093 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0:0, changed state to down
Feb  3 19:58:56.093: Se0/2/0:0 PPP: Outbound cdp packet dropped
Feb  3 19:58:56.101: Se0/0/1:0 LCP: Timeout: State TERMsent
Feb  3 19:58:56.101: Se0/0/1:0 LCP: State is Closed
Feb  3 19:58:56.101: Se0/0/1:0 PPP: Phase is DOWN
Feb  3 19:58:56.101: Se0/0/1:0 PPP: Phase is ESTABLISHING, Passive Open
Feb  3 19:58:56.101: Se0/0/1:0 LCP: State is Listen
Feb  3 19:58:57.837: Se0/2/0:0 LCP: Timeout: State TERMsent
Feb  3 19:58:57.837: Se0/2/0:0 LCP: State is Closed
Feb  3 19:58:57.837: Se0/2/0:0 PPP: Phase is DOWN
Feb  3 19:58:57.841: Se0/2/0:0 PPP: Phase is ESTABLISHING, Passive Open
Feb  3 19:58:57.841: Se0/2/0:0 LCP: State is Listen
Feb  3 13:58:57.845 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/3/1:0, changed state to up
Feb  3 19:58:57.857: Se0/0/1:0 LCP: I CONFREQ [Listen] id 111 len 28
Feb  3 19:58:57.857: Se0/0/1:0 LCP:    MagicNumber 0xB4B34899 (0x0506B4B34899)
Feb  3 19:58:57.857: Se0/0/1:0 LCP:    MRRU 1500 (0x110405DC)
Feb  3 19:58:57.857: Se0/0/1:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:57.861: Se0/0/1:0 MLP: Peer MRRU (1500) less than group Mu3 MTU (1524)
Feb  3 19:58:57.861: Se0/0/1:0 LCP: O CONFREQ [Listen] id 150 len 28
Feb  3 19:58:57.861: Se0/0/1:0 LCP:    MagicNumber 0x49477EF2 (0x050649477EF2)
Feb  3 19:58:57.861: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:57.861: Se0/0/1:0 LCP:    EndpointDisc 1 Ply2811MPLS (0x130E01506C79323831314D504C53)
Feb  3 19:58:57.861: Se0/0/1:0 LCP: O CONFNAK [Listen] id 111 len 8
Feb  3 19:58:57.861: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:57.869: Se0/0/1:0 LCP: I CONFACK [REQsent] id 150 len 28
Feb  3 19:58:57.869: Se0/0/1:0 LCP:    MagicNumber 0x49477EF2 (0x050649477EF2)
Feb  3 19:58:57.869: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:57.869: Se0/0/1:0 LCP:    EndpointDisc 1 Ply2811MPLS (0x130E01506C79323831314D504C53)
Feb  3 19:58:57.869: Se0/0/1:0 LCP: I CONFREQ [ACKrcvd] id 112 len 28
Feb  3 19:58:57.869: Se0/0/1:0 LCP:    MagicNumber 0xB4B34899 (0x0506B4B34899)
Feb  3 19:58:57.869: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:57.869: Se0/0/1:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:57.873: Se0/0/1:0 LCP: O CONFACK [ACKrcvd] id 112 len 28
Feb  3 19:58:57.873: Se0/0/1:0 LCP:    MagicNumber 0xB4B34899 (0x0506B4B34899)
Feb  3 19:58:57.873: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)
Feb  3 19:58:57.873: Se0/0/1:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)
Feb  3 19:58:57.873: Se0/0/1:0 LCP: State is Open
Feb  3 19:58:57.873: Se0/0/1:0 PPP: Phase is FORWARDING, Attempting Forward
Feb  3 13:58:57.873 CST: %LINK-3-UPDOWN: Interface Multilink3, changed state to down
Feb  3 19:58:57.877: Se0/0/1:0 PPP: Phase is ESTABLISHING, Finish LCP
Feb  3 19:58:57.877: Se0/0/1:0 MLP: Request add link to bundle
Feb  3 19:58:57.877: Se0/0/1:0 PPP: Phase is VIRTUALIZED
Feb  3 19:58:57.877: Se0/0/1:0 LCP: I TERMREQ [Open] id 113 len 4
Feb  3 19:58:57.877: Se0/0/1:0 LCP: O TERMACK [Open] id 113 len 4
Feb  3 19:58:57.877: Se0/0/1:0 PPP: Sending Acct Event[Down] id[86404]
Feb  3 19:58:57.877: Se0/0/1:0 PPP: Phase is TERMINATING
Feb  3 19:58:57.877: Se0/0/1:0 MLP: Can't add link to bundle, interface renegotiated without MP
*********************************************************************************** *** *** *** *** Unauthorized Access Strictly Prohibited *** *** *** *** *** ********************************************************************************

User Access Verification

Username: bfairchild
Password:

Ply2811MPLS#
Ply2811MPLS#
Ply2811MPLS#sh run
Building configuration...

Current configuration : 5954 bytes
!
! Last configuration change at 12:25:53 CST Fri Feb 3 2012 by bfairchild
! NVRAM config last updated at 12:27:20 CST Fri Feb 3 2012 by bfairchild
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec localtime show-timezone
no service password-encryption
!
hostname Ply2811MPLS
!
boot-start-marker
boot system flash:c2800nm-entbasek9-mz.124-20.T4.bin
boot-end-marker
!
card type t1 0 2
card type t1 0 3
logging message-counter syslog
logging buffered 20000
!
aaa new-model
!
!
aaa authentication login default group tacacs+ local
aaa authorization console
aaa authorization exec default group tacacs+ local if-authenticated
aaa authorization commands 0 default group tacacs+ local
aaa authorization commands 1 default group tacacs+ local
aaa authorization commands 15 default group tacacs+ local
aaa accounting exec default start-stop group tacacs+
aaa accounting commands 0 default start-stop group tacacs+
aaa accounting commands 1 default start-stop group tacacs+
aaa accounting commands 15 default start-stop group tacacs+
aaa accounting network acct_methods start-stop group rad_acct
aaa accounting system default start-stop group tacacs+
!
!
aaa session-id common
clock timezone CST -6
clock summer-time CDT recurring
no network-clock-participate wic 0
no network-clock-participate wic 1
no network-clock-participate wic 2
no network-clock-participate wic 3
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
multilink bundle-name authenticated
!
!
!
!
!        
!
username local privilege 15 secret 5 $1$WEe9$jSgGX8j8ggTp8Xs57qPxr.
archive
log config
  hidekeys
!
!
controller T1 0/0/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/0/1
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/1/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/1/1
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/2/0
framing esf
linecode b8zs
cablelength long 0db
channel-group 0 timeslots 1-24
!
controller T1 0/2/1
framing esf
linecode b8zs
cablelength long 0db
channel-group 0 timeslots 1-24
!
controller T1 0/3/0
framing esf
linecode b8zs
cablelength long 0db
channel-group 0 timeslots 1-24
!
controller T1 0/3/1
framing esf
linecode b8zs
cablelength long 0db
channel-group 0 timeslots 1-24
!
!
class-map match-all VOICE-CONTROL
match access-group 151
class-map match-all VOICE
match access-group 150
!
!
policy-map WAN-EDGE
class VOICE
    priority percent 50
class VOICE-CONTROL
    priority percent 1
class class-default
    fair-queue
!
!
!
!
interface Tunnel64
no ip address
shutdown
!
interface Multilink1
ip address 12.85.128.34 255.255.255.252
ip flow ingress
ip flow egress
ppp multilink
ppp multilink group 1
service-policy output WAN-EDGE
!
interface Multilink2
no ip address
ip flow ingress
ip flow egress
shutdown
ppp multilink
ppp multilink group 2
service-policy output WAN-EDGE
!
interface Multilink3
mtu 1524
ip address 12.84.188.222 255.255.255.252
ppp multilink
ppp multilink group 3
!
interface FastEthernet0/0
ip address 192.168.64.2 255.255.255.248
ip accounting output-packets
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.64.18 255.255.255.252
delay 500000
duplex auto
speed auto
!
interface Serial0/0/0:0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
!
interface Serial0/0/1:0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 3
!
interface Serial0/1/0:0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
!
interface Serial0/1/1:0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
!
interface Serial0/2/0:0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 3
ppp multilink fragment size 1496
!
interface Serial0/2/1:0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 3
!
interface Serial0/3/0:0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 3
!
interface Serial0/3/1:0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 3
!
router eigrp 100
redistribute bgp 65001 metric 1500 1 255 1 1500
network 10.0.64.0 0.0.7.255
network 192.168.64.0 0.0.0.7
network 192.168.64.16 0.0.0.3
no auto-summary
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
network 10.0.64.0 mask 255.255.248.0
network 10.164.64.0 mask 255.255.248.0
network 12.20.38.32 mask 255.255.255.240
network 172.16.10.0 mask 255.255.255.0
network 192.168.64.0 mask 255.255.255.248
network 192.168.64.8 mask 255.255.255.252
network 192.168.64.12 mask 255.255.255.252
network 192.168.64.16 mask 255.255.255.252
network 192.168.64.24 mask 255.255.255.248
neighbor 12.85.128.33 remote-as 7018
no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip flow-export source Multilink1
ip flow-export version 5
ip flow-export destination 10.0.105.17 2055
!
ip tacacs source-interface FastEthernet0/0
!
logging trap notifications
logging source-interface FastEthernet0/0
logging 10.0.104.52
access-list 101 deny   ip any host 10.164.0.11
access-list 101 deny   ip any host 10.164.0.12
access-list 101 deny   ip any host 10.164.0.13
access-list 101 permit ip any any
access-list 150 permit ip any any dscp ef
access-list 151 permit ip any any dscp cs5
snmp-server community wg96gbltd RO
snmp-server community wg96GBLTD RW
!
!
tacacs-server host 10.0.104.231
tacacs-server host 10.0.87.140
tacacs-server directed-request
tacacs-server key 7 044C5B0F582D1E425A
!
control-plane
!
banner motd ^C*********************************************************************************** *** *** *** *** Unauthorized Access Strictly Prohibited *** *** *** *** *** ******************************************************************************** ^C
!
line con 0
line aux 0
line vty 0 4
!
scheduler allocate 20000 1000
ntp server 10.0.96.93
end

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

ppp multilink problem

Bill

This is very interesting and helpful. Thanks for posting to the thread with this information about how you solved the problem. +5 to you for posting the solution. Perhaps now you could mark the question as answered so other people can know that they would find the solution here?

HTH

Rick

6 REPLIES
Bronze

Re: ppp multilink problem

Your mtu size of 1524 on Multilink3 doesn't match the fragment size on serial0/2/0:0 of 1496.

Change the mtu size to match the interface.

Also this may help as well

http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcflfi.html#wp1000907

Hope this helps

Eugen

New Member

Re: ppp multilink problem

Thanks for looking at this.  I changed the mtu size as you suggested.  Still no luck.

It looks ok until this message:

Feb  7 02:07:32.307: Se0/2/0:0 MLP: cdp packet forwarded to wrong interface

Then it goes ahead and drops the link from the bundle and then starts all over again.

Debug:

Feb  7 02:07:30.307: Se0/2/0:0 PPP: Phase is ESTABLISHING, Passive Open

Feb  7 02:07:30.307: Se0/2/0:0 LCP: State is Listen

Feb  7 02:07:30.323: Se0/2/0:0 LCP: I CONFREQ [Listen] id 19 len 28

Feb  7 02:07:30.323: Se0/2/0:0 LCP:    MagicNumber 0xC57F0DCD (0x0506C57F0DCD)

Feb  7 02:07:30.323: Se0/2/0:0 LCP:    MRRU 1500 (0x110405DC)

Feb  7 02:07:30.323: Se0/2/0:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)

Feb  7 02:07:30.327: Se0/2/0:0 LCP: O CONFREQ [Listen] id 104 len 28

Feb  7 02:07:30.327: Se0/2/0:0 LCP:    MagicNumber 0x5A0D4435 (0x05065A0D4435)

Feb  7 02:07:30.327: Se0/2/0:0 LCP:    MRRU 1500 (0x110405DC)

Feb  7 02:07:30.327: Se0/2/0:0 LCP:    EndpointDisc 1 Ply2811MPLS (0x130E01506C79323831314D504C53)

Feb  7 02:07:30.327: Se0/2/0:0 LCP: O CONFACK [Listen] id 19 len 28

Feb  7 02:07:30.327: Se0/2/0:0 LCP:    MagicNumber 0xC57F0DCD (0x0506C57F0DCD)

Feb  7 02:07:30.327: Se0/2/0:0 LCP:    MRRU 1500 (0x110405DC)

Feb  7 02:07:30.327: Se0/2/0:0 LCP:    EndpointDisc 1 group147520 (0x130E0167726F7570313437353230)

Feb  7 02:07:30.331: Se0/2/0:0 LCP: I CONFACK [ACKsent] id 104 len 28

Feb  7 02:07:30.331: Se0/2/0:0 LCP:    MagicNumber 0x5A0D4435 (0x05065A0D4435)

Feb  7 02:07:30.331: Se0/2/0:0 LCP:    MRRU 1500 (0x110405DC)

Feb  7 02:07:30.331: Se0/2/0:0 LCP:    EndpointDisc 1 Ply2811MPLS (0x130E01506C79323831314D504C53)

Feb  7 02:07:30.331: Se0/2/0:0 LCP: State is Open

Feb  7 02:07:30.331: Se0/2/0:0 PPP: Phase is FORWARDING, Attempting Forward

Feb  7 02:07:30.335: Se0/2/0:0 LCP: I TERMREQ [Open] id 20 len 4

Feb  7 02:07:30.335: Se0/2/0:0 LCP: Discard packet in FORWARDING phase

Feb  7 02:07:30.335: Se0/2/0:0 PPP: Phase is ESTABLISHING, Finish LCP

Feb  7 02:07:30.335: Se0/2/0:0 MLP: Request add link to bundle

Feb  7 02:07:30.335: Se0/2/0:0 PPP: Phase is VIRTUALIZED

Feb  7 02:07:30.335: Se0/2/0:0 MLP: Adding link to bundle

Feb  7 02:07:30.339: Mu3 Debug: Condition 1, interface Se0/2/0:0 triggered, count 1

Feb  7 02:07:30.339: Se0/2/0:0 MLP: Computed frag size 5752 exceeds configured value, changed to 1496

Feb  7 02:07:30.339: Mu3 MLP: Added first link Se0/2/0:0 to bundle group147520

Feb  6 20:07:30.343 CST: %LINK-3-UPDOWN: Interface Multilink3, changed state to up

Feb  7 02:07:30.343: Mu3 PPP: Outbound cdp packet dropped

Feb  7 02:07:30.343: Mu3 PPP: Phase is UP

Feb  7 02:07:30.343: Mu3 IPCP: O CONFREQ [Closed] id 1 len 10

Feb  7 02:07:30.343: Mu3 IPCP:    Address 12.84.188.222 (0x03060C54BCDE)

Feb  7 02:07:30.347: Mu3 CDPCP: O CONFREQ [Closed] id 1 len 4

Feb  7 02:07:30.347: Mu3 PPP: Process pending ncp packets

Feb  7 02:07:30.347: Se0/2/0:0 PPP: Process pending ncp packets

Feb  7 02:07:30.347: Mu3 PPP: Process pending ncp packets

Feb  6 20:07:31.343 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink3, changed state to up

Feb  7 02:07:32.307: Se0/2/0:0 MLP: cdp packet forwarded to wrong interface

Feb  7 02:07:32.331: Se0/2/0:0 LCP: I TERMREQ [Open] id 21 len 4

Feb  7 02:07:32.331: Mu3 MLP: No previous member for idle link in 'group147520'

Feb  7 02:07:32.331: Se0/2/0:0 LCP: O TERMACK [Open] id 21 len 4

Feb  7 02:07:32.335: Se0/2/0:0 PPP: Sending Acct Event[Down] id[A2656]

Feb  7 02:07:32.335: Se0/2/0:0 MLP: Request drop link from bundle Mu3

Feb  7 02:07:32.335: Se0/2/0:0 PPP: Phase is TERMINATING

Feb  7 02:07:32.335: Mu3 MLP: Removing link Se0/2/0:0 from bundle group147520

Feb  7 02:07:32.335: Mu3 MLP: Dropped link Se0/2/0:0 from bundle group147520

Feb  7 02:07:32.335: Mu3 Debug: Condition 1, interface Se0/2/0:0 cleared, count 0

Feb  6 20:07:32.343 CST: %LINK-3-UPDOWN: Interface Multilink3, changed state to down

Feb  7 02:07:33.307: Se0/2/0:0 PPP: Outbound cdp packet dropped

Feb  6 20:07:33.343 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink3, changed state to down

Bronze

Re: ppp multilink problem

Is BGP running between your multilink3 and ISP?

The reason I am asking is that the ip address configured for multilink3 is not in same subnet as ip address used for neighbor statement under bgp config.

Also if the router at the other end is not cisco, disable cdp on serial interface

Eugen

New Member

Re: ppp multilink problem

Here is the solution(from Cisco TAC):  There are two mutlilink's on  this router.  Both were using the local endpoint discriminator of  Ply2811MPLS.  This caused a problem when trying to add an interface to  the new multilink(multilink3).  We added a local endpoint discriminator  of cisco123 to the new serial interfaces:

This first – to find an available extension:

interface Serial0/2/0:0

no ip address

encapsulation ppp

fair-queue

ppp multilink

ppp multilink group 3

ppp multilink endpoint string cisco123

Then they could be added to multilink3

Ply2811MPLS#sh ppp multilink

Multilink3

  Bundle name: group147520

  Remote Endpoint Discriminator: [1] group147520

  Local Endpoint Discriminator: [1] cisco123

  Bundle up for 08:55:00, total bandwidth 7680, load 1/255

  Receive buffer limit 60000 bytes, frag timeout 1000 ms

    0/0 fragments/bytes in reassembly list

    0 lost fragments, 0 reordered

    0/0 discarded fragments/bytes, 0 lost received

    0x111 received sequence, 0x124 sent sequence

  Member links: 5 active, 0 inactive (max not set, min not set)

    Se0/2/0:0, since 08:55:00, 5760 weight, 1496 frag size

    Se0/0/1:0, since 08:47:22, 5760 weight, 1496 frag size

    Se0/2/1:0, since 08:46:13, 5760 weight, 1496 frag size

    Se0/3/1:0, since 08:45:53, 5760 weight, 1496 frag size

    Se0/3/0:0, since 08:45:41, 5760 weight, 1496 frag size

Multilink1

  Bundle name: group18540

  Remote Endpoint Discriminator: [1] group18540

  Local Endpoint Discriminator: [1] Ply2811MPLS

  Bundle up for 2w1d, total bandwidth 4608, load 63/255

  Receive buffer limit 36000 bytes, frag timeout 1000 ms

    0/0 fragments/bytes in reassembly list

    688 lost fragments, 39707171 reordered

    0/0 discarded fragments/bytes, 0 lost received

    0x60E223 received sequence, 0xDD93E1 sent sequence

  Member links: 3 active, 0 inactive (max not set, min not set)

    Se0/1/1:0, since 2w1d

    Se0/0/0:0, since 2w1d

    Se0/1/0:0, since 6d08h

Thanks - Bill

Hall of Fame Super Gold

ppp multilink problem

Bill

This is very interesting and helpful. Thanks for posting to the thread with this information about how you solved the problem. +5 to you for posting the solution. Perhaps now you could mark the question as answered so other people can know that they would find the solution here?

HTH

Rick

ppp multilink problem

Bill,

Very interesting solution. I must admit.Haven't seen this fix before. A big thanks for sharing the solution and enabling us to increase our knowledge. I love CSC cuz if this. wonderful ppl with great knowledge and also willingness to share it with others +5 from me too

4171
Views
10
Helpful
6
Replies
CreatePlease to create content