Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PPP over Frame-Relay

hi

Why is it that we may want to configure PPP over Frame-relay,if both technologies are both layer two encapsulation techniques why do we use the two of them at the same time.For a moment i thought it is done to establish a secure connection between two end point by configuring ppp chap.

can somebody explain this.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: PPP over Frame-Relay

Hi,

We use PPP over frame relay for various reasons, mainly to benefit from the PPP features, authentication, MPPP, LFI and more, but both end devices must support it.

Example:

interface Serial1/0.1 point-to-point

bandwidth 128

frame-relay interface-dlci 51 ppp Virtual-Template1

class FRTS

!

interface Virtual-Template1

bandwidth 128

ip address 10.10.1.2 255.255.255.252

max-reserved-bandwidth 90

ppp multilink

ppp multilink fragment delay 10

ppp multilink interleave

!

map-class frame-relay FRTS

frame-relay cir 128000

frame-relay bc 12800

frame-relay be 0

frame-relay mincir 128000

service-policy output voice

HTH, please do rate all helpful replies,

Mohammed Mahmoud.

3 REPLIES

Re: PPP over Frame-Relay

Hi,

We use PPP over frame relay for various reasons, mainly to benefit from the PPP features, authentication, MPPP, LFI and more, but both end devices must support it.

Example:

interface Serial1/0.1 point-to-point

bandwidth 128

frame-relay interface-dlci 51 ppp Virtual-Template1

class FRTS

!

interface Virtual-Template1

bandwidth 128

ip address 10.10.1.2 255.255.255.252

max-reserved-bandwidth 90

ppp multilink

ppp multilink fragment delay 10

ppp multilink interleave

!

map-class frame-relay FRTS

frame-relay cir 128000

frame-relay bc 12800

frame-relay be 0

frame-relay mincir 128000

service-policy output voice

HTH, please do rate all helpful replies,

Mohammed Mahmoud.

New Member

Re: PPP over Frame-Relay

hi can u give a brief descriptionof how the virtual interface works as applied to the serial interface.

Re: PPP over Frame-Relay

Hi,

A virtual template interface is used to provide the configuration for dynamically created Virtual-Access interfaces. It is created by users and can be saved in nonvolatile RAM (NVRAM).

Once the virtual template interface is created, it can be configured in the same way as a serial interface.

To create a virtual template interface that can be configured and applied dynamically in creating virtual access interfaces, use the interface virtual-template command in global configuration mode.

Virtual template interfaces can be created and applied by various applications such as Virtual Profiles, virtual private dialup networks (VPDN), PPP over ATM, PPP over Frame Relay, protocol translation, and Multichassis Multilink PPP (MMP).

Following are FR and ATM examples:

interface Serial1/0.1 point-to-point

bandwidth 128

frame-relay interface-dlci 51 ppp Virtual-Template1

class FRTS

interface ATM1/0.52 point-to-point

ip vrf forwarding customer

pvc 101/52

abr 167 167

oam-pvc manage

encapsulation aal5ciscoppp virtual-Template 1

http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_command_reference_chapter09186a0080080d36.html#wp1017915

HTH, please do rate all helpful replies,

Mohammed Mahmoud.

221
Views
0
Helpful
3
Replies