Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

PPP T1 connection

Hello all, I've a question about a T1 set up that I'm working on.  I'm attempting to use a 2901 router with a purchased T1 HWIC and that will go as a Point to Point (Lease line) connection back to the local network where it will connect to an adtran CSU device.

Currently there are 2 older Nortell routers with an attached CSU via a serial cable.  On the "home side" the clocking is set to "network" and on the "remote" side the clocking is currently set to internal. 

My problem is I can't seem to get the 2901 to connect.  Currently in the lab environment there is home made cross over cable that connects fully functioninig set up from on nortell to the other.  As such I'm using the same cable and putting into the HWIC on the cisco device:  This is my set up:

===================================================================================================

R1#sh run
Building configuration...

Current configuration : 3735 bytes
!
! Last configuration change at 18:10:41 UTC Thu Aug 2 2012 by bcit
! NVRAM config last updated at 13:49:25 UTC Thu Aug 2 2012 by bcit
! NVRAM config last updated at 13:49:25 UTC Thu Aug 2 2012 by bcit
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
ip domain name yourdomain.com
multilink bundle-name authenticated
!
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-2510099137
  enrollment selfsigned
  subject-name cn=IOS-Self-Signed-Certificate-2510099137
  revocation-check none
  rsakeypair TP-self-signed-2510099137
!
!

license udi pid CISCO2901/K9 sn
!
!
username privilege 15 password 0
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
  no ip address
  shutdown
!
interface GigabitEthernet0/0
  description DIA-interface
  no ip address
  duplex auto
  speed auto
!
interface GigabitEthernet0/1
  description internal
  ip address 10.110.5.1 255.255.255.192
  duplex full
  speed auto
!
interface Serial0/0/0
  ip address 10.160.3.66 255.255.255.240
  encapsulation ppp
  service-module t1 clock source internal
  service-module t1 timeslots 1-24
!
router rip
  version 2
  network 10.0.0.0
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 10.160.3.64
!
access-list 1 permit 10.110.0.0 0.0.255.255
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 10.160.0.0 0.0.255.255
access-list 1 permit any
access-list 100 permit ip any any
access-list 100 permit ip 10.0.0.0 0.255.255.255 any
!
!
!
control-plane
!
!
!
line con 0
  login local
line aux 0
line 2
  no activation-character
  no exec
  transport preferred none
  transport input all
  transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
  stopbits 1
line vty 0 4
  access-class 23 in
  privilege level 15
  login local
  transport input telnet ssh
line vty 5 15
  access-class 23 in
  privilege level 15
  login local
  transport input telnet ssh
!
scheduler allocate 20000 1000
end

R1#
Aug  2 18:43:15.054: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
R1#sh int ser
R1#sh int serial 0/0/0
Serial0/0/0 is up, line protocol is down
   Hardware is GT96K with integrated T1 CSU/DSU
   Internet address is 10.160.3.66/28
   MTU 1500 bytes, BW 1536 Kbit/sec, DLY 20000 usec,
      reliability 251/255, txload 1/255, rxload 1/255
   Encapsulation PPP, LCP REQsent, loopback not set
   Keepalive set (10 sec)
   Last input 00:00:02, output 00:00:00, output hang never
   Last clearing of "show interface" counters 20:11:23
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops)
      Conversations  0/1/256 (active/max active/max total)
      Reserved Conversations 0/0 (allocated/max allocated)
      Available Bandwidth 1152 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
      381 packets input, 11428 bytes, 0 no buffer
      Received 0 broadcasts (0 IP multicasts)
      173 runts, 5 giants, 0 throttles
      290 input errors, 14 CRC, 0 frame, 89 overrun, 0 ignored, 14 abort
      773 packets output, 10822 bytes, 0 underruns
      0 output errors, 0 collisions, 2494 interface resets
      327 unknown protocol drops
      0 output buffer failures, 0 output buffers swapped out
      20 carrier transitions
      DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R1#sh ip int bri
R1#sh ip int brief
Any interface listed with OK? value "NO" does not have a valid configuration

Interface                  IP-Address      OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down   
GigabitEthernet0/0         unassigned      YES unset  down                  down   
GigabitEthernet0/1         10.110.5.1      YES manual down                  down   
Serial0/0/0                10.160.3.66     YES manual up                    down   
NVI0                       unassigned      NO  unset  up                    up     
R1#
Aug  2 18:43:43.314: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down

*********************************************************

Thank you for any help you guys can provide.

Message was edited by: willy moronta

Everyone's tags (2)
6 REPLIES
Gold

PPP T1 connection

The home made may not have everything pinned like a cisco cable.Is it a 4 wire crossover between the csu's ?

Timing on both sides should be set to line or network.

What is the far end router ?

Hall of Fame Super Gold

PPP T1 connection

There are so many errors, pointing to faulty circuit. Have telco fix, even if they claim all is fine, have them prove it's working in front of you on presemis.

New Member

PPP T1 connection

Hello, thank you for responses.

Vmiller:  The cable is a full 8 pin cross over cable made by "good union labor"   and currently works in the set up.  I'm on an end work station that is connected to the main network via the T1 connection

Both ends of the connection have same set up:

Nortel Router <-->serial <-->adtran CSU <--- > adtran CSu <----> Nortell router

[remote]  timing currently "internal                         [home] timing currently "network"

I tried to change both to be internal - as I didn't see a network option on the cisco device only a line option.

The circuit is currently in a lab environment but has worked in the past.  Ofcourse the old, if it ain't broke why fix it comes to mind.  But we'd like to start using a Cisco device in order to do other things on it which the Nortell is incapable of.

Again, thank you very much for your replies.

Hall of Fame Super Gold

PPP T1 connection


Vmiller:  The cable is a full 8 pin cross over cable made by "good union labor"   and currently works in the set up.  I'm on an end work station that is connected to the main network via the T1 connection

I have news for the union labourer, T1 cross only requires 2 pairs, or 4 pins:

https://kb.sipadvantage.com/kb_upload/image/T1%20crossover.jpg

Gold

PPP T1 connection

Ok, so this is an inhouse test circuit is it just a cable, or is the carrier involved?

If you connect a nortel where the cisco is, do things work ?

If thats true, then there is something else amiss.

How are the adtrans set up for clock ?

New Member

PPP T1 connection

Thanks guys you got me thinking on the right track.

I figured out the problems and in case anyone has to deal with old ARN here is a quick summary:

The MTU on nortell device is by default 1600 as opposed to cisco's 1500, the encapsulation is set to "default HDLC" which is nortell HDLC and not the same cisco's HDLC, regardless it needs to be the same on both ends, in this case we'll make it PPP.  I'm still seeing a small number of errors but the connection is up now.  Timing as vmiller pointed out to me needs to be the same on both sides.

I appreciate the help so far.

1477
Views
0
Helpful
6
Replies
CreatePlease to create content