Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PPP

Hello,

I have a cisco router 18XX series with 2 fastethernet ports,1 console,1 AUX. ISP has dropped 1 ethernet cable to branch office for internet connection, I want to configure a PPPOE on ethernet interface to connect to internet.

Can anybody link me to proper explanation doc's or book, for better troubleshooting and configuration.

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: PPP

You may need to configure speed and duplex on the interface.

Also

interface FastEthernet0/0
ip nat outside

is not needed. The actual interface is Dialer.

ip route 0.0.0.0 0.0.0.0 Dialer1

Also not needed. Done with ppp command.

5 REPLIES
Hall of Fame Super Gold

Re: PPP

New Member

Re: PPP

Hello bevila,

I have been to this doc before, I had configured according to the above document instead of atm interface i have 2 Ethernet interface,1 is connecting to internal network and the other I m connecting the ISP link, i want to confirm instead of ATM i have fastethernet Interface connected to ISP link,Will it work ??????

interface FastEthernet0/0
description Connected to ISP Link
no ip address
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.25

description connected to internal network
encapsulation dot1Q 25
ip address 192.168.25.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1455
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp authentication chap callin
ppp chap hostname XXXXXX
ppp chap password  XXXXXXX
ppp pap sent-username XXXXX password 0 XXXXX
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept

no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
no ip http secure-server
ip nat inside source list 110 interface Dialer1 overload

access-list 110 permit ip any any
!

dialer-list 1 protocol ip permit

Hall of Fame Super Gold

Re: PPP

That is what the document is all about.

Use:

mtu 1492
ip tcp adjust-mss 1452

not needed:

ip mtp 1492

dialer idle-timeout 0
dialer persistent
dialer-group 1

Please remember to rate useful posts clicking on the stars below.

New Member

Re: PPP

Thanks for ur reply,appreciate

1 more query,

When i connect ISP link to my router the link is up but the protocol is down no LED is blinking on router interface. But when i connect to my laptop  LAN Card the LED glows and the physical connection is UP,

Is i m missing anything in the config's.???

Thanks

Hall of Fame Super Gold

Re: PPP

You may need to configure speed and duplex on the interface.

Also

interface FastEthernet0/0
ip nat outside

is not needed. The actual interface is Dialer.

ip route 0.0.0.0 0.0.0.0 Dialer1

Also not needed. Done with ppp command.

450
Views
0
Helpful
5
Replies