cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
752
Views
5
Helpful
3
Replies

PPPoE, ADSL - authentication problem

buchynska
Level 1
Level 1

I have to set up pppoe on ADSL link. The steps are:

modem connected, pppoe, pap authentication, and the last - external ip adress from provider.

I have tried it on Cisco 871 and Cisco 806 - both tries had same error in debug log.

Here is my config and part of debug

Using 1605 out of 131072 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

no service dhcp

!

hostname burshtyn806

!

enable secret xxx

enable password xxx

!

username pbivf password xxxxx

clock timezone UKR 2

clock summer-time UKRS recurring last Sun Mar 3:00 last Sun Oct 3:00

ip subnet-zero

no ip domain lookup

!

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

interface Ethernet0

ip address 10.18.80.3 255.255.254.0

no ip route-cache

ip tcp adjust-mss 1452

no ip mroute-cache

no cdp enable

!

interface Ethernet1

no ip address

no ip route-cache

no ip mroute-cache

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

interface Dialer1

ip address negotiated

ip mtu 1492

encapsulation ppp

no ip mroute-cache

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap

ppp pap sent-username xxx@provider.net password 0 xxxxxx

ip nat inside source list 1 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

no ip http secure-server

!

access-list 1 permit 0.0.0.0 255.0.0.0

dialer-list 1 protocol ip permit

no cdp run

snmp-server community XXXXX RO

snmp-server enable traps tty

!

line con 0

exec-timeout 0 0

stopbits 1

line vty 0 4

access-class 182 in

exec-timeout 0 0

no login

transport input telnet

!

scheduler max-task-time 5000

!

end

and here is the log

PPPoE:

PPPoE protocol events debugging is on

PPPoE control packets debugging is on

PPP:

PPP protocol negotiation debugging is on

VPN:

VPDN events debugging is on

*Mar 1 20:20:43.978: Vi1 PPP: Using dialer call direction

*Mar 1 20:20:43.978: Vi1 PPP: Treating connection as a callout

*Mar 1 20:20:43.978: Vi1 PPP: Phase is ESTABLISHING, Active Open

….

*Mar 1 20:20:43.998: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

*Mar 1 20:20:44.050: Vi1 LCP: State is Open

*Mar 1 20:20:44.050: Vi1 PPP: Phase is AUTHENTICATING, by both

*Mar 1 20:20:44.054: Vi1 PAP: Using hostname from interface PAP

*Mar 1 20:20:44.054: Vi1 PAP: Using password from interface PAP

*Mar 1 20:20:44.054: Vi1 PAP: O AUTH-REQ id 1 len 35 from "myusername@provider.net"

*Mar 1 20:20:44.098: [0]PPPoE 59020: I R:0011.5c31.311b L:000a.f409.22df Et1

C0 21 05 03 00 04

*Mar 1 20:20:44.102: Vi1 LCP: I TERMREQ [Open] id 3 len 4

*Mar 1 20:20:44.102: Vi1 LCP: O TERMACK [Open] id 3 len 4

*Mar 1 20:20:44.102: Vi1 PPP: Sending Acct Event[Down] id[B9A]

*Mar 1 20:20:44.106: Vi1 PPP: Phase is TERMINATING

* ...

*Mar 1 20:20:44.158: PPPoE : Shutting down client session

*Mar 1 20:20:44.162: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1

*Mar 1 20:20:44.170: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

Please, help!

1 Accepted Solution

Accepted Solutions

Hello,

you might want to try:

ppp authentication pap callin

HTH,

GP

View solution in original post

3 Replies 3

Hello,

you might want to try:

ppp authentication pap callin

HTH,

GP

YES!!! IT WORKS, IT REALLY WORKS!!!

Thank you very much!!!

We have a very similar configuration. our only difference is , we need dial backup to work using async1. Can you help with this?

Review Cisco Networking products for a $25 gift card