Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PPPoE and NAT on WAN link of Cisco 1801 router

Does anyone know if PPPoE can be configured on the Ethernet WAN Link of my 1801 router? fa0 will obtain a IP address thru the Speedstream 5100 and the NAT overload command seems to work fine when applied to the interface. The difference is that I can't ping the SBC DNS servers from the router like I can from my workstation. I have tried moving the login to VPDN/Dialer 0 secnario as outlined in Cisco's PDF, but all of the VPDN commands are not available on my router ie "protocol pppoe" and "initiate to A.B.C.D". I'm running Version 12.3(8)YI1 IOS. Any help would be appreciated.

  • WAN Routing and Switching
2 REPLIES
New Member

Re: PPPoE and NAT on WAN link of Cisco 1801 router

Can you post your configuration?

Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)

bdennis@internetworkexpert.com

Internetwork Expert, Inc.

http://www.InternetworkExpert.com

Toll Free: 877-224-8987

Direct: 775-745-6404 (Outside the US and Canada)

New Member

Re: PPPoE and NAT on WAN link of Cisco 1801 router

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname PM1

!

boot-start-marker

boot-end-marker

!

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

!

!

ip cef

!

!

no ftp-server write-enable

!

!

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface BRI0

no ip address

shutdown

!

interface FastEthernet0

ip address dhcp

ip nat outside

duplex auto

speed auto

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

shutdown

!

interface FastEthernet3

no ip address

shutdown

!

interface FastEthernet4

no ip address

shutdown

!

interface FastEthernet5

no ip address

shutdown

!

interface FastEthernet6

no ip address

shutdown

!

interface FastEthernet7

no ip address

shutdown

!

interface FastEthernet8

no ip address

shutdown

!

interface Vlan1

ip address 192.168.67.1 255.255.255.0

ip nat inside

!

router eigrp 100

network 192.168.67.0

auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0

!

no ip http server

ip nat inside source list 2 interface FastEthernet0 overload

!

access-list 2 permit 192.168.67.0 0.0.0.255

!

control-plane

!

!

line con 0

password xxxxx

login

line aux 0

line vty 0 4

password xxxxx

login

!

no scheduler allocate

end

486
Views
0
Helpful
2
Replies