Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PPPoE configuration problem in Linux.

Hi friends,

     I am configuring PPPoE on linux. While configuration the client is not able to connect.

I am using following configurations at server side.

1. /etc/ppp/options

asyncmap 0

crtscts

lock

modem

proxyarp

lcp-echo-interval 30

lcp-echo-failure 4

2. /etc/ppp/pppoe-server-options

# PPP options for the PPPoE server

# LIC: GPL

debug

plugin /etc/ppp/plugins/rp-pppoe.so

require-pap

mtu 1492

mru 1492

ktune

proxyarp

lcp-echo-interval 10

lcp-echo-failure 2

nobsdcomp

noccp

novj

noipx

3. /etc/ppp/pap-secrects

# Secrets for authentication using PAP

# client        server  secret                  IP addresses

prem            *       prem123                 *

At client side,

1.  /etc/ppp/options

asyncmap 0

crtscts

lock

modem

proxyarp

lcp-echo-interval 30

lcp-echo-failure 4

2. /etc/ppp/pppoe.conf

ETH=eth0

USER=prem

DEMAND=no

DNSTYPE=SERVER

PEERDNS=yes

DNS1=

DNS2=

DEFAULTROUTE=yes

CONNECT_TIMEOUT=30

CONNECT_POLL=2

ACNAME=

SERVICENAME=

PING="."

CF_BASE=`basename $CONFIG`

PIDFILE="/var/run/$CF_BASE-pppoe.pid"

SYNCHRONOUS=no

CLAMPMSS=1412

LCP_INTERVAL=20

LCP_FAILURE=3

PPPOE_TIMEOUT=80

FIREWALL=NONE

LINUX_PLUGIN=/etc/ppp/plugins/rp-pppoe.so

PPPOE_EXTRA=""

PPPD_EXTRA=""

3. /etc/ppp/pap-secrets

# Secrets for authentication using PAP

# client        server  secret                  IP addresses

prem           *       prem123                  *

At client side, i  am getting error like  "/usr/sbin/pppoe-start:   line 215: 2584 Terminated     $CONNECT   "$@"   >

/dev/null 2>&!.

When  i saw at server side in /var/log/messages, i am getting Nov 17 14:35:48  localhost pppoe-server[15254]: Terminating on signal 2 -- killing all  PPPoE sessions

And at tcpdump side i am not getting any packets.

Can you tell me what might be the problem.

Regards,

Prem.    

573
Views
0
Helpful
0
Replies