Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PPPoE DSL Problems, NGI

Hello,

I'm trying to use a cisco 887VA-SEC-K9 router for a domestic PPPoE DSL (italian NGI DSL) but it doesn't work..

No problem with my domestic router.

I have another problem: I'm installing cisco-config-pro-exp-k9-2_6-en but it doesen't work. The browser requests login but then appears a blank page.

Is there anybody can help me?

Thank you very much

Fabrice

My configuration:

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname xbRouter

!

boot-start-marker

boot-end-marker

!

!

no logging buffered

!

no aaa new-model

!

memory-size iomem 10

clock timezone PCTime 1 0

clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-471455566

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-471455566

revocation-check none

rsakeypair TP-self-signed-471455566

!

!

crypto pki certificate chain TP-self-signed-471455566

certificate self-signed 01

xxx

      quit

!

!

!

!

!

ip domain name xb81

ip name-server 192.168.186.100

ip ddns update method ccp_ddns1

HTTP

  add http://x.x.x@members.dyndns.org/nic/update?system=dyndns&hostname=//x.x.x@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>

  remove http://x.x.x@members.dyndns.org/nic/update?system=dyndns&hostname=//x.x.x@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>

!

ip cef

no ipv6 cef

!

!

multilink bundle-name authenticated

license udi pid CISCO887VA-SEC-K9 sn FCZ160891N2

!

!

username ccpuser privilege 15 secret 5 $1$o0Ai$wIXcbWD4CObRNZSt.aTQA0

username fabrice privilege 15 secret 5 $1$NpO1$YvgI6Tl9rtsOV1EmfRM.v/

!

!

!

!

!

controller VDSL 0

!

no ip ftp passive

!

!

!

!

!

!

!

!

!

interface Ethernet0

description $ETH-WAN$

no ip address

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface ATM0

ip address 192.168.1.1 255.255.255.0

no atm ilmi-keepalive

pvc 8/35

  encapsulation aal5snap

!

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface Vlan1

ip address 192.168.186.191 255.255.255.0

ip access-group 100 in

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1412

!

interface Dialer1

ip ddns update hostname x.x.x

ip ddns update ccp_ddns1

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username xxx password 0 xxx

!

ip forward-protocol nd

ip http server

ip http access-class 1

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip nat inside source list 3 interface Dialer1 overload

!

access-list xxxxx

dialer-list 1 protocol ip permit

!

!

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

access-class 101 in

privilege level 15

login local

transport input telnet ssh

!

end

Everyone's tags (3)
3 REPLIES
Cisco Employee

PPPoE DSL Problems, NGI

Hello Fabrice,

After verifying your configuration, I am not sure how is your router connected to the DSL service. Is there a separate standalone DSL modem connected to your router, or are you using the built-in DSL interface in the router?

If your router is connected to the DSL service using its own DSL interface then you should remove all the PPPoE commands from the Ethernet0 interface as they are not supposed to be placed there. In addition, the PPPoE client has to be configured under the ATM interface under the appropriate VPI/VCI, so for example:

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 8/35

  encapsulation aal5snap

  pppoe-client dial-pool-number 1

Notice that even the ATM0 interface is not going to have any IP address itself. The IP address will be assigned only to the Dialer1 interface after the PPPoE session goes up. Also make sure that for your DSL connection, the ATM VPI/VCI combination of 8/35 is the correct one. This has to be consulted with your DSL service provider.

Please keep us informed!

Best regards,

Peter

New Member

PPPoE DSL Problems, NGI

Thanks Peter,

Unfortunately I still have problems: the connections is UP but it seems that is not properly nated.

can help me?

Thank you very much

Fabrice

Test Activity Details

ActivityStatus
Checking interface status... Up
Interface physical status :Up
Line protocol status :Up
Checking for DNS settings... Successful
DNS lookup set :Yes
Statically configured DNS servers : 192.168.186.100
Dynamically imported DNS servers :None
Checking interface IP address.. Successful
Interface IP address :81.174.***
Interface IP address Type :Negotiated
Checking exit interface... Failed
Exit interface found :Vlan1

My ISP require:

PPPoA (PPP over ATM) o PPPoE (PPP over Ethernet)

- Encapsulation: LLC/SNAP o MUX

- VPI: 8

- VCI: 35

My configuration:

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname xbRouter

!

boot-start-marker

boot-end-marker

!

!

no logging buffered

!

no aaa new-model

!

memory-size iomem 10

clock timezone PCTime 1 0

clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-471455566

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-471455566

revocation-check none

rsakeypair TP-self-signed-471455566

!

!

crypto pki certificate chain TP-self-signed-471455566

certificate self-signed 01

  ***

      quit

!

!

!

!

!

ip domain name xb81

ip name-server 192.168.186.100

ip ddns update method ccp_ddns1

HTTP

  add http://***@members.dyndns.org/nic/update?system=dyndns&hostname=//***@members.dyndns.org/nic/update?system=dyndns&hostname=&myip=

  remove http://***@members.dyndns.org/nic/update?system=dyndns&hostname=//***@members.dyndns.org/nic/update?system=dyndns&hostname=&myip=

!

ip cef

no ipv6 cef

!

!

multilink bundle-name authenticated

license udi pid CISCO887VA-SEC-K9 sn FCZ160891N2

!

!

username ccpuser privilege 15 secret 5 $1$o0Ai$wIXcbWD4CObRNZSt.aTQA0

username fabrice privilege 15 secret 5 $1$NpO1$YvgI6Tl9rtsOV1EmfRM.v/

!

!

!

!

!

controller VDSL 0

!

no ip ftp passive

!

!

!

!

!

!

!

!

!

interface Ethernet0

description $ETH-WAN$

no ip address

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 8/35

  encapsulation aal5snap

  pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface Vlan1

ip address 192.168.186.191 255.255.255.0

ip access-group 100 in

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1412

!

interface Dialer1

ip ddns update hostname ***

ip ddns update ccp_ddns1

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username *** password 0 ***

!

ip forward-protocol nd

ip http server

ip http access-class 1

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip nat inside source list 5 interface Dialer1 overload

!

access-list 1 permit 192.168.186.192

access-list 1 permit 192.168.186.204

access-list 1 remark Auto generated by SDM Management Access feature

access-list 1 permit 192.168.186.99

access-list 1 remark CCP_ACL Category=1

access-list 1 permit 192.168.186.100

access-list 2 remark INSIDE_IF=Vlan1

access-list 2 remark CCP_ACL Category=2

access-list 2 permit 192.168.186.0 0.0.0.255

access-list 3 remark CCP_ACL Category=2

access-list 3 permit 192.168.186.0 0.0.0.255

access-list 4 remark CCP_ACL Category=2

access-list 4 permit 192.168.186.0 0.0.0.255

access-list 5 remark CCP_ACL Category=2

access-list 5 permit 192.168.186.0 0.0.0.255

access-list 100 remark Auto generated by SDM Management Access feature

access-list 100 remark CCP_ACL Category=1

access-list 100 permit tcp host 192.168.186.100 host 192.168.186.191 eq telnet

access-list 100 permit tcp host 192.168.186.204 host 192.168.186.191 eq telnet

access-list 100 permit tcp host 192.168.186.99 host 192.168.186.191 eq telnet

access-list 100 permit tcp host 192.168.186.100 host 192.168.186.191 eq 22

access-list 100 permit tcp host 192.168.186.204 host 192.168.186.191 eq 22

access-list 100 permit tcp host 192.168.186.99 host 192.168.186.191 eq 22

access-list 100 permit tcp host 192.168.186.192 host 192.168.186.191 eq 22

access-list 100 permit tcp host 192.168.186.100 host 192.168.186.191 eq www

access-list 100 permit tcp host 192.168.186.99 host 192.168.186.191 eq www

access-list 100 permit tcp host 192.168.186.100 host 192.168.186.191 eq 443

access-list 100 permit tcp host 192.168.186.204 host 192.168.186.191 eq 443

access-list 100 permit tcp host 192.168.186.99 host 192.168.186.191 eq 443

access-list 100 permit tcp host 192.168.186.192 host 192.168.186.191 eq 443

access-list 100 permit tcp host 192.168.186.100 host 192.168.186.191 eq cmd

access-list 100 permit tcp host 192.168.186.204 host 192.168.186.191 eq cmd

access-list 100 permit tcp host 192.168.186.99 host 192.168.186.191 eq cmd

access-list 100 permit tcp host 192.168.186.192 host 192.168.186.191 eq cmd

access-list 100 deny   tcp any host 192.168.186.191 eq telnet

access-list 100 deny   tcp any host 192.168.186.191 eq 22

access-list 100 deny   tcp any host 192.168.186.191 eq www

access-list 100 deny   tcp any host 192.168.186.191 eq 443

access-list 100 deny   tcp any host 192.168.186.191 eq cmd

access-list 100 deny   udp any host 192.168.186.191 eq snmp

access-list 100 permit ip any any

access-list 101 remark Auto generated by SDM Management Access feature

access-list 101 remark CCP_ACL Category=1

access-list 101 permit ip host 192.168.186.100 any

access-list 101 permit ip host 192.168.186.204 any

access-list 101 permit ip host 192.168.186.99 any

access-list 101 permit ip host 192.168.186.192 any

dialer-list 1 protocol ip permit

!

!

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

access-class 101 in

privilege level 15

login local

transport input telnet ssh

!

end

New Member

PPPoE DSL Problems, NGI

Good morning,

I managed to solve the connection problem.

I changed the following parameters:

interface Ethernet0

no ip address

shutdown

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

pvc 8/35

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1

interface Dialer1

ip ddns update hostname xb81.dyndns.org

ip ddns update ccp_ddns1

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username 5267835949 password 0 423G2Xrd interface Dialer1
ip ddns update hostname xb81.dyndns.org
ip ddns update ccp_ddns1
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username 5267835949 password 0 423G2Xrd

1043
Views
0
Helpful
3
Replies