Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

PPPoE DSL Problems, probably MTU or MSS - ALICE

Hello,

I'm trying to use a cisco 887 router for a domestic PPPoE DSL (italian ALICE DSL).

I can ping public host but I can't surf. Only a few web site can be reached and very slowly, i checked dns and name resolution is ok.

No problem with my domestic router.

Can you please tell me a right PPPoE configuration for my router?

I tried several MTU and MSS value but without success.

(do I have to set mtu or ip mtu?).

Is there anybody can help me?

Thank you very much

Johnny


11 REPLIES
Community Member

Re: PPPoE DSL Problems, probably MTU or MSS - ALICE

My configuration is the following

interface Vlan1

mtu 1452

ip address 10.240.4.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1442

ip flow ingress

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1394

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

no atm ilmi-keepalive

pvc 8/35

  encapsulation aal5snap

  pppoe-client dial-pool-number 1

interface Dialer0

description $FW_OUTSIDE$

mtu 1442

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1394

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname aliceadsl

ppp chap password 7 155841464E60616E6279

ppp pap sent-username aliceadsl password 7 024C4E11414C456B0604

ppp ipcp dns request

Hall of Fame Super Gold

Re: PPPoE DSL Problems, probably MTU or MSS - ALICE

Configure:

interface Vlan1

default mtu

default ip mtu

ip flow ingress

ip tcp adjust-mss 1452

interface  ATM0

default ip address

default ip redirects

default ip unreachables

default ip proxy-arp

no ip flow ingress

no atm ilmi-keepalive

pvc  8/35

  encapsulation aal5snap

  pppoe-client  dial-pool-number 1

interface  Dialer0

description $FW_OUTSIDE$

mtu 1492

no ip tcp adjust-mss 1394

Community Member

Re: PPPoE DSL Problems, probably MTU or MSS - ALICE

Hi Paolo,

Thank you very much.

I can see a little number of web site, and most of allonly in the first page.

The router still doesn't work, while my domestic router works perfectly.

The value I used are the ones you suggested in the answer to my post but they don't work.

I also tried to chagnge IOS firmware without any  success.

can you help me?

Thanks

JOhnny

Hall of Fame Super Gold

Re: PPPoE DSL Problems, probably MTU or MSS - ALICE

Send complete config again after the changes.

Community Member

Re: PPPoE DSL Problems, probably MTU or MSS - ALICE

!

interface ATM0

no ip address

ip flow ingress

no atm ilmi-keepalive

pvc 8/35

  encapsulation aal5snap

  pppoe-client dial-pool-number 1

!

!

interface Vlan1

ip address 10.240.4.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip nat inside

ip inspect FW in

ip virtual-reassembly

ip tcp adjust-mss 1452

!

!

interface Dialer0

description $FW_OUTSIDE$

mtu 1492

ip address negotiated

ip flow ingress

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname aliceadsl

ppp chap password 7 155841464E60616E6279

ppp pap sent-username aliceadsl password 7 024C4E11414C456B0604

ppp ipcp dns request

!

!

dialer-list 1 protocol ip permit

Hall of Fame Super Gold

Re: PPPoE DSL Problems, probably MTU or MSS - ALICE

try:

interface vlan1

     no ip virtual-reassembly

     no ip inspect FW in

     no ip flow ingress


interface dialer0

     no ip virtual-reassembly

     no ip flow ingress

     ppp ipcp default route

And remove any other default route you may have.

Community Member

Re: PPPoE DSL Problems, probably MTU or MSS - ALICE

Thank you paolo,

in a couple of hours I'll try the new configuration.

as regards IP INSPECT FW IN i tried yesterday to disable any firewall but without any success (that configuration line is a result of the last tests).

I didn't try to remove default routes using ipcp default route and to disable ip virtual-reassembly.

Let's see tonight if it will be ok (I'm testing the configuration in my home adsl connection).

I thank you very much

Johnny

Community Member

Re: PPPoE DSL Problems, probably MTU or MSS - ALICE

It doesn't work.

I open only a few web sites, very slowly.

Ping and name resolution works correctly.

If I use the router to connect as a ezvpn client to a central site with split tunnel, I have no problem to open web internal pages (printer gui, intranet web site and so on), i can ping and dns outside but i have the same issues with web external sites.

I noticed that DSL interface ATM0 shows capacity used 100%

Hall of Fame Super Gold

Re: PPPoE DSL Problems, probably MTU or MSS - ALICE

Please post the complete configuration, only remove any public IP and password.

Community Member

Re: PPPoE DSL Problems, probably MTU or MSS - ALICE

Hi

How can Cisco releases the CCNA Discovery and Exploration documentation with full of corrections in it.  If you need proof you check my blog www.CiscoMistakes.blogspot.com. Take some necessary action. I am able to find 1 correction in 15-20 pages. Some of those are published in my blog.  If you are not concerned with the documentation please report this to the concerned team or person.

This is Satya Rao (Mr. Perfectionist), a 28 year old South Indian guy, I have been taking CCNA training from the April 19th 2010, in one of the Cisco Networking Academy named IGIAT (Indo-German Institute of Advanced Technology) in Visakhapatnam, South India.

We know how important a proper documentation for any software or hardware. It should be given one of the major importance, without proper documentation the software or hardware is useless.

While I am reading your CCNA Discovery and Exploration materials I have found some corrections in the documentation. More than 300 corrections in the module 1 and 2 of CCNA Discovery and Exploration.

My correction checking includes spelling mistakes, punctuations errors, formatting errors, technical mistakes, diagrammatic error, etc.

I don’t want anyone to point out my favorite company’s documentation. Yes ordinary people may not find all of them but they will some of them.

Microsoft Windows is a 100% correction less documentation. I have studied lots of their documentation and unable to find not even a single correction, why not Cisco develops that kind of correction free, documentation to the world. Yes, it’s possible with me, the Mr. Perfectionist.

Please give me a chance to make it 100% correction less, yes the documentation is 99.999% good. But not 100%. Why should we take chance when Mr. Perfectionist is available?

Of course small punctuation corrections are not so big in terms of technical issues, but the high quality documentation must need everything to be high.

We all know that how many times it was checked before finalizing the documentation but still I found these many corrections.

If you want to test my talent or capacity give me your latest finalized version of any technical documentation and let me found the corrections in that documentation. You came to know how fast I will give you the 100% correction less out put.

Just imagine I have found these many corrections after you people done all kinds of proofreading before releasing to the world, how much useful I will be if I am in your documentation department.

I think you know, how hard it is find mistakes from a very great companies documentation like Cisco, (if not hard you would have released it 100% correction free to the world) not 5 or 10, I have found hundreds (still finding). If you really understand my talent you must give me a quality analyst job in documentation.

I know there are no vacancies but a person like me you should place me, to get better output, as the quality analysts there, unable to give the 100% quality.

I am ready to sign any kind of bond you wish.

You can fire me out at any time if you not satisfied with my work.

One of my weak point is I can’t tolerate if something is wrong or someone doing wrong. With this weak point I can easily find out mistakes in any documentation with ease at the maximum speed possible, which a computer can’t do.

Please someone recognize my work and effort and help me by providing a job with minimum possible pay. Willing to work 12 hrs a day at any time of the day.

I was worked as a proof reader in a medical transcription company for John F Kennedy hospital of California for one year.

I can give you results more than you expect from me.

Most importantly I need a job in my favorite company, Cisco. Willing to work from home too.

I think its not a big problem for a big company to give a job to a boy whose father died at his age 5.

Please give me one opportunity to prove myself.

If you came to know about this blog through an email, please forward the mail to the concerned person in the concerned department would be appreciated. (If not, humans help the humans who, will help the human kind.)

Thank you very much.

Satya Rao

Mobile: 919290286822

Email: satyarao321@gmail.com

I have created one blog with some of those correction please check it.

http://ciscomistakes.blogspot.com/

http://CiscoMistakes.blogspot.com/

I have not created this blog to generate some revenue, some popularity, or to point out the Cisco's mistakes to downgrade its standards. I just want to be one in the Cisco organization technical documentation team, for correction free documentation.

Community Member

Re: PPPoE DSL Problems, probably MTU or MSS - ALICE

Hi

How can Cisco releases the CCNA Discovery and Exploration documentation with full of corrections in it.  If you need proof you check my blog www.CiscoMistakes.blogspot.com. Take some necessary action. I am able to find 1 correction in 15-20 pages. Some of those are published in my blog.  If you are not concerned with the documentation please report this to the concerned team or person.

This is Satya Rao (Mr. Perfectionist), a 28 year old South Indian guy, I have been taking CCNA training from the April 19th 2010, in one of the Cisco Networking Academy named IGIAT (Indo-German Institute of Advanced Technology) in Visakhapatnam, South India.

We know how important a proper documentation for any software or hardware. It should be given one of the major importance, without proper documentation the software or hardware is useless.

While I am reading your CCNA Discovery and Exploration materials I have found some corrections in the documentation. More than 300 corrections in the module 1 and 2 of CCNA Discovery and Exploration.

My correction checking includes spelling mistakes, punctuations errors, formatting errors, technical mistakes, diagrammatic error, etc.

I don’t want anyone to point out my favorite company’s documentation. Yes ordinary people may not find all of them but they will some of them.

Microsoft Windows is a 100% correction less documentation. I have studied lots of their documentation and unable to find not even a single correction, why not Cisco develops that kind of correction free, documentation to the world. Yes, it’s possible with me, the Mr. Perfectionist.

Please give me a chance to make it 100% correction less, yes the documentation is 99.999% good. But not 100%. Why should we take chance when Mr. Perfectionist is available?

Of course small punctuation corrections are not so big in terms of technical issues, but the high quality documentation must need everything to be high.

We all know that how many times it was checked before finalizing the documentation but still I found these many corrections.

If you want to test my talent or capacity give me your latest finalized version of any technical documentation and let me found the corrections in that documentation. You came to know how fast I will give you the 100% correction less out put.

Just imagine I have found these many corrections after you people done all kinds of proofreading before releasing to the world, how much useful I will be if I am in your documentation department.

I think you know, how hard it is find mistakes from a very great companies documentation like Cisco, (if not hard you would have released it 100% correction free to the world) not 5 or 10, I have found hundreds (still finding). If you really understand my talent you must give me a quality analyst job in documentation.

I know there are no vacancies but a person like me you should place me, to get better output, as the quality analysts there, unable to give the 100% quality.

I am ready to sign any kind of bond you wish.

You can fire me out at any time if you not satisfied with my work.

One of my weak point is I can’t tolerate if something is wrong or someone doing wrong. With this weak point I can easily find out mistakes in any documentation with ease at the maximum speed possible, which a computer can’t do.

Please someone recognize my work and effort and help me by providing a job with minimum possible pay. Willing to work 12 hrs a day at any time of the day.

I was worked as a proof reader in a medical transcription company for John F Kennedy hospital of California for one year.

I can give you results more than you expect from me.

Most importantly I need a job in my favorite company, Cisco. Willing to work from home too.

I think its not a big problem for a big company to give a job to a boy whose father died at his age 5.

Please give me one opportunity to prove myself.

If you came to know about this blog through an email, please forward the mail to the concerned person in the concerned department would be appreciated. (If not, humans help the humans who, will help the human kind.)

Thank you very much.

Satya Rao

Mobile: 919290286822

Email: satyarao321@gmail.com

I have created one blog with some of those correction please check it.

http://ciscomistakes.blogspot.com/

http://CiscoMistakes.blogspot.com/

I have not created this blog to generate some revenue, some popularity, or to point out the Cisco's mistakes to downgrade its standards. I just want to be one in the Cisco organization technical documentation team, for correction free documentation.

2926
Views
0
Helpful
11
Replies
CreatePlease to create content