Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

PPPoE issue on 2801

I have a new 2801 that uses both a T1 via S 0/2/0 and a DSL modem in transparent bridge mode via FE 0/1. The T1 works fine, however I can't get any packets to go out the DSL interface. FE 0/1 is configured to use a PPPoE connection, and it appears to be up and have an ip, however if I try to send packets out that interface, nothing goes out. I've tried by using a policy route-map and also by simply changing the default route to point to that interface.

I know the interface is up from show interfaces Dialer 1. Any ideas on why I can't send/receive packets through this interface?

Here is the config:

router#show run

Building configuration...

Current configuration : 4753 bytes

!

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

boot-start-marker

boot system flash c2801-ipbasek9-mz.124-8.bin

boot-end-marker

!

security authentication failure rate 3 log

security passwords min-length 6

logging buffered 51200 debugging

logging console critical

enable secret xxx

!

no aaa new-model

!

resource policy

!

clock timezone MDT -7

clock summer-time MDT date Apr 6 2003 2:00 Oct 26 2003 2:00

no ip source-route

ip cef

!

!

ip tcp synwait-time 10

!

!

no ip bootp server

ip name-server 198.x.x.2

ip name-server 198.x.x.22

!

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ES_LAN$$FW_INSIDE$

ip address 199.104.x.x.255.255.240

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/1

description $FW_OUTSIDE$$ETH-LAN$

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no ip mroute-cache

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

no mop enabled

!

interface FastEthernet0/1/0

!

interface FastEthernet0/1/1

!

interface FastEthernet0/1/2

!

interface FastEthernet0/1/3

!

interface Serial0/2/0

ip address 204.228.x.x.255.255.252

!

interface Vlan1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip flow egress

ip route-cache flow

!

interface Dialer1

description Qwest DSL

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp pap sent-username username password 7 password

!

ip route 0.0.0.0 0.0.x.x.228.133.45

!

no ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

logging trap debugging

access-list 111 permit tcp any any eq www

no cdp run

route-map toDSL permit 1

match ip address 111

set interface Dialer1

!

!

control-plane

!

banner login ^CAuthorized access only!

Disconnect IMMEDIATELY if you are not an authorized user!^C

!

line con 0

password xxx

login

line aux 0

password xxx

login

line vty 0 4

exec-timeout 30 0

privilege level 15

login local

transport input ssh

line vty 5 15

privilege level 15

login local

transport input ssh

!

scheduler allocate 20000 1000

ntp clock-period 17178103

ntp update-calendar

ntp server 198.60.22.240 source Serial0/2/0

end

3 REPLIES
VIP Purple

Re: PPPoE issue on 2801

Hello,

I have made a couple of additions/amendments to your config, can you implement those and check if it makes a difference ? Changes are marked with an arrow -->

Current configuration : 4753 bytes

!

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

boot-start-marker

boot system flash c2801-ipbasek9-mz.124-8.bin

boot-end-marker

!

security authentication failure rate 3 log

security passwords min-length 6

logging buffered 51200 debugging

logging console critical

enable secret 5 $1$EWDt$pvWzeNhilneb/EUJosxlv0

!

no aaa new-model

!

resource policy

!

clock timezone MDT -7

clock summer-time MDT date Apr 6 2003 2:00 Oct 26 2003 2:00

no ip source-route

ip cef

!

!

ip tcp synwait-time 10

!

!

no ip bootp server

ip name-server 198.60.22.2

ip name-server 198.60.22.22

!

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ES_LAN$$FW_INSIDE$

ip address 199.104.124.210 255.255.255.240

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/1

description $FW_OUTSIDE$$ETH-LAN$

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no ip mroute-cache

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

no mop enabled

!

interface FastEthernet0/1/0

!

interface FastEthernet0/1/1

!

interface FastEthernet0/1/2

!

interface FastEthernet0/1/3

!

interface Serial0/2/0

ip address 204.228.133.46 255.255.255.252

!

interface Vlan1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip flow egress

ip route-cache flow

!

interface Dialer1

description Qwest DSL

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

--> ppp authentication pap callin

ppp pap sent-username username password 7 password

!

--> ip route 0.0.0.0 0.0.0.0 Dialer1

--> dialer-list 1 protocol ip permit

!

no ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

logging trap debugging

access-list 111 permit tcp any any eq www

no cdp run

route-map toDSL permit 1

match ip address 111

set interface Dialer1

!

!

control-plane

!

banner login ^CAuthorized access only!

Disconnect IMMEDIATELY if you are not an authorized user!^C

!

line con 0

password 7 05280E16255E41594F

login

line aux 0

password 7 106D010001051D5B5A

login

line vty 0 4

exec-timeout 30 0

privilege level 15

login local

transport input ssh

line vty 5 15

privilege level 15

login local

transport input ssh

!

scheduler allocate 20000 1000

ntp clock-period 17178103

ntp update-calendar

ntp server 198.60.22.240 source Serial0/2/0

end

HTH,

GP

New Member

Re: PPPoE issue on 2801

GP, I applied the changes you suggested, yet still can't get any traffic via the PPPoE connection.

I can ping and traceroute from the router to anywhere with the default route set to Dialer1 (the DSL), or S 0/2/0 (T1).

But from any device connected either directly to the router or on the other side of the firewall, all traffic stops as soon as I set the default route to Dialer1.

I know the PPPoE is up via show ip interface Dialer 1.

I opened a case with Cisco about this. They said it was my firewall, however, I connected a laptop direct to FE 0/0 (where the firewall normally connects) and set the default route to the DSL (Dialer1). I could ping anything inside the router, but not past it.

New Member

Re: PPPoE issue on 2801

I also tried the MTU adjust fix as per this Cisco doc:

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_fix/826/swg/advconf.htm#wp1097132

"If a Cisco router terminates the PPPoE traffic, a computer connected to the Ethernet interface may have problems accessing websites. The solution is to manually reduce the maximum transmission unit (MTU) configured on the computer by constraining the TCP maximum segment size (MSS). Enter the following command on the router's Ethernet 0 interface:

ip tcp adjust-mss mss

where mss is 1452 or less. "

It didn't resolve the issue.

676
Views
0
Helpful
3
Replies
CreatePlease to create content