Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PPPoE on an 871 help

I am trying to set up an 871 router to connect to DSL over PPPoE. As far as I can tell, it is set up correctly, but it doesn't look like it is negotiating properly. I have attached the config as well as the output from the debug ppp negotiation.

Am I missing something in the cofiguration? I am not real familiar with DSL.

Thanks

5 REPLIES

Re: PPPoE on an 871 help

why i cant see any NAT deployment

and also why u configure chap and pap

use one

New Member

Re: PPPoE on an 871 help

I am not worried about NAT, I can add that once I get the DSL up and running. I configured both PAP and CHAP as I don't know which one Bell South uses, and the tech support person I spoke with couldn't tell me.

Re: PPPoE on an 871 help

this is a sample config use it as refrence

CPE!ip dhcppool MyPool

network 10.0.0.0 255.0.0.0

default-router 10.0.0.1

!

interface Ethernet0/1

no ip address

pppoe enable

pppoe-client dial-pool-number 1

!

interface Ethernet0/0

ip address 10.0.0.1 255.0.0.0

ip nat inside

!

interface Dialer0

ip address negotiated

encapsulation ppp

dialer pool 1

ip mtu 1492

ip nat outside

ppp authentication chap callin

pppchap password mysecret

!

ip nat inside source list 101 interface Dialer0 overload

access-list 101 permit ip 10.0.0.0 0.255.255.255 any

!

ip route 0.0.0.0 0.0.0.0Dialer0

rate if helpful

Re: PPPoE on an 871 help

interface Dialer1

no ip address x.x.x.x 255.255.255.248

ip address negotiated

no ppp authentication chap pap callin

ppp authentication chap callin

ppp chap hostname username@bellsouth.net

ppp chap password password

no ppp pap sent-username username@bellsouth.net password password

no ip route 0.0.0.0 0.0.0.0 74.165.50.205

no ip route 0.0.0.0 0.0.0.0 68.213.6.193

ip route 0.0.0.0 0.0.0.0 Dialer1

and show again

deb ppp neg

deb ppp auth

New Member

Re: PPPoE on an 871 help

Do you know if it worked?

140
Views
0
Helpful
5
Replies