Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PPPoE over L2TPv3

Hi;

we have two routers connected directly to each other through E1 link, first router is 2811 router and the second one is 7200 router.

since 2811 router as I know, is not supporting pppoe server only client; so we need to terminate whatever pppoe packates coming via the fa of the 2811 router in the fa of the 7200 router.

To do this so; I have configured L2TPv3 in the two router and Xconnect in the fa of each router.

the L2TPv3 tunnel is up and established but the pppoe traffic is not being sent to the 7200 router or may be it is sent but not terminated.

Regards,

aalhousani

2 ACCEPTED SOLUTIONS

Accepted Solutions
Silver

Re: PPPoE over L2TPv3

Yes thts right.....guess its a bit late for this ? Anyways how did it go ?

Silver

Re: PPPoE over L2TPv3

Well say you want to terminate 3 L2Tp sessions on E0/1 and connect it back-to-back to E0/2.

Create sub interfaces like this

e0/1.1

encapsulation dot1q 100

xconnect to L2TPv3 peer

e0/1.2

encapsulation dot1q 200

xconnect to L2TPv3 peer

Pls note that at the remote end too you should terminate L2TPv3 on a subinterface.

E0/2.1

encapsulation dot1q 100

pppoe enable

E0/2.2

encapsulation dot1q 200

pppoe enable

16 REPLIES
Silver

Re: PPPoE over L2TPv3

Could you please provide the config. of both routers ?

New Member

Re: PPPoE over L2TPv3

Hello Jak;

the 2811 router configuration is:-

pseudowire-class fah-test

encapsulation l2tpv3

ip local interface Serial0/0/0

!

interface FastEthernet0/0

no ip address

no ip mroute-cache

duplex auto

speed auto

pppoe enable group global

no cdp enable

xconnect 195.229.243.198 123 pw-class fah-test

!

interface Serial0/0/0

ip address 195.229.243.170 255.255.255.252

no ip mroute-cache

no fair-queue

no cdp enable

!

The 7200 router configuration is:

vpdn enable

!

vpdn-group 1

!

!

pseudowire-class fah-test

encapsulation l2tpv3

ip local interface POS2/0

!

interface Serial1/0

ip address 195.229.243.169 255.255.255.252

serial restart-delay 0

no cdp enable

!

interface POS2/0

description FAH/IWAN-NAD/POP VC4S02

ip address 195.229.243.198 255.255.255.252

encapsulation ppp

ip ospf message-digest-key 1 md5

ip ospf cost 128

crc 32

!

interface Ethernet3/0

no ip address

no ip mroute-cache

duplex full

pppoe enable group global

xconnect 195.229.243.170 123 pw-class fah-test

!

interface Virtual-Template1

mtu 1492

ip address 217.284.198.129 255.255.255.128

peer default ip address pool Test

ppp authentication pap

!

ip local pool Test 217.284.198.130 217.284.198.140

!

bba-group pppoe global

virtual-template 1

!

Silver

Re: PPPoE over L2TPv3

You may need to xconnect on one FE and terminate the PPPoE on another FE. You cannot terminate the PPPoE on the same interface where the xconnect is present. You could probably connect both the FEs with a crossover

New Member

Re: PPPoE over L2TPv3

Hi attraqutam;

So, you mean to not enable pppoe in the xconnect interfaces in either 2811 nor 7200 routers, but enable pppoe in differnet ethernet in 7200 and cross connect the xconnect and pppoe ethernets in 7200...

Good I will will try that and come back to you.

Silver

Re: PPPoE over L2TPv3

Yes thts right.....guess its a bit late for this ? Anyways how did it go ?

New Member

Re: PPPoE over L2TPv3

Hello,

It is work fine as per your recomandation...

if it is possible to terminate more than one L2TPv3 tunnels in the same interface of the router (by using the subinterfaces) coming from different sources? And then cross connect this interface with another interface in the same router and terminate the pppoe for all L2TPv3 tunnels?

I have tried that but the xconnect is not configurable in the subinterface!

Attached is the show version...

Regards,

Ahmed Al Housani

Silver

Re: PPPoE over L2TPv3

Is it supporting encapsulation dot1q in the subinterface ? I think it may be interface limitation.

New Member

Re: PPPoE over L2TPv3

Thanks;

can you explain more, please?

If that what you mean:-

router(config)#int e3/0.1

router(config-subif)#

router(config-subif)#

router(config-subif)#

router(config-subif)#en

router(config-subif)#encapsulation ?

dot1Q IEEE 802.1Q Virtual LAN

router(config-subif)#encapsulation do

router(config-subif)#encapsulation dot1Q

% Incomplete command.

router(config-subif)#encapsulation dot1Q ?

<1-4094> IEEE 802.1Q VLAN ID

router(config-subif)#encapsulation dot1Q

Silver

Re: PPPoE over L2TPv3

Well say you want to terminate 3 L2Tp sessions on E0/1 and connect it back-to-back to E0/2.

Create sub interfaces like this

e0/1.1

encapsulation dot1q 100

xconnect to L2TPv3 peer

e0/1.2

encapsulation dot1q 200

xconnect to L2TPv3 peer

Pls note that at the remote end too you should terminate L2TPv3 on a subinterface.

E0/2.1

encapsulation dot1q 100

pppoe enable

E0/2.2

encapsulation dot1q 200

pppoe enable

New Member

Re: PPPoE over L2TPv3

Thank you very much attrqautam,

The issue I was configuring the xconnect in the e3/0 interface then when I come to configure the same in the subinterface 3/0.1 it will not take it (:

New Member

Re: PPPoE over L2TPv3

Dear Gautam Attravanam,

I have configure the L2TPv3 in the subinterfaces in both router and the L2TPv3 tunnels comes up.

But when I cross connect the subinterface to another interface and configure PPPoE there, It is glitches to terminate PPPoE traffic.

In the 7200 Router:-

=====================

interface Ethernet3/0

no ip address

no ip mroute-cache

duplex full

no cdp enable

!

interface Ethernet3/0.1

encapsulation dot1Q 100

no cdp enable

xconnect 200.229.200.166 123 pw-class fah-test

!

interface Ethernet3/3

no ip address

duplex full

no cdp enable

!

interface Ethernet3/3.1

encapsulation dot1Q 100

pppoe enable group global

In the 2811 router (where the client is initiating the pppoe traffic):-

=====================

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$

no ip address

no ip mroute-cache

duplex auto

speed auto

no cdp enable

!

interface FastEthernet0/0.1

encapsulation dot1Q 100

no cdp enable

xconnect 200.229.200.174 123 pw-class fah-test

Thanks and appriciate your fast respond.

Silver

Re: PPPoE over L2TPv3

Are you getting any specific error messages ?

Also hope this link may help you with the config

http://www.cisco.com/en/US/products/sw/iosswrel/ps1834/products_feature_guide09186a0080080386.html

New Member

Re: PPPoE over L2TPv3

no errors messages..

by going through the link, I found that pppoe must be configured in the vdpn group!

the issue is when I upgrde the router to have L2TP feature, the pppoe in the new IOS is not configurable in the vpdn-group but in the bba-group.

Did you think this may cuase the issue?

Silver

Re: PPPoE over L2TPv3

Is it possible to give the entire PPPoE configuration ? Also is this configuration working when configured on the main interface instead of the sub-interface. Also does creating separate bba groups help instead of using the global group

New Member

Re: PPPoE over L2TPv3

Sure find below is the pppoe configureation (it is configured only in the 7200 router).

vpdn enable

!

vpdn-group 1

!

bba-group pppoe global

virtual-template 1

!

interface Ethernet3/3.1

encapsulation dot1Q 100

pppoe enable group global

!

interface Virtual-Template1

mtu 1492

ip address 200.164.200.129 255.255.255.128

peer default ip address pool Test

ppp authentication pap

!

ip local pool Test 200.164.200.130 200.164.200.140

Note the following:-

1) under the vpdn-group (dialin), I can't configure protocol pppoe.

2) It is not possible to configure prorocol pppoe under the subinterface.

3) Yes it was working when configered in the main interface but when also the L2TPv3 is configured in the main interface.

4) regarding creating seperate bba group, I don't try it.

Thanks.

New Member

Re: PPPoE over L2TPv3

Hello,

Did you think the IOS maybe cuasing this issue? where I am running 12.4(10) in the router.

Refrence to the link you posted; the pppoe was configured under the vpdn-group where in this IOS pppoe is configured under bba-group!

744
Views
0
Helpful
16
Replies