Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

PPPoE Service Tagg Null

Hy,

I configured pppoe server on cisco 3845 router.

When i try to connect with pppoe client the connection not made.

On the router, debug pppoe packets, show me this message:

Service tag: NULL Tag

Why?

Thanks

7 REPLIES
Cisco Employee

Re: PPPoE Service Tagg Null

Hello,

Please post the entire PPPoE session debug and also please post the configuration of your interfaces that are related to the PPPoE (the physical interface and the Dialer interface).

Thanks!

Best regards,

Peter

Community Member

Re: PPPoE Service Tagg Null

Thanks Peter

This is my router configuration

#########################################

aaa new-model

!

!

aaa authentication login default local

aaa authentication ppp default local

aaa authorization network default local

aaa accounting network default none

!

ip dhcp pool ADSL-Pots

network 192.168.200.0 255.255.255.0

default-router 192.168.200.1

!

vpdn enable

!

vpdn-group 1

! Default L2TP VPDN group

accept-dialin

protocol pppoe

!

username adsl password 7 1416161800

!

bba-group pppoe global

virtual-template 1

!

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/0.200

encapsulation dot1Q 200

ip address 192.168.200.1 255.255.255.0

pppoe enable group global

!

interface Virtual-Template1

mtu 1492

ip unnumbered GigabitEthernet0/0.200

peer default ip address dhcp-pool ADSL-Pots

ppp authentication pap

!

#####################################

I want to mention that pppoe client (Zyxel P-2602-RL-D1A)connect to pppoe server (Cisco3845) through adsl line and

Zyxel IPDSLAM.

debug pppoe packets output:

#######################################

*Sep 3 13:45:00.434: PPPoE 0: I PADI R:0002.cfad.ec40 L:ffff.ffff.ffff 200 Gi0/0.200

FF FF FF FF FF FF 00 02 CF AD EC 40 81 00 00 C8

88 63 11 09 00 00 00 0C 01 01 00 00 01 03 00 04 ...

*Sep 3 13:45:00.434: PPPoE 0: O PADO, R:0023.5e92.4d70 L:0002.cfad.ec40 200 Gi0/0.200

*Sep 3 13:45:00.434: Service tag: NULL Tag

00 02 CF AD EC 40 00 23 5E 92 4D 70 81 00 00 C8

88 63 11 07 00 00 00 31 01 01 00 00 01 03 00 04 ...

*Sep 3 13:45:02.434: PPPoE 0: I PADI R:0002.cfad.ec40 L:ffff.ffff.ffff 200 Gi0/0.200

FF FF FF FF FF FF 00 02 CF AD EC 40 81 00 00 C8

88 63 11 09 00 00 00 0C 01 01 00 00 01 03 00 04 ...

*Sep 3 13:45:02.434: PPPoE 0: O PADO, R:0023.5e92.4d70 L:0002.cfad.ec40 200 Gi0/0.200

*Sep 3 13:45:02.434: Service tag: NULL Tag

00 02 CF AD EC 40 00 23 5E 92 4D 70 81 00 00 C8

88 63 11 07 00 00 00 31 01 01 00 00 01 03 00 04 ...

*Sep 3 13:45:06.434: PPPoE 0: I PADI R:0002.cfad.ec40 L:ffff.ffff.ffff 200 Gi0/0.200

FF FF FF FF FF FF 00 02 CF AD EC 40 81 00 00 C8

88 63 11 09 00 00 00 0C 01 01 00 00 01 03 00 04 ...

*Sep 3 13:45:06.434: PPPoE 0: O PADO, R:0023.5e92.4d70 L:0002.cfad.ec40 200 Gi0/0.200

*Sep 3 13:45:06.434: Service tag: NULL Tag

00 02 CF AD EC 40 00 23 5E 92 4D 70 81 00 00 C8

88 63 11 07 00 00 00 31 01 01 00 00 01 03 00 04 ...

######################################

Best regards

Cisco Employee

Re: PPPoE Service Tagg Null

Hello,

Thank you for the additional information. Your configuration appears to be OK, I have tried it with minimal changes on my routers and I got it running on the first attempt.

Don't be worried about the NULL Tag now - it is not the cause of your problem.

The debug does show something anomalous, though. As you can see, the ADSL router sends you the packet which starts the PPPoE session - the PADI packet (PPPoE Active Discovery Initiation). Your router receives it and responds with a PADO packet (PPPoE Active Discovery Offer), exactly as it should. However, the remote end does not appear to receive or accept the PADO, and again sends the PADI.

To me, it seems that either your PADO packets do not reach the ADSL router or they are not accepted by it. You should direct your diagnostics in this direction. Is there any way to monitor the PPPoE process on the ADSL router?

Best regards,

Peter

Community Member

Re: PPPoE Service Tagg Null

Hello Peter,

After several attempts pppoe client (adsl router) connect to pppoe server (C3845)and analog phone register to Cisco Call Manager as SIP Phone, but SIP phone registration takes 40 seconds.

I don't know why the connection is broken?

This is my network.

analogic phone ---> adsl router ------> IPDSLAM ---> C3560 ---> C3845

C3560 <--- Cisco Call Manager

I attached debug pppoe packets logs on C3845 router.

I check next week if adsl router keeps some pppoe logs.

Thanks Peter.

Best regards.

Cisco Employee

Re: PPPoE Service Tagg Null

Hello Ioan,

The recent debugs you have attached appear to be quite normal - no indication of a problem. There are two disconnections recorded in the debug - did you explicitely request the router to terminate the PPPoE session, or did the session terminate on its own?

The instability and the slowness of the entire PPPoE session somewhat puzzles me. When the ADSL router connects, can you make a couple of basic connectivity tests just to see if there are no transmission errors on the DSL line? Try running a long ping, transfer a file, simply create a bidirectional load on the DSL link and see if there are any errors on the ADSL router or on the DSLAM port.

If you have a free router available that supports PPPoE on its Ethernet port, you could also try connecting it to the C3560 and configuring it as a PPPoE client. This way you could narrow down if the problems are on the C3560 down to your C3845, or if the probles more probably lies in the DSL part.

Best regards,

Peter

Cisco Employee

Re: PPPoE Service Tagg Null

Hello Ioan,

Have you been able to proceed in solving your issue?

Best regards,

Peter

Community Member

Re: PPPoE Service Tagg Null

Hello all, i would like to ask whatsthe confiuration for cisco 3845 router, my set up is DSL Modem> Cisco3845>PC, my internet is Static but it need to dial a username and password, but i cant seem to make it work, been doin it for almost 2 weeks now but i still dont get internet access hope to hear from you soon, im new at configurin this routers and i dont know if im doing the right codes for it, sorry to bother you all, have a reat day

1191
Views
0
Helpful
7
Replies
CreatePlease to create content