Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PPPoE with an 1841

This one has got me stumped, i hope someone out there can help.

We have an 1841 with 2 x Fast Ethernet interfaces running IOS 12.4. We currenlty connect to the internet via a wireless link through this router on one of its Fast Ethernet interfaces. Behind this router we have 2 x 1721 routers segmenting the network further. The ISP has recently provided us with a new wireless connection that requires us to use PPPoE. I have adjusted the 1841 config and tested it, DNS resolution still works OK, I can still send and receive e-mail between our MS Exchange server and my webmail account with the ISP, finally, I can get to some websites, in particular those hosted here in New Zealand. However many other websites are no longer accessible, especially international websites. Here is the section of the config setup for PPPoE:

interface Null0

no ip unreachables

!

interface FastEthernet0/0

description $ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ETH-LAN$$FW_OUTSIDE$

no ip address

no ip redirects

no ip unreachables

ip virtual-reassembly

no ip route-cache cef

no ip route-cache

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

no mop enabled

!

interface FastEthernet0/1

description $ETH-LAN$$FW_INSIDE$

ip address 192.168.7.1 255.255.255.0

ip access-group 106 in

no ip unreachables

ip nat inside

ip virtual-reassembly

no ip route-cache cef

no ip route-cache

duplex auto

speed auto

no cdp enable

no mop enabled

!

interface Dialer1

ip address negotiated

ip access-group 103 in

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

no cdp enable

ppp authentication chap callin

ppp chap hostname REMOVED

ppp chap password 7 REMOVED

There are no problems routing to the internet with the previous wireless link. The problems occur after I make the changes. Please help as I really need to get this sorted out?

8 REPLIES
Silver

Re: PPPoE with an 1841

have you a default route 0.0.0.0 0.0.0.0 that goes via the outside interface?

can you add a diagram to understand more?

New Member

Re: PPPoE with an 1841

The default route i am using is:

ip route 0.0.0.0 0.0.0.0 Dialer1

My test computer is on the 192.168.7.x network, the same network as the LAN interface of this router, i am bypassing the proxy server and going stright through the router (configured as the PCs default gateway).

Some websites are accessible, particularly local New Zealand ones. Others, particularly international sites are not.

Hall of Fame Super Silver

Re: PPPoE with an 1841

Hello Trevor,

the problem you describe points to a problem of routing of your public address.

If you have had MTU problems that were the first I thought of, you should be able to access some sites , some other slowly, some other could stuck but with no geographic correlation.

Try to use a looking glass that you can find here for different countries:

www.traceroute.org

to check if your public address is known outside New Zeland.

Your provider could have just got the address block or other issue.

OR reduce the ip mtu also on the internal LAN side just to verify it is not an MTU issue.

This is something more likely then what I suggested above.

Hope to help

Giuseppe

New Member

Re: PPPoE with an 1841

Great thanks for that. I will try in the morning.

Another thing i found is:

ip tcp adjust-mss 1452

Should i use this on the fast Ethernet LAN interface?

Hall of Fame Super Silver

Re: PPPoE with an 1841

Hello Trevor,

I would simply reduce the ip mtu on the LAN interface to make a test to understand if there is any MTU issue with new setup

use

int f0/0

ip mtu 1450

(just for a test)

Hope to help

Giuseppe

New Member

Re: PPPoE with an 1841

Hi Giuseppe,

I had already tried ip tcp adjust-mss 1452 on int fa0/0 before i received your last message.

Early indications are good in that internet access appears to be reliable now that i have made this change.

Do you think i should change the MTU size also?

Cheers,

Trev

Hall of Fame Super Silver

Re: PPPoE with an 1841

Hello Trevor,

it was a suggestion for a test but your tests with ip tcp adjust-mss 1452 have proven effective.

You have fixed it and so I wouldn't make other changes for the moment.

I just don't understand why the issue was more present on international web sites.

Hope to help

Giuseppe

New Member

Re: PPPoE with an 1841

Sure, thanks.

I too am confused why it affected international sites mostly.

Anyway, all is good so far. Thank you for your help.

Cheers,

Trev

343
Views
4
Helpful
8
Replies
CreatePlease login to create content