Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

PPPOE with SBC and Cisco 1721

Hi,

I have a 1721 with an ADSL WIC and a 4-port switch. I have it configured and it is connecting to SBC but I'm confused as to the ethernet ports. SBC gives me 5 static IPs. I use one for the Dialer interface. Do I use one for E0, another for E1, etc? Or do I set up DHCP within a VLAN?

Any pointers would be great. The current config is below.

Thanks,

Jon

Router#show run

Building configuration...

Current configuration : 1364 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.0.1

!

ip dhcp pool napa_dhcp

network 192.168.0.0 255.255.255.0

default-router 192.168.0.1

dns-server 206.13.28.12 206.13.31.12

!

!

ip cef

vpdn enable

!

!

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/35

pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

speed auto

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface Vlan1

no ip address

!

interface Dialer1

mtu 1492

ip address SOME.I.P.ADDRESS 255.255.255.248

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

ppp chap hostname HOSTNAME

ppp chap password 0 PASSWORD

ppp pap sent-username USERNAME password 0 PASSWORD

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

!

!

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

!

end

3 REPLIES

Re: PPPOE with SBC and Cisco 1721

You can use the remaining four either as part of a NAT pool or for making static mappings between public and private ip addresses (say for web, mail access from internet to the inside). On E0 and E1 (if required) you can use RFC 1918 addresses (private space) and then have those addresses nat overload on the dialer interface ip address.

You can use DHCP to assign private addreses on e0 and e1.

HTH

PS: Please remember to rate helpful replies!

Community Member

Re: PPPOE with SBC and Cisco 1721

OK. For now, all I want to do is be able for the server on the inside of the net to talk to a server on the outside. So I'm thinking add FE1 as part of the NAT pool.

Any pointers for making static mappings between public and private ip addresses? I've never done that before.

Thanks for your help here! It's made a difference.

Jon

Re: PPPOE with SBC and Cisco 1721

hi

Below mentioned syntax is being used to map the local ip to the global ip (static NAT)

ip nat inside source static

--------------------------------------------------

ip nat inside source static { tcp | udp }

Above mentioned command maps based on the PORT No.This is very much vital coz using one public ip u can map to different services hosted on different ports..

ip nat inside source static tcp 192.168.10.1 25 171.69.232.209 25

in the above statement we are mapping only the tcp port of local server to the global address

regds

234
Views
5
Helpful
3
Replies
CreatePlease to create content