Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

PPPoE

we are having cisco 1841 router and we need to implement PPPoE with dynamic ip address from ISP, into this router, could some one please give details configuration and debugging to get us connected to the internet. thank you

1 REPLY

Re: PPPoE

Try this.

interface Ethernet1

description $FW_OUTSIDE$$ETH-WAN$

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

duplex auto

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

!

interface Dialer1

ip address dhcp

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname USERNAME

ppp chap password PASSWORD

ppp pap sent-username USERNAME password PASSWORD

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip nat inside source list 1 interface Dialer1 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

HTH - Please rate if it does.

Regards

Stephen

========================== http://www.rconfig.com A free, open source network device configuration management tool, customizable to your needs! - Always vote on an answer if you found it helpful
132
Views
0
Helpful
1
Replies
CreatePlease to create content