Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

prevent routing loop

HI ALL!

I've sumarized toward the core from each dist.i;m a little bit confused about the routing loop;the routing P is EIGRP.CAN U use static route to the null0.how is the procedure.PS Have a look to my config&the attachment:

core:

router eigrp 100

network 10.0.0.0

no auto-summary

DS1

router eigrp 100

network 10.0.0.0

passive-interface default

no passive-interface gi0/1

no auto-summary

int gi0/1

ip address

ip summary-address eigrp 100 10.3.0.0 255.255.0.0

DS2

router eigrp 100

network 10.0.0.0

passive-interface default

no passive-interface gi0/1

no auto-summary

int gi0/1

ip address

ip summary-address eigrp 100 10.2.0.0 255.255.0.0

DS3

router eigrp 100

network 10.0.0.0

passive-interface default

no passive-interface gi0/1

no auto-summary

int gi0/1

ip address

ip summary-address eigrp 100 10.4.0.0 255.255.0.0

DS4

router eigrp 100

network 10.0.0.0

passive-interface default

no passive-interface gi0/1

no auto-summary

int gi0/1

ip address

ip summary-address eigrp 100 10.5.0.0 255.255.0.0.

do i creat a null interface on each dist than advertised the route to null.how can i configure this depending on my diagram?

10xs

Ali

12 REPLIES

Re: prevent routing loop

Hi Ali,

AFAIK if you just create a static route pointing to null0 interface on your Distribution Switch it should be ok.

eg

On your dist switch 1 you can configure something like this

ip route 10.3.0.0 255.255.0.0 null0

In same way you can have this static route on all your distribution switch where you have configured summarisation.

HTH, if yes please rate the post.

Ankur

New Member

Re: prevent routing loop

hi 10xs for ur reply!

on the dist1 this config it will be like this:

DS1

router eigrp 100

network 10.0.0.0

passive-interface default

no passive-interface gi0/1

no auto-summary

int gi0/1

ip address

ip summary-address eigrp 100 10.3.0.0 255.255.0.0

int null0

!ip route 10.3.0.0 255.255.0.0 null0

on dist 2

DS2

router eigrp 100

network 10.0.0.0

passive-interface default

no passive-interface gi0/1

no auto-summary

int gi0/1

ip address

ip summary-address eigrp 100 10.2.0.0 255.255.0.0

!

int null0

!

ip route 10.2.0.0 255.255.0.0 null0

and so on;on all the remaining dist..ankur can u explain to me what happen without this command & with this command

10xs

ali

Re: prevent routing loop

Hi Ali,

Lets me try to explain...

Lets take an example you have not configured static route pointing to null 0 interface so what could be the result. Your summarised route will be advertised to different routers and neighbors say the core router. Now if any node behind core router want to reach any of the specific routes from that summarised routes, the core router will fwd the request to your distribution router as it has learned the summarised route from distribution router.

Now lets say that particular route from summarised route is not available due to any reason or distrubution router is not aware of that specific route because that specific route is down what will happen in that case. The request may be sent to the default route if you have any on dstribution router and that default router may again send the request to distribution router and in this case ther may be a loop between a distribution router and default router.

If you have a static route pointing to null 0 interface on distribution router and even if any specific route is down from that summarised route then it will check the static route pointing to null 0 interface and will drop the packet and will prevent routing loop. Now this is one situation which can create rouitng loop and it all depends on your network and routing design not necessary that without static route pointing to null 0 interface you will get into routing loop but it is recommended that if you have summarised route better to have static route also pointing to null 0.

Check this link may be of help

http://www.cisco.com/en/US/tech/tk364/technologies_tech_note09186a00801c9a6e.shtml#topic1

Hope I am able to explain, if yes please rate the post.

Ankur

New Member

Re: prevent routing loop

Hi ankur 10xs for ur reply!

have a look to this config;it is correct:

DS1

router eigrp 100

network 10.0.0.0

passive-interface default

no passive-interface gi0/1

no auto-summary

int gi0/1

ip address

ip summary-address eigrp 100 10.3.0.0 255.255.0.0

int null0

!ip route 10.3.0.0 255.255.0.0 null0

on dist 2

DS2

router eigrp 100

network 10.0.0.0

passive-interface default

no passive-interface gi0/1

no auto-summary

int gi0/1

ip address

ip summary-address eigrp 100 10.2.0.0 255.255.0.0

!

int null0

!

ip route 10.2.0.0 255.255.0.0 null0

10xs

Re: prevent routing loop

Hi Ali,

That's perfect!!

Have a luck and nice stable network ;)

HTH, if yes please rate all post.

Ankur

New Member

Re: prevent routing loop

HI ANKUR 10XS FOR UR HELP

DO I NEED TO CREAT 1ST A NULL INTERFACE IN EACH DIST IN THE NETWORK.THAN I CREAT A THE STATIC ROUTE TO NULL0.ANKUR B/W I DONT HAVE ROUTERS IN MY NETWORKS ALL IS L3 SWITCHS(6509-E)

10XS

ali

Re: prevent routing loop

Hi Ali,

Yes you can very well create null0 interface on cat6k switch and then configure static route pointing to the null0 interface.

Have a look at this link

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat6000/12_1e/comref/i1.htm#wp1265171

HTH, if yes please rate all post.

Ankur

New Member

Re: prevent routing loop

HI 10XS FOR UR REPLY!

THE CONFIG ON ALL DIST LIKE THIS.COORECT ME IF I'M WRONG.

DS1

router eigrp 100

network 10.0.0.0

passive-interface default

no passive-interface gi0/1

no auto-summary

int gi0/1

ip address

ip summary-address eigrp 100 10.3.0.0 255.255.0.0

!

INT null0

!

ip route 10.3.0.0 255.255.0.0 null0

DS2

router eigrp 100

network 10.0.0.0

passive-interface default

no passive-interface gi0/1

no auto-summary

int gi0/1

ip address

ip summary-address eigrp 100 10.2.0.0 255.255.0.0

!

INT null0

!

ip route 10.2.0.0 255.255.0.0 null0

DS3

router eigrp 100

network 10.0.0.0

passive-interface default

no passive-interface gi0/1

no auto-summary

int gi0/1

ip address

ip summary-address eigrp 100 10.4.0.0 255.255.0.0

INT null0

!

ip route 10.4.0.0 255.255.0.0 null0

!

DS4

router eigrp 100

network 10.0.0.0

passive-interface default

no passive-interface gi0/1

no auto-summary

!

int gi0/1

ip address

ip summary-address eigrp 100 10.5.0.0 255.255.0.0

INT null0

!

ip route 10.5.0.0 255.255.0.0 null0

!

THIS CONFIG ITS CORRECT

10XS

ALI

Re: prevent routing loop

hi Ankur,

first of all i like to wish you congratulation for your cisco job and can i have your new email ID

regards

Devang

Re: prevent routing loop

Hi Ali,

Your config is perfect!!

Wish you a luck for your sweet and stable network.

HTH, if yes please rate the post.

Devang: Thanks for your wishes!! You can reach me on anky_is_yanky@yahoo.com

Regards,

Ankur

Re: prevent routing loop

HI

Ankur i would also like to share u r e-mail ID hope u dnot mind.

Thanks

Mahmood

Re: prevent routing loop

Hi Mahmood,

You are most welcome!!

Regards,

Ankur

357
Views
23
Helpful
12
Replies