Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

primary and backup interfaces

Hello,

I have a 2900 router with two GigabitEthernet interfaces. I want to configure the interface 0/1 like the primary, and the 0/0 like a backup,
but I have a problem. When I disconnect the cable from interface 0/1 the backup interface began to work, but if I don't disconnect the cable, but there is a problem with the internet access going out that primary interface, the backup doesn't begin to work. How could I do to detect that you cannot get to Internet through that Interface to begin to use the backup?. The current configuration is the one above. 

interface GigabitEthernet0/0

ip address 10.10.10.2 255.255.255.252

ip nat outside

ip virtual-reassembly in

load-interval 30

duplex auto

speed auto

!

interface GigabitEthernet0/1

backup delay 10 30

backup interface GigabitEthernet0/0

ip address 192.168.1.2 255.255.255.252

ip nat outside

ip virtual-reassembly in

load-interval 30

duplex auto

speed auto

!

ip nat inside source route-map backup interface GigabitEthernet0/0 overload

ip nat inside source route-map primary interface GigabitEthernet0/1 overload

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip route 0.0.0.0 0.0.0.0 10.10.10.1

!

access-list 5 permit any

!

route-map backup permit 10

match ip address 5

match interface GigabitEthernet0/0

!

route-map primary permit 10

match ip address 5

match interface GigabitEthernet0/1

!

!

Thanks in advance for your help.

6 REPLIES

primary and backup interfaces

Accoring to my testing, it looks like you should be able to do something like use sla and then track your static route:

ip sla 1

icmp-echo

timeout 1000

threshold 10

frequency 5

ip sla schedule 1 life forever start-time now

track 1 interface FastEthernet0/0 line-protocol

ip route 0.0.0.0 0.0.0.0 192.168.1.1 254

ip route 0.0.0.0 0.0.0.0 10.10.10.1 track 1

The 10.10.10.1 static route will only be available if fa0/0 is up. If fa0/0 goes down, it will install the other route. In order for you to identify routing issues, etc, you'd have to use something more intelligent like PfR in order to do that.

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

primary and backup interfaces

Yes you need to use IP SLA becasue in your config there are 2 default route .

once the interface is down the 1st configured default gateway will be there and any packet coming to reach internet it will go via 1st default route ................it will  never reach 2nd default route .

& as u r 1st default route next hop ip is not reachable packet will start getting drop .

Regards

Ritesh

New Member

primary and backup interfaces

Thanks for your help,

I have tried this configuration, but it doesn't works, I don't know if there is anything wrong:

ip sla 1

icmp-echo 8.8.8.8

timeout 1000

frequency 5

threshold 10

ip sla schedule 1 life forever start-time now

track 1 interface GigabitEhternet0/1 line-protocol


ip route 0.0.0.0 0.0.0.0 192.168.1.1 track 1

ip route 0.0.0.0 0.0.0.0 10.10.10.1 254

I have also tried with:

ip route 0.0.0.0 0.0.0.0 192.168.1.1 254

ip route 0.0.0.0 0.0.0.0 10.10.10.1 track 1

But it doen't work

Am I configuring something wrong?

Thanks for your help

primary and backup interfaces

When you say it doesn't work, what are you wanting it to do? What should happen is when you lose connection via g0/1 to the ISP, the static route for 192.168.1.1 will drop out of the table and then your 10.10.10.1 route should show up. Is that part happening?

Try this. Do a "sho ip route | inc 0.0.0.0" before pulling the cable to g0/1. Make a note of what it says. Then pull the cable and do a "show ip route | inc 0.0.0.0" and make a note of what it says. If it switches, then the sla piece is working as intended, but something else is wrong.

HTH, John *** Please rate all useful posts ***
New Member

primary and backup interfaces

Hi,

I need that when the connection to Internet through the primary Interface goes down it automaticaly route to the backup interface. It swap to the other route when I disconnect the cable, but it doesn't work if the cable is left connected but the connection goes down.

Now I have this configuration:

!

track 1 interface GigabitEhternet0/1 line-protocol

!

interface GigabitEthernet0/0 --backup interface

ip address 10.10.10.2 255.255.255.252

ip nat outside

ip virtual-reassembly in

load-interval 30

duplex auto

speed auto

!

interface GigabitEthernet0/1 -- primary interface

backup delay 10 30

backup interface GigabitEthernet0/0

ip address 192.168.1.2 255.255.255.252

ip nat outside

ip virtual-reassembly in

load-interval 30

duplex auto

speed auto

!

ip nat inside source route-map backup interface GigabitEthernet0/0 overload

ip nat inside source route-map primary interface GigabitEthernet0/1 overload

ip route 0.0.0.0 0.0.0.0 10.10.10.1 254

ip route 0.0.0.0 0.0.0.0 192.168.1.1 track 1

!

ip sla 1

icmp-echo 8.8.8.8

threshold 10

frequency 5

ip sla schedule 1 life forever start-time now

!

access-list 5 permit any

!

route-map backup permit 10

match ip address 5

match interface GigabitEthernet0/0

!

route-map primary permit 10

match ip address 5

match interface GigabitEthernet0/1

!

I would appreciate if somebody could help me to find what is wrong.

Thanks in advance

Re: primary and backup interfaces

Hi John,

I think that you got the track wrong.

If you probe the next-hop router ( ISP ) then you should use this probe and track it:

So :

no track 1 interface GigabitEhternet0/1 line-protocol

track 1 rtr 1

Also the ip sla is probing 8.8.8.8 if the sla goes down , because of the Primary ISP, the first default route will be installed. The Internet will work and the IP SLA will work again through Backup link, and the primary default route will come UP , and so on.

So the solution will be to use under the sla 1 config source interface GigabitEthernet0/1.

Regards

Dan

644
Views
0
Helpful
6
Replies
CreatePlease to create content