Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

priority class traffic gets dropped

Dear fellow Ciscoers,

I've been wondering if I may have missed something in my config and could use a second pair of eyes. I am configuring a router for a branch office that will connect to head office via VPN and created a policy for a bunch of VOIP phones so that even if the link is congested the call quality doesn't suffer. Problem is , when I congest the link , VOIP packets still show drops.

=========================================

speed test in the UP direction (with no policy applied)

.85 mbps

=========================================

This is the policy configuration:

 

policy-map QOS_OUT
 class Voip
  priority percent 70
  queue-limit 64 packets
 class class-default
  queue-limit 8 packets
  shape average 600000
  random-detect

interface FastEthernet8
 bandwidth 850
 bandwidth qos-reference 850

 service-policy output QOS_OUT
 hold-queue 10 out

=========================================

output of show policy-map command
ISR1_ATS_DT_Showroom#show policy-map int fa 8
 FastEthernet8

  Service-policy output: QOS_OUT

    queue stats for all priority classes:
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/49/0
      (pkts output/bytes output) 1860/504664

    Class-map: Voip (match-all)
      1909 packets, 410392 bytes
      5 minute offered rate 0000 bps, drop rate 0000 bps
      Match:  precedence 1
      Priority: 70% (595 kbps), burst bytes 14850, b/w exceed drops: 0

 

=========================================

troubleshooting done:

- lower the queue length for default-class
- lower the shaping value for default-class
- added random detect for default-class

-created a parent policy and put the shaping in it instead of just for the default class.

-increased percentage of bandwidth for priority class just to see if it makes any difference

=========================================

IOS Version 15.2(4)M4 , Cisco 891

=========================================

Notes: it doesn 't look like they're no buffer drops so there's gotta be another reason for it.

Everyone's tags (1)
2 REPLIES

I don't see any class maps?

I don't see any class maps? One of the easier ways would be to remove your config and try auto qos voip trust on Fast8. Then edit your values to match what is needed.

Community Member

It started working and I can

It started working and I can't recall what the culprit was . I'll keep this one in mind for next time. Thanks,
 

52
Views
3
Helpful
2
Replies
CreatePlease to create content