Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Problem about flash in Cisco877-k9

I installed flash module (4MB) to Cisco877, then formatted the flash and uploaded IOS version 12.4(11)XJ into the router. After turned off the router more than 1 day, it could not open the boot file. The size of IOS is 0 byte when I typed the command 'dir flash:' in rommon mode. The information below is the error message I got when boot the router.

flashfs[0]: Checking block 151...bad block number (407)

flashfs[0]: erasing block 151...done.

flashfs[0]: Checking block 152...bad checksum (58096 != 53697)

flashfs[0]: erasing block 152...done.

flashfs[0]: erasing block 152 with status unknown[0xe]

flashfs[0]: inconsistent sector list, fileid 2, parent_fileid 0

flashfs[0]: block 151 not available or in use, state: unknown[0xe].

flash: file system initialization failed

Could not open boot directory: flash:/

Unable to open boot file

Could anyone suggest me what I should do?

Thank you.

1 REPLY
Silver

Re: Problem about flash in Cisco877-k9

Try to upload new IOS using XMODEM this should erase the flase and try initialize it again. if same issue persist it could be a damaged flash and you will need to open a case with Cisco TAC for replacement.

Hope this helps,

Regards,

347
Views
0
Helpful
1
Replies