Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem configuring 881 for PPPoE

Hi, I had configured an 871 to use PPPoE before. Now I tried to use the same configuration on a new 881, I was able to connect to the Internet from the router, but my PC behind the 881 cannot ping any public address except the one on the WAN interface. Has anyone had similar experience? Below is my config. I also tried using the ccpexp, but it doesn't have a wizard like before, just a simple flash page, no pppoe.

!

vpdn enable

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin ppp pap sent-username pe1012@sbcglobal.net password x68mTE

ppp ipcp dns request ppp ipcp address accept

!

dialer-list 1 protocol ip list 1

ip nat inside source list 1 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

!

interface FastEthernet4

pppoe-client dial-pool-number 1

ip nat outside

ip route-cache flow

duplex auto

speed auto

ip nbar protocol-discovery

!

interface Vlan1

ip address 10.10.10.1 255.255.255.0

ip route-cache flow

ip tcp adjust-mss 1452

!

access-list 1 permit 10.10.10.0 0.0.0.255

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions

Problem configuring 881 for PPPoE

hi

plese change it

vpdn enable

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

ip nat outside

ppp authentication pap callin ppp pap sent-username pe1012@sbcglobal.net password x68mTE

ppp ipcp dns request ppp ipcp address accept

!

dialer-list 1 protocol ip list 1

ip nat inside source list 1 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

!

interface FastEthernet4

pppoe enable group global

pppoe-client dial-pool-number 1

no ip nat outside

ip route-cache flow

duplex auto

speed auto

ip nbar protocol-discovery

!

interface Vlan1

ip address 10.10.10.1 255.255.255.0

ip route-cache flow

ip tcp adjust-mss 1452

ip nat inside

!

access-list 1 permit 10.10.10.0 0.0.0.255

ip route 0.0.0.0 0.0.0.0 interface dialer 1 overload

show ip interface brief

check you are getting ip on your dialer interface

if not contact your ISP for specific dialer settings.

Jawad

Jawad
5 REPLIES
VIP Super Bronze

Problem configuring 881 for PPPoE

Hi,

Can you add

ip nat inside

to vlan 1 and test again?

HTH

New Member

Problem configuring 881 for PPPoE

Thank you for your reply, I did have that in there, somehow I didn't paste that in the post above:

ip nat inside

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1452

I started with a working configuration for DHCP and modified the WAN interface to use PPPoE, so the LAN part was working when I connected the 881 behind another router using DHCP, my PC could connect to the Internet through the two routers.

Problem configuring 881 for PPPoE

hi

plese change it

vpdn enable

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

ip nat outside

ppp authentication pap callin ppp pap sent-username pe1012@sbcglobal.net password x68mTE

ppp ipcp dns request ppp ipcp address accept

!

dialer-list 1 protocol ip list 1

ip nat inside source list 1 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

!

interface FastEthernet4

pppoe enable group global

pppoe-client dial-pool-number 1

no ip nat outside

ip route-cache flow

duplex auto

speed auto

ip nbar protocol-discovery

!

interface Vlan1

ip address 10.10.10.1 255.255.255.0

ip route-cache flow

ip tcp adjust-mss 1452

ip nat inside

!

access-list 1 permit 10.10.10.0 0.0.0.255

ip route 0.0.0.0 0.0.0.0 interface dialer 1 overload

show ip interface brief

check you are getting ip on your dialer interface

if not contact your ISP for specific dialer settings.

Jawad

Jawad
New Member

Problem configuring 881 for PPPoE

Thank you, I will try that when I get to the office next week. I did type in pppoe enable group global, but when I ran "show running-config" this line was not shown, I was wondering why. I assumed it was the default. I also tried changing Dialer1 to dialer 0, didn't work either. When I typed "ip show route" I could see the public IP address assigned to the WAN by the ISP and the next hop, so that part was working. As I said I could ping any public IP address from the router, so I suspect the problem is the routing/permission from LAN to WAN. But the routing worked when I used DHCP.

New Member

Problem configuring 881 for PPPoE

Thank you very much, apparently with the new firmware ip nat outside needs to be under the Dialer interface. I ended up installing CCP on my PC and using that to generate the basic commands.

1152
Views
0
Helpful
5
Replies