Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem configuring QoS in Cisco861

Hello,

I'm having problems to configure QoS in Cisco861 with IOS 15.0M. What I want is quite simple, I want to configure two VLAN with different traffic shaping/policing policitics towards Internet:

VLAN 1 - 2/1 Mbps

VLAN 2 - 8/1 Mbps

WAN Interface is 10/2 Mbps

FIRST. I tried to configure traffic policing/shaping in the WAN Interface (Fa4). But it worked only for the outbound traffic and not for the inbound traffic, I suspect that is due to source NAT (Am I wrong?). The download test give me 3Mbps (class-default), bad behaivour, and the upload test is done well 1Mbps.

ip access-list extended wired-users

permit ip 192.168.1.0 0.0.0.255 any

permit ip any 192.168.1.0 0.0.0.255

class-map match-any wired-users

match access-group name wired-users

policy-map wan-output

class wired-users

   police cir 1000000

     conform-action transmit

     exceed-action drop

     violate-action drop

class class-default

   police cir 3000000

     conform-action transmit

     exceed-action drop

     violate-action drop

interface FastEthernet4

description Internet

ip address 172.16.4.22 255.255.255.0

ip nat outside

ip virtual-reassembly

zone-member security internet

duplex auto

speed auto

service-policy input wan-output

service-policy output wan-output

end

SECOND, due to the limitation discovered I configure police/shape in the switch port fa0. I remark that this is a switchport and not a routeport. I disable the service-policy of the wan interface and enable the service policy only in the fa0 interface. The results are even worse. None direction is limited, download test gave me 25Mbps and the upload test 5,5 Mbps.

ip access-list extended wired-users

permit ip 192.168.1.0 0.0.0.255 any

permit ip any 192.168.1.0 0.0.0.255

class-map match-any wired-users

match access-group name wired-users

policy-map wan-output

class wired-users

   police cir 1000000

     conform-action transmit

     exceed-action drop

     violate-action drop

class class-default

   police cir 3000000

     conform-action transmit

     exceed-action drop

     violate-action drop

interface FastEthernet0

description Puerto Usuarios Cableada

service-policy input wan-output

service-policy output wan-output

end

interface Vlan1

description Red Usuarios Cableada

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

zone-member security wired

end

THIRD, I also tried to configure the service policy in the SVI interface (vlan1) but it means that it not possible to configure a service-policy in a SVI interface.

Could you give me some advice about how to configure shaping/policing to get what I want? It's the first time I try to configure QoS in Cisco as it's obvious

Thanks!

Christian

172
Views
0
Helpful
0
Replies
CreatePlease login to create content