Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Problem in serial links!!

Hi,

I am facing an acute problem. I've a cisco 3725 series router in which I've got 8 serial interfaces, out of which 6 are active and one is shut. The problem is, when i ping any of the local serial interfaces, I.e. whenever i ping any ip assigned on serial interfaces, I get huge loses. The funny thing is, when i trace the IP assigned on the serial interface, I get a reply that in the first HOP only, the IP shown is of the Next HOP i.e. the next router's serial interface IP. And the second HOP shown is of the local Serial interfaces's IP, whereas the IP in the First hops should be of the local serial interface. Please suggest.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Problem in serial links!!

Tapas

As I said before this is absolutely normal behavior. Let us review how traceroute works and see how that produces the results that you see. Traceroute sends probe packets and manipulates the TTL of the packet. First it sends a probe with TTL set to 1. The probe gets to the first layer 3 interface, which decreases the TTL, and sends an error message because the TTL is now 0. Traceroute sends another probe with TTL increased by 1. It continues to do this until it reaches the destination or until it gets to max TTL (by default 30 hops). The error messages are how traceroute finds the path through the network. So when you issue this command:

traceroute 10.202.0.1

the router sends a probe packet out the serial interface with TTL 1. There is no reason that the first response should be your own interface since it is sending the packet and the TTL is 1. The packet gets to pani, which decreases the TTL and sends its error message that the TTL is 0. So the first response that you see is from pani and that shows up in your results as it should. Then your router sends probes with TTL of 2. The probe gets to pani which decreases the TTL (now equal 1) and forwards the packet out the serial interface. The packet now gets to you and you generate the response. So you see the second response as being from your interface. This is normal behavior and is not a problem.

HTH

Rick

5 REPLIES
Silver

Re: Problem in serial links!!

Hi ,

Can you paste the config of the router and "show interface " output of one serial interface.

Thanks,

satish

Hall of Fame Super Silver

Re: Problem in serial links!!

In this situation I believe that we do not need configs or show interface since what he is describing is in fact normal behavior for point to point serial links. In IOS if you ping or traceroute to your own serial interface address the IOS actually sends a packet out the interface. The packet is received by the neighbor and forwarded back to your router. (and then you generate a response which is sent out the interface, received by the neighbor and forwarded back to you). This is not a problem - it is normal behavior for IOS. An interesting way to demonstrate this is to ping the address of the neighbor and then ping your own address. The response time for ping your own address should be just about double the response time to ping the neighbor (since the packets are going over the link twice as often). And if you want to really proove this you can run debug ip packet on the neighbor router, ping your own serial interface address, and look at the debug output on the neighbor which will clearly show that it received your ping, forwarded the ping, received your response, and forwarded the response.

The original post described packet loss on some of the interfaces and we do not have enough information to deal with that yet. But I believe that the main point of the original post was concern that the next hop in the traceroute was the neighbor when he thought that the first next hop should be his own address. And the answer to this is that it is normal behavior.

HTH

Rick

New Member

Re: Problem in serial links!!

Thanks for the reply rick. I still have a question on this. The question is even if the packet is sent out thru the out interface, and it comes back as a reply, then while tracing the local IP, in the first HOP itself, it should show the IP of the exit interface OR may also show RTO i.e. * * *, but its not showing that, where as in the first HOP, it shows the neighbouring router's serial interface's IP. Please suggest.

Hall of Fame Super Silver

Re: Problem in serial links!!

Tapas

As I said before this is absolutely normal behavior. Let us review how traceroute works and see how that produces the results that you see. Traceroute sends probe packets and manipulates the TTL of the packet. First it sends a probe with TTL set to 1. The probe gets to the first layer 3 interface, which decreases the TTL, and sends an error message because the TTL is now 0. Traceroute sends another probe with TTL increased by 1. It continues to do this until it reaches the destination or until it gets to max TTL (by default 30 hops). The error messages are how traceroute finds the path through the network. So when you issue this command:

traceroute 10.202.0.1

the router sends a probe packet out the serial interface with TTL 1. There is no reason that the first response should be your own interface since it is sending the packet and the TTL is 1. The packet gets to pani, which decreases the TTL and sends its error message that the TTL is 0. So the first response that you see is from pani and that shows up in your results as it should. Then your router sends probes with TTL of 2. The probe gets to pani which decreases the TTL (now equal 1) and forwards the packet out the serial interface. The packet now gets to you and you generate the response. So you see the second response as being from your interface. This is normal behavior and is not a problem.

HTH

Rick

New Member

Re: Problem in serial links!!

HOST#sh runn

ip host bhat 10.203.0.2

ip host pani 10.202.0.2

ip host luck 10.204.0.2

ip host chan 10.200.0.2

ip accounting-list 0.0.0.0 255.255.0.0

ip accounting-transits 100

ftp-server enable

no ftp-server write-enable

isdn switch-type basic-net3

!

!

!

!

interface Serial0/1

no ip address

shutdown

clockrate 2000000

!

interface Serial1/0

description ********************************* WAN TO PANIPAT

router eigrp 100

network 10.1.0.0 0.0.255.255

network 10.2.0.0 0.0.255.255

network 10.3.0.0 0.0.255.255

network 10.4.0.0 0.0.255.255

network 10.5.0.0 0.0.255.255

network 10.6.0.0 0.0.255.255

network 10.7.0.0 0.0.255.255

network 10.10.0.0 0.0.255.255

network 10.201.0.0 0.0.255.255

network 10.202.0.0 0.0.255.255

network 10.203.0.0 0.0.255.255

network 10.204.0.0 0.0.255.255

network 10.205.0.0 0.0.255.255

network 10.206.0.0 0.0.255.255

network 10.210.0.0 0.0.255.255

network 10.211.0.0 0.0.255.255

network 10.212.0.0 0.0.255.255

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0

ip route 10.1.0.0 255.255.0.0 Serial1/1

ip route 10.2.0.0 255.255.0.0 Serial1/4

ip route 10.3.0.0 255.255.0.0 Serial1/0

ip route 10.4.0.0 255.255.0.0 Serial1/2

ip route 10.5.0.0 255.255.0.0 Serial1/5

ip route 10.6.0.0 255.255.0.0 Serial1/3

ip route 10.7.0.0 255.255.0.0 Serial1/6

HOST#sh int se1/0

Serial1/0 is up, line protocol is up

Hardware is CD2430 in sync mode

Description: ********************************* WAN TO PANIPAT

Internet address is 10.202.0.1/30

MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input 00:00:00, output 00:00:02, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 2221

Queueing strategy: weighted fair

Output queue: 0/1000/64/2221 (size/max total/threshold/drops)

Conversations 0/30/32 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 96 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

1240728 packets input, 270757052 bytes, 0 no buffer

Received 95824 broadcasts, 0 runts, 0 giants, 0 throttles

63447 input errors, 57215 CRC, 0 frame, 0 overrun, 0 ignored, 6232 abort

1311404 packets output, 899143110 bytes, 0 underruns

0 output errors, 0 collisions, 3376 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

HOST#traceroute 10.202.0.1

Type escape sequence to abort.

Tracing the route to 10.202.0.1

1 pani (10.202.0.2) 28 msec 24 msec 28 msec

2 10.202.0.1 56 msec 52 msec *

286
Views
5
Helpful
5
Replies