Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Problem in setting origin of the route

Hi all,

I am having the following problem in Redistributing static routes into BGP .

Consider eBGP between R2 and R3.

Configurations are :

R2 configs :

hostname R2

ip route 150.1.1.0/24 10.1.1.20

route-map Set_Map permit 20

set origin egp

router bgp 100

redistribute static route-map Set_Map

neighbor 40.1.1.30 remote-as 200

R3 configs :

router bgp 200

neighbor 40.1.1.20 remote-as 100

When I do 'show ip bgp' in R3, it shows as below :

*> 150.1.1.0/24 40.1.1.20 100 100 ?

Why it's not changing to 'e'.

Thanks,

Vijaybabu

2 REPLIES
Hall of Fame Super Bronze

Re: Problem in setting origin of the route

I duplicated your config and it's working here.

My config:

Router 1

router bgp 2

no synchronization

bgp log-neighbor-changes

redistribute connected route-map bgporigin

redistribute static route-map Set_Map

neighbor 172.25.1.1 remote-as 1

neighbor 172.25.1.1 ebgp-multihop 10

default-information originate

no auto-summary

ip route 10.150.1.0 255.255.255.0 Null0

route-map Set_Map permit 20

set origin egp 2

Router 2:

#sh ip bgp

Network Next Hop Metric LocPrf Weight Path

*> 0.0.0.0 172.25.1.2 0 0 2 e

*> 10.40.0.0/16 172.25.1.2 0 0 2 e

*> 10.45.0.0/16 172.25.1.2 0 0 2 e

*> 10.50.0.0/16 172.25.1.2 0 0 2 e

*> 10.55.0.0/16 172.25.1.2 0 0 2 e

*> 10.150.1.0/24 172.25.1.2 0 0 2 e

The only thing I see missing from you is the AS # under the route-map

For instance

it should be

route-map Set_Map permit 20

set origin egp 100

Please rate helpful posts.

Thanks

New Member

Re: Problem in setting origin of the route

Hi Edison,

Thanks for your extensive help.

I will check my configs.

Thanks,

Vijaybabu

324
Views
5
Helpful
2
Replies
CreatePlease to create content