Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem in Static routes redistrubution in OSPF

Hi,

We have a router on which OSPF process is running on some interfaces and on some another interfaces static routes are configured. All static routes are redistributed in OSPF. For interface on which static routes are configured, PRI to BRI ISDN line is configured as a backup to serail link. This is configured using a dialer watch on remote router having BRI Port. When leased link is ok , this route is properly distributed in OSPF process and we can reach that network from other OSPF running routers. But when link fails ISDN takes over and connectivity is established. in short commands are as follows

ip route NETWORK_A 172.30.9.2 ( next hop address of serial link )

ip route NETWORK_A 172.20.9.2 200 ( next hop address of bri interface on remote router and distance as 200 )

Now as when first route is down it takes second route and I can ping to remote router even when working on BRI ISDN. But this route is not distributed in OSPF process enabled interfaces.

Second thing I have observed that if I just remove the second command and just put it back again, immediately route is redistributed to OSPF process.

Any suggestion on configurtaion ?

Appreciate any link on cisco.com

Thanx in advance

Subodh

4 REPLIES
New Member

Re: Problem in Static routes redistrubution in OSPF

try adding the "redistribute static subnets" command under the OSPF process.

Regards

Steve

New Member

Re: Problem in Static routes redistrubution in OSPF

Hi ,

I think redistribute static subnets might help.

can u paste {show run} Plz that would help to see how its configured . Also check out the link .

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a00804556bb.html

see/rate if this link works ..

TC

Prs

New Member

Re: Problem in Static routes redistrubution in OSPF

hi,

we have given redistribute subnets command in ospf ,

but still these routes are not getting redistrubuted in OSPF enabled interfaces.

Is there any timer after that only routes are redistributed. Can we minimise this timer. So that secondary routes will be immedialtely redistributed. We waited for 45 minutes thinking that OSPF will redistribute all routing table , but it didnt work. Has it some thing to do with remote router configuration ( dialer watch configured)

Thanks in advance

New Member

Re: Problem in Static routes redistrubution in OSPF

What's the platform and IOS level you're running? Sounds suspiciously like an IOS bug.

122
Views
0
Helpful
4
Replies
CreatePlease login to create content