Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Problem with Cisco 1841 and SPA504G Phones

Hello to everyone!

I am new to the Cisco support community. Sorry in advance if this post does not belong here, please feel free to move it to the correct place. We have been having some problems with some of our SPA504G and Linksys 942s phones not registering and the buttons staying in amber light. This sometimes happens when the phone is rebooted or disconnected. The setup we have is a Cisco 1841 router and a 2950 switch. Whenever the problem occurs, we apply the command "clear ip nat translations * " in the router and the phones register again, and work normally. Has this happened to anyone? We know it’s a problem with the NAT table translations, since that command does the trick. We also tried modifying the NAT translation timeout using the command “ip nat translation udp-timeout 65” but it did not work. Any ideas why this is happening, or how to fix it?

Thanks!

Everyone's tags (4)
2 REPLIES

Problem with Cisco 1841 and SPA504G Phones

I've the same problem with Cisco router and NAT SIP clients in general.

When a SIP device is under NAT sometimes the registration fails.

I think that this is due to a sub-optimum SIP ALG of Cisco NAT.

I tried some tricks, sometimes it work:

- upgrade cisco IOS (expecially the version 15)

- build a KRON script to clear NAT

- build a KRON scirpt to reload router

- disable SIP ALG (no ip nat service SIP) and use NAT features of SIP clients or third party SBC

Regards.

Hall of Fame Super Gold

Problem with Cisco 1841 and SPA504G Phones

Wrong forum, post in "Infrastrcture - WAN and routing". You can move your post using the actions panel on the right.

1456
Views
0
Helpful
2
Replies
CreatePlease to create content