Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

problem with dhcp client

hi, i have a cisco soho 91.

i have a problem with client dhcp: on e0 of my router there is my lan and e0 have a static ip (192.168.2.0), WAN port must have dinamic ip assigned by ISP. this is my configuration:

Router#sh run

Building configuration...

Current configuration : 3402 bytes

!

version 12.3

service nagle

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

no logging buffered

logging rate-limit 500

enable secret 5 xxxxxxxxxxxxxxxxxxxx

!

username Router password 7 xxxxxxxxxxx

no aaa new-model

ip subnet-zero

no ip source-route

ip tcp selective-ack

ip tcp window-size 2144

ip tcp synwait-time 50

!

!

no ip bootp server

ip cef

!

!

!

!

!

!

!

interface Ethernet0

ip address 192.168.2.1 255.255.255.0

ip access-group 130 in

ip nat inside

no cdp enable

!

interface Ethernet1

ip address dhcp

no ip redirects

no ip unreachables

no ip proxy-arp

ip accounting access-violations

ip nat outside

duplex auto

no cdp enable

!

ip nat inside source list PERMISSIONI_NAT interface Ethernet1 overload

ip classless

no ip forward-protocol udp bootps

no ip forward-protocol udp tftp

no ip forward-protocol udp nameserver

no ip forward-protocol udp domain

no ip forward-protocol udp time

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

no ip forward-protocol udp tacacs

no ip http server

no ip http secure-server

!

!

ip access-list standard PERMISSIONI_NAT

permit 192.168.2.0 0.0.0.255

but i don't recive any ip.

now post result of debug dhcp det

3 REPLIES
New Member

Re: problem with dhcp client

*Mar 1 00:40:40.267: DHCP: Waiting for 10 seconds on interface Ethernet1

*Mar 1 00:40:44.619: DHCP: QScan: Purging entry

*Mar 1 00:40:44.619: DHCP: deleting entry 814549E4 0.0.0.0 from list

*Mar 1 00:40:44.619: Temp IP addr: 0.0.0.0 for peer on Interface: unknown

*Mar 1 00:40:44.619: Temp sub net mask: 0.0.0.0

*Mar 1 00:40:44.619: DHCP Lease server: 0.0.0.0, state: 8 Purging

*Mar 1 00:40:44.619: DHCP transaction id: 25FE

*Mar 1 00:40:44.619: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs

*Mar 1 00:40:44.619: No timer running

*Mar 1 00:40:44.619: Retry count: 0 Client-ID:

*Mar 1 00:40:44.619: Hostname: Router

*Mar 1 00:40:50.267: DHCP: Try 3 to acquire address for Ethernet1

*Mar 1 00:40:50.267: DHCP: allocate request

*Mar 1 00:40:50.267: DHCP: zapping entry in DHC_PURGING state for Et1

*Mar 1 00:40:50.267: DHCP: new entry. add to queue

*Mar 1 00:40:50.271: DHCP: SDiscover attempt # 1 for entry:

*Mar 1 00:40:50.271: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet1

*Mar 1 00:40:50.271: Temp sub net mask: 0.0.0.0

*Mar 1 00:40:50.271: DHCP Lease server: 0.0.0.0, state: 1 Selecting

*Mar 1 00:40:50.271: DHCP transaction id: 2600

*Mar 1 00:40:50.271: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs

*Mar 1 00:40:50.271: Next timer fires after: 00:00:03

*Mar 1 00:40:50.271: Retry count: 1 Client-ID: cisco-0012.d9ae.1905-Et1

*Mar 1 00:40:50.271: Hostname: Router

*Mar 1 00:40:50.271: DHCP: SDiscover: sending 293 byte length DHCP packet

*Mar 1 00:40:50.271: DHCP: SDiscover 293 bytes

*Mar 1 00:40:50.275: B'cast on Ethernet1 interface from 0.0.0.0

*Mar 1 00:40:53.271: DHCP: SDiscover attempt # 2 for entry:

*Mar 1 00:40:53.271: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet1

*Mar 1 00:40:53.271: Temp sub net mask: 0.0.0.0

*Mar 1 00:40:53.271: DHCP Lease server: 0.0.0.0, state: 1 Selecting

*Mar 1 00:40:53.271: DHCP transaction id: 2600

*Mar 1 00:40:53.271: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs

*Mar 1 00:40:53.271: Next timer fires after: 00:00:03

*Mar 1 00:40:53.271: Retry count: 2 Client-ID: cisco-0012.d9ae.1905-Et1

*Mar 1 00:40:53.271: Hostname: Router

*Mar 1 00:40:53.271: DHCP: SDiscover: sending 293 byte length DHCP packet

*Mar 1 00:40:53.271: DHCP: SDiscover 293 bytes

*Mar 1 00:40:53.275: B'cast on Ethernet1 interface from 0.0.0.0

*Mar 1 00:40:56.271: DHCP: SDiscover attempt # 3 for entry:

*Mar 1 00:40:56.271: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet1

*Mar 1 00:40:56.271: Temp sub net mask: 0.0.0.0

*Mar 1 00:40:56.271: DHCP Lease server: 0.0.0.0, state: 1 Selecting

*Mar 1 00:40:56.271: DHCP transaction id: 2600

*Mar 1 00:40:56.271: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs

*Mar 1 00:40:56.271: Next timer fires after: 00:00:03

*Mar 1 00:40:56.271: Retry count: 3 Client-ID: cisco-0012.d9ae.1905-Et1

*Mar 1 00:40:56.271: Hostname: Router

*Mar 1 00:40:56.271: DHCP: SDiscover: sending 293 byte length DHCP packet

*Mar 1 00:40:56.271: DHCP: SDiscover 293 bytes

*Mar 1 00:40:56.275: B'cast on Ethernet1 interface from 0.0.0.0

*Mar 1 00:40:59.271: DHCP: QScan: Timed out Selecting state

*Mar 1 00:41:10.267: DHCP: QScan: Purging entry

*Mar 1 00:41:10.267: DHCP: deleting entry 8147AABC 0.0.0.0 from list

*Mar 1 00:41:10.267: Temp IP addr: 0.0.0.0 for peer on Interface: unknown

*Mar 1 00:41:10.267: Temp sub net mask: 0.0.0.0

*Mar 1 00:41:10.267: DHCP Lease server: 0.0.0.0, state: 8 Purging

*Mar 1 00:41:10.267: DHCP transaction id: 25FF

*Mar 1 00:41:10.267: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs

*Mar 1 00:41:10.267: No timer running

*Mar 1 00:41:10.267: Retry count: 0 Client-ID:

*Mar 1 00:41:10.267: Hostname: Router%Unknown DHCP problem.. No allocation possible

what is the problem?

there is a mistake in my configuration?

New Member

Re: problem with dhcp client

what kind of device is upstream from your E1 interface? (i.e. cable modem? adsl modem?).

Depending on what device it is have your power-cycled that upstream device? Some cable devices will cache a single MAC Address and if you switch downstream devices, the newly attached device will not receive an IP if the cable device has not been power cycled.

New Member

Re: problem with dhcp client

after E1 interfaces there are 5 wireless antennas (5GHz) and after there is a dhcp server.

322
Views
0
Helpful
3
Replies
CreatePlease login to create content