Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

problem with distribution list

Hi ,

I having problem understanding the distribution list configured on my router my eigrp running on top of it .

interface Ethernet0

ip address 10.1.1.1 255.255.0.0

ip access-group BLOCK-WORM in

!

interface Serial0

description NOT IN USE

no ip address

shutdown

!

interface Serial1

ip address 10.2.2.2 255.255.255.252

bandwidth 64

!

router eigrp 10

redistribute static metric 10000 100 255 1 1500

passive-interface Serial0

network 10.0.0.0

distribute-list 11 out

no auto-summary

!

ip classless

ip route 10.1.1.0 255.255.255.0 10.2.2.2

!

!

access-list 1 permit 10.201.0.0 0.0.255.255

access-list 1 permit 10.202.1.0 0.0.0.255

!

access-list 11 deny 10.2.2.0 0.0.0.255

access-list 11 permit 10.3.3.0 0.0.0.255

!

the 10.3.3.0 is from another network lan ip address connected via serial link

the serial link ip address is 10.2.2.2

The question , how come the EIGRP is pointing on serial interface 1 which is down . And the connectivity between two routers is ok .

Thanks in advance.

14 REPLIES
Silver

Re: problem with distribution list

Hi,

The access-list 11 allowing only the advertisement of network 10.3.3.0 and also blocking the advertisement of connected subnet 10.2.2.0. This advertisement of 10.3.3.0 will happen only when it has the route to that network thro. other router over that serial interface. So when that serial interface is down, this router itself won't see the route to 10.3.3.0 n/w via that serial so that EIGRP will withdraw itzz route.

I think it will help you in understanding.

Rate if it clears ur doubt,

Rgs

New Member

Re: problem with distribution list

Hi Bala ,

I am bit confused on the EIGRP route advertisment , if the route is connected via serial interface , does it need to advertise again .

I just like point to point and you add the routes on both side of the router .

Why do you really need a distribution list .

Alman

New Member

Re: problem with distribution list

Another things the serial 0 is passive and being shutdown . After that , there'a distribution list being assign to that interface .

Passive interface is supposed to recieve routing updates not send any routing updates , correct me if i am wrong .

New Member

Re: problem with distribution list

Hi,

can you let me know the output of 'sh ip route'

Regards,

Rajesh

New Member

Re: problem with distribution list

Hi Rajesh , below is output of sh ip route

C 10.2.2.0/30 is directly connected, Serial1

S 10.3.3.0/24 [1/0] via 10.2.2.2

Purple

Re: problem with distribution list

Hi,

In EIGRP, when you configure a passive-interface, it will neither receive nor send routes over the interface. Therefore, in your setup, no EIGRP routes will be received over the serial interface. Also, I notice that you have no EIGRP routes in the routing table. Do you have any EIGRP neighbors up at all ? The output of 'show ip eigrp neighbors' will show you that.

Pls do remember to rate posts.

Paresh

New Member

Re: problem with distribution list

Hi ,

I am sorry , for asking for more detail . I am still new with EIGRP . The question is ,if why do we need to configure a passive interface which will not receive or send updates over a serial interface in general , not to my setup .

In my setup , you might be correct . The serial interface 0 is shutdown , and in the EIGRP process . will not send send and receive eigrp updates .

As i don't see any EIGRP routes

I have EIGRP neigbours in the same EIGRP 10 , but different router . How is it being connected ?

Purple

Re: problem with distribution list

Hi,

You would configure an interface as passive if you wanted to advertise the IP network configured on that interface as an internal EIGRP route but did not actually have any potential neighbors on that interface.

If you do see EIGRP neighbors, then it must mean that they exist on one of the two non-passive interfaces that you have.. Serial1 and Ethernet 0....

Pls do remember to rate posts.

Paresh

New Member

Re: problem with distribution list

Hi there , check with you , but when I put show ip eigrp int , it shows :

Interface Peers Un/Reliable SRTT

Et0 2 0/0 10

Se1 0 0/0 0

But i don' t see s0 , which the EIGRP is being configured , maybe is because it's being shut down .

Based on the output , just now , does that mean the se1 , is in EIGRP process

Purple

Re: problem with distribution list

That is correct - you do not see it because it is shut down. If you un-shut it, it will appear in the output.

However, due to the reasons I mentioned earlier, you will not see any neighbors over it.

EIGRP is certainly running over Serial1, which is why it appears in your output.

Pls do remember to rate posts.

Paresh

New Member

Re: problem with distribution list

Hi,

Sorry , I didn't get it . I did not enable EIGRP on Serial1 but on serial 0 . How come it's running on serial 1

Purple

Re: problem with distribution list

Hi,

The trick here is to understand what the 'network 10.0.0.0' statement under the EIGRP process is doing. It is basically telling the router to enable EIGRP on every interface that has an address that falls under the 10.0.0.0/255.0.0.0 network. Since the IP address of serial1 is 10.2.2.2, that makes it part of the 10.0.0.0/255.0.0.0 network. As a result, EIGRP runs on that interface.

Pls do remember to rate posts.

Paresh

New Member

Re: problem with distribution list

Thanks ,

There was routing issue , I take out the access-list on 11 and add a route which is on the other side , means I add a route on 10.3.3.1 router to add 10.1.2.128 with 255.255.255.128 .

But when I put back the access-list 11 , I can't ping a host in 10.1.2.30 , but when i remove the access-list , it's ok .

New Member

Re: problem with distribution list

on the access-list 11 , i changed the statement to

access-list 11 deny 10.2.2.0 0.0.0.255

access-list 11 permit 10.3.3.0 0.0.0.255

access-list 11 permit 10.1.2.128 0.0.0.127

but still , cannot ping a host on 10.1.2.30 .

I will be back , in a day

189
Views
28
Helpful
14
Replies
CreatePlease login to create content