Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem with Internet Connectivity on 871W router

I am trying to setup a 871W router to work as a wireless LAN in our lab. I would like to connect it to a shared internet port on our server for internet access (WAN port). I can ping router from the system thats connected to the router LAN (FE0) and I can also ping to the gateway (shared port) too. But I was not able to ping anything else outside that. No internet connectivity either.. This is the first time I am configuring a cisco router, it would be great if you can guide me in right direction.

thanks

4 REPLIES
Hall of Fame Super Silver

Re: Problem with Internet Connectivity on 871W router

Hello Pavan,

the following link can help

http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/wireless.html

what you need:

a default static route on the 871W pointing to the gateway port.

the internet gateway needs a route to the subnet that the 871W uses for the wireless lan

then because we use private ip addresses inside all networks someone has to do NAT:

or the internet gateway is configured for NAT of the wireless lan subnet or:

the 871W has to NAT the wireless lan ip subnet using its ip address on the wired link.

for NAT commands on the 871W look the following

http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/pppoenat.html#wpxref20820

you need

ip nat inside on the correct layer 3 radio interface

bvi 1 associated to vlan 1 = dot1q 1

int bvi1

ip nat inside

ip nat outside on ethernet towards gateway

access-list 10 permit 10.10.10.10 0.0.0.255

ip nat inside source list 10 inter fas0/0 overload

the gateway has to then NAT to be able to access the internet

Hope to help

Giuseppe

New Member

Re: Problem with Internet Connectivity on 871W router

I am attaching my config file.. is there something I need to change... I still cant access internet on my system connected to FE0. The WAN connection is the shared connection using a static IP.

Hall of Fame Super Silver

Re: Problem with Internet Connectivity on 871W router

Hello Pavan,

you should check the state of interface vlan1 and bv1

if you feel confident with telnet access

do

sh ip int brief

check if they are up/up

you may need to enable them with

conf t

int vlan 1

no shut

int bv1

no shut

2) does the PC connected to lan interface fas0 receive an ip address from the pool

you can check it from the shell

with ipconfig /all

on the router you can verify if NAT is working with

sh ip nat translations

3) to be noted I think you should a radio11 subinterface as in the example I linked from config guide

Hope to help

Giuseppe

New Member

Re: Problem with Internet Connectivity on 871W router

Sorry I didn't reply for a long time. I was able to get it running by using a excel worksheet provided on TechRepublic, with minor additions to make it work for mine.

thanks for your help.

153
Views
0
Helpful
4
Replies
CreatePlease to create content