Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Problem with IP addresses?????

Hi

Our network works over our ISP's IP VPN cloud and we are running BGP. We have several sites connecting to our main area centre.

We have a device(eg laptop) at site X which connects to a device(laptop) at our HQ. If we make the device(site x) x.x.x.1 /30 and our router interface x.x.x.2 /30 and try to do a simple file share over the network the link is extremely slow,400 - 500bps, yet if we swap the IP's around,ie device x.x.x.2 and our router interface x.x.x.1, then the connection is fine. We are blaming our ISP and they are saying it's our configuration that is the problem. I have tried different routers and there is no difference. We had a CCIE at our office last week and he couldn't understand the problem!

All our links work over fibre and terminate on a Hauwei Echolife ONU.

Attached is a partial configuration of a router at one of our sites.

Is there anyone that has perhaps had a similar problem over IP VPN?

interface FastEthernet0/0 - TO ISP

ip address 10.1.1.2 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1 - TO LAN

ip address 192.168.21.2 255.255.255.252

duplex auto

speed auto

!

router bgp 65001

bgp router-id 10.1.1.2

bgp log-neighbor-changes

neighbor 10.1.1.1 remote-as 64517

!

address-family ipv4

redistribute static

neighbor 10.1.1.1 activate

no auto-summary

no synchronization

network 192.168.21.0 mask 255.255.255.252

exit-address-family

6 REPLIES

Re: Problem with IP addresses?????

Can you post "sh int fa0/0" and "sh int fa0/1"?

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Problem with IP addresses?????

I will do so when I get to the office in the morning(I work in Abu Dhabi)

Thanks!!

New Member

Re: Problem with IP addresses?????

As requested.

Site A:

FastEthernet0/0 is up, line protocol is up

Hardware is MV96340 Ethernet, address is 0024.974e.10f0 (bia 0024.974e.10f0)

Description: $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$

Internet address is 10.1.1.122/30

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:03, output 00:00:03, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

17114 packets input, 19839708 bytes

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

26 input errors, 11 CRC, 15 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

22345 packets output, 9990891 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

FastEthernet0/1 is up, line protocol is down

Hardware is MV96340 Ethernet, address is 0024.974e.10f1 (bia 0024.974e.10f1)

Internet address is 30.30.30.2/30

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Auto-duplex, Auto Speed, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 22:24:38, output 00:00:06, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

13919 packets input, 9258741 bytes

Received 127 broadcasts, 1 runts, 0 giants, 0 throttles

11 input errors, 0 CRC, 10 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

25388 packets output, 20079729 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Not a lot of data on the port as I was busy testing the link with Vanguard routers before I copied the config's.

New Member

Re: Problem with IP addresses?????

Site B:

FastEthernet0/0 is up, line protocol is up

Hardware is MV96340 Ethernet, address is 0024.97c5.1828 (bia 0024.97c5.1828)

Internet address is 10.1.1.2/30

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 1000 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

1243 packets input, 192966 bytes

Received 50 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

2826 packets output, 178042 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

FastEthernet0/1 is up, line protocol is down

Hardware is MV96340 Ethernet, address is 0024.97c5.1829 (bia 0024.97c5.1829)

Internet address is 192.168.21.2/30

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Auto-duplex, Auto Speed, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 05:27:03, output 00:00:08, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

285 packets input, 24636 bytes

Received 70 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

2256 packets output, 173672 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Re: Problem with IP addresses?????

For starters, I would hardcode the duplex and speed settings. Try that and see if it helps. You don't have any CRC errors, which is usually and indication of mismatched duplex settings, but I would hard code to say the least.

I would also connect the routers the way that they're connected when you're having the problem, and then repost the "sh int" with the "slow" interface. I'm assuming that the slow interface is f0/1 when it's connected to the inside?

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Problem with IP addresses?????

Hi John

Thanks!

I'll post the configs tomorrow but it really doesn't matter how long the routers are connected. As soon as I connect them with this specific configuration the transfer between the 2 devices,both connected to the fa0/1interfaces, is slow. If I swap the the IP's around between the device and it's interface(fa0/1) then there's no problem!

Cheers

Greg

184
Views
0
Helpful
6
Replies
CreatePlease to create content