Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Problem With Multicast Redundancy

Hi All,

I have network with 4 asr1004 routers and two sites.

The main traffic in our network is multicast.

I have designed the network with OSPF on all the links and Anycast RP redundancy.

everything is working well except one thing.

When the Main RP router goes offline the multicast is sent through the second RP within couple seconds (1 to 3)

The problem is when the main RP is getting back online i am getting 60 seconds multicast freeze and i don't know why.

I will thank anyone who can help

Best Regards.

Everyone's tags (2)
4 REPLIES
Gold

Problem With Multicast Redundancy

Hi Yosi,

could u post ur anycast RP config for both RPs here plz?


Soroush.

Hope it Helps, Soroush.
New Member

Problem With Multicast Redundancy

Hi,

Here the RP configuration on both RP routers:

RTR1:

interface loopback 0

ip address 1.1.1.1 255.255.255.255

interface loopback 1

ip address 10.1.1.1 255.255.255.255

ip msdp peer 10.1.1.2 connect-source loopback 1

ip msdp originator-id loopback 1

ip pim rp-address 1.1.1.1

RTR2:

interface loopback 0

ip address 1.1.1.1 255.255.255.255

interface loopback 1

ip address 10.1.1.2 255.255.255.255

ip msdp peer 10.1.1.1 connect-source loopback 1

ip msdp originator-id loopback 1

ip pim rp-address 1.1.1.1

Thanks.

Gold

Problem With Multicast Redundancy

in case of failure, a couple of seconds to switch to the second RP is fine, though the 60 sec recovery time sounds too long here.

the config looks fine, but try adding ip pim sparse-mode to both of ur loopbacks on ur RPs, and double check if the OSPF router-id is different from the loopback addresses used here.

Hope it Helps,

Soroush.

Hope it Helps, Soroush.
New Member

Problem With Multicast Redundancy

Hi,

The problem eventually was very simple.

After i have made debug every aspect of multicast and msdp protocols i did not find anything wrong.

The solution was to change the carrier delay on the interface.

In my original configuration the carrir delay was 0ms.

I forgot that this means 0ms on both ways.

I changed the values:

Down 0ms

Up 10sec

After that everything worked fine.

Thanks for all the help.

Best Regards.

Yosi

488
Views
0
Helpful
4
Replies