Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Problem with traffic shaping a 3750 metro

I'm supporting several 3750 metro switches comprising a WAN.  The presentation speed of each multipoint layer2 interface throughout the WAN is being increased, so ive been asked to apply some shaping to limit egress speed dependent on the destination IP of the traffic. Advice ive been given is that the following example suits what i need:

ip access-list extended foo_acl

permit ip any 192.168.10.0 0.0.0.255

!

class-map match-any foo_class

match access-group foo_acl

!

policy-map foo_policy

class foo_class

shape average 10000000

!

int gig1/1/1

service-policy output foo_policy

Ive applied this. All goes in fine until i apply the service-policy to the ES interface. At that point, i get the errors:

QoS: Invalid match access-group in class foo_class

QoS: Invalid policy map foo_policy

Any idea what i'm doing wrong?

1 REPLY
Cisco Employee

Problem with traffic shaping a 3750 metro

Hi Jim,

Not sure about your IOS but I think this should be relevant.

From this page:

http://www.cisco.com/en/US/docs/switches/metro/catalyst3750m/software/release/12.2_37_se/configuration/guide/swqos.html#wp1281296

Class maps that contain ACLs are not supported in either an egress policy or in a hierarchical ingress policy attached to an ES port or EtherChannel. You cannot configure the match access-group acl-index-or-name class-map configuration command in a hierarchical policy map.

You can try matching the traffic based on vlans and shape it accordingly.

Here is the link which explains regarding "Configuring Shaping":

http://www.cisco.com/en/US/docs/switches/metro/catalyst3750m/software/release/12.2_37_se/configuration/guide/swqos.html#wp1282429

Here is the example from the link:

This example shows how to configure VLAN-level, average-rate shaping. It

limits each traffic class, vlan101 and vlan102, to a data transmission

rate of 400 Mbps.

Switch(config)# class-map match-all vlan101

Switch(config-cmap)# match vlan 101

Switch(config-cmap)# exit

Switch(config)# class-map match-all vlan102

Switch(config-cmap)# match vlan 102

Switch(config-cmap)# exit

Switch(config)# policy-map vlan-policy

Switch(config-pmap)# class vlan101

Switch(config-pmap-c)# shape average 400000000

Switch(config-pmap-c)# exit

Switch(config-pmap)# class vlan102

Switch(config-pmap-c)# shape average 400000000

Switch(config-pmap-c)# exit

Switch(config-pmap)# exit

Switch(config)# interface gigabitethernet1/1/1

Switch(config-if)# switchport trunk encapsulation dot1q

Switch(config-if)# switchport mode trunk

Switch(config-if)# service-policy output vlan-policy

Hope this helps,

Nik

370
Views
0
Helpful
1
Replies