Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problems connecting Cisco 887 VA router to Vodafone broadband

Hi All,

I am trying to connect a 887 VA router to Vodafone broadband in Ireland office. I am ripping my hair out now trying to get a connection to the internet. I have the following config - can anyone see where I have gone wrong?

I am connecting to ADSL+ service using built in modem in router over standard phone line. I have a static assigned external IP with the broadband service.

Thankyou so much to anyone who can help -  below the config is a screen shot of the show controller vdsl 0 command and the debug info that it gives.

!
!
no ip domain lookup
ip domain name globalhomeireland.com
ip host view Primary www.globalhomegroup.com 93.107.38.138
ip name-server 8.8.8.8
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
vpdn enable
!
vpdn-group 1
!
vpdn-group GLOBAL-VPN
! Default PPTP VPDN group
description Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1
!
license udi pid CISCO887VA-SEC-K9 sn FCZ172390QW
!
!
!
!
!
!
!
controller VDSL 0
!
no ip ftp passive
!
!
!
!
!
!
!
!
!
interface Loopback0
no ip address
!
interface Ethernet0
description $WAN_OUTSIDE$
no ip address
no ip route-cache
shutdown
pppoe enable
pppoe-client dial-pool-number 1
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
ip address 93.107.38.138 255.255.255.0
pvc 8/35
  protocol ip 89.19.65.189 broadcast
!
!
interface FastEthernet0
no ip address
no cdp enable
!
interface FastEthernet1
no ip address
no cdp enable
!
interface FastEthernet2
no ip address
no cdp enable
!
interface FastEthernet3
no ip address
no cdp enable
!
interface Vlan1
description Internal GH LAN
ip address 192.168.10.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Dialer0
description ADSL WAN Dialer
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip flow ingress
ip dns view-group Primary
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname xxxxxxxx@vodafone.com
ppp chap password 0 broadband
ppp pap sent-username xxxxxxxxx@vodafone.com password 0 broadband
no cdp enable
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
ip dns view Primary
ip nat inside source list 101 interface Dialer0 overload
ip nat inside source static tcp 192.168.10.1 3389 interface Dialer0 3389
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no service-routing capabilities-manager
dialer-list 1 protocol ip permit
no cdp run
!
access-list 101 permit ip 192.168.0.0 0.0.255.255 any
access-list 101 permit ip 192.168.10.0 0.0.0.255 any
access-list 101 permit ip any any
access-list 101 permit icmp any any
access-list 101 permit udp any any
--More--
!
control-plane
!
!
!
line con 0
exec-timeout 5 30
password ???????
login
no modem enable
line aux 0
line vty 0 4
password ????????
login
transport input all
!
!
end

Debug showing PPPoe stuff

Controller VDSL 0 is UP

Daemon Status:           Up

                        XTU-R (DS)              XTU-C (US)
Chip Vendor ID:         'BDCM'                   'IFTN'
Chip Vendor Specific:   0x0000                   0x8279
Chip Vendor Country:    0xB500                   0xB500
Modem Vendor ID:        'CSCO'                   '    '
Modem Vendor Specific:  0x4602                   0x0000
Modem Vendor Country:   0xB500                   0x0000
Serial Number Near:    FCZ172390QW 887VA-S 15.3(1)T
Serial Number Far:
Modem Version Near:    15.3(1)T
Modem Version Far:     0x8279

Modem Status:            TC Sync (Showtime!)
DSL Config Mode:         AUTO
Trained Mode:            G.992.5 (ADSL2+) Annex A
TC Mode:                 ATM
Selftest Result:         0x00
DELT configuration:      disabled
DELT state:              not running
Trellis:                 ON                       ON
SRA:                     disabled                        disabled
--More--
*Jul 31 13:46:56.066: (Ethernet0): Null atm_db
*Jul 31 13:46:56.066: (atm_vc_is_bridged_dot1q)ATM: VC with handle 0x0 not found

*Jul 31 13:46:56.066: (atm_vc_is_bridged_dot1q)ATM: VC with handle 0x0 not found
SRA count:              0                       0
Bit swap:                enabled                         enabled
Bit swap count:         1                       0
Line Attenuation:        25.0 dB                 11.1 dB
Signal Attenuation:      25.6 dB                 11.2 dB
Noise Margin:             6.2 dB                 11.4 dB
Attainable Rate:        22440 kbits/s            1192 kbits/s
Actual Power:             0.0 dBm                12.6 dBm
Total FECC:             440                      0
Total ES:               32                       0
Total SES:              31                       0
Total LOSS:             3                        0
Total UAS:              14825                    14825
Total LPRS:             0                        0
Total LOFS:             25                       0
Total LOLS:             0                        0

Full inits:             4
Failed full inits:      4
Short inits:            4
Failed short inits:     0

Firmware        Source          File Name (version)
--------        ------          -------------------
VDSL            embedded        VDSL_LINUX_DEV_01212008 (1)

Modem FW  Version:      120306_1254-4.02L.03.A2pv6C035j.d23j
Modem PHY Version:      A2pv6C035j.d23j
Vendor Version:         Ap6v35j.23j 68


                  DS Channel1     DS Channel0   US Channel1       US Channel0
Speed (kbps):             0            18428             0              1020
SRA Previous Speed:       0                0             0                 0
Previous Speed:           0            18428             0              1020
Total Cells:              0          2081256             0             91777
User Cells:               0              450             0                 0
Reed-Solomon EC:          0                0             0                 0
CRC Errors:               0             1379             0                 0
Header Errors:            0                0             0                 0
Interleave (ms):       0.00             7.89          0.00              1.13
Actual INP:            0.00             2.02          0.00              0.00

Training Log :  Stopped
Training Log :  Stopped

Everyone's tags (3)
1 REPLY
New Member

Problems connecting Cisco 887 VA router to Vodafone broadband

Your static IP address should be on the dialer interface not the atm0.1 interface

The atm config should be similar to:

interface atm0
no ip address
bundle-enable
dsl operating-mode auto
!
interface atm0.1 point-to-point
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
pvc 8/35
  pppoe-client dial-pool-number 1

Add the below to the dialer:

interface Dialer0

ip address 93.107.38.138 255.255.255.0

1792
Views
0
Helpful
1
Replies
CreatePlease login to create content