Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Problems connecting routers

I dont know if I'm just retarted or soemthing but I cannot get these 2 routers to connect.

I have two Cisco 2621XM router both equipped with NM-4A/S cards.

I connect router1 with a 1 foot dte/dce cable on serial 1/1 DTE side and the other on serial 1/2 DCE side.

Router1

int serial 1/1

ip address 155.1.0.1 255.255.255.252

encapsulation hdlc

Router2

int serial 1/2

ip address 155.1.0.2 255.255.255.252

clock rate 64000

encapsulation hdlc

Am I missing something?

I shutdown and unshut and the interface on router1 goes up and down after like 15 seconds. and I cant ping for the life of me.

Any advise?

5 REPLIES
Hall of Fame Super Bronze

Re: Problems connecting routers

The up/down is an indication that clocking is not configured in the link.

I see you have the clock-rate command at one side, which should be the DCE side. Can we verify that is indeed the DCE side by posting show interface controllers from both routers?

Thanks

__

Edison.

New Member

Re: Problems connecting routers

I changed routers and same problem

Router2 - DTE Side of cable

interface Serial1/1

ip address 155.1.0.1 255.255.255.252

R2#show controllers serial 1/1

CD2430 Slot 1, Port 1, Controller 0, Channel 1, Revision 19

Channel mode is synchronous serial

idb 0x84D45D08, buffer size 1524, V.35 DTE cable

Global registers

rpilr 0x2, rir 0x0, risr 0x0, rfoc 0x0, rdr 0x0

tpilr 0x1, tir 0x0, tisr 0x0, tftc 0x0, tdr 0x2

mpilr 0x3, mir 0x0, misr 0x0

bercnt 0xFF, stk 0x0

Per-channel registers for channel 1

Option registers

0x02 0x00 0x42 0xE7 0xE0 0x00 0x00

Command and status registers

cmr 0xC0, ccr 0x00, csr 0xC8, msvr-rts 0x11, msvr-dtr 0x11

Clock option registers

rcor 0x86, rbpr 0x01, tcor 0xC8, tbpr 0x01

Interrupt registers

ier 0x89, livr 0x04, licr 0x04

DMA buffer status 0x00

DMA receive registers

arbaddr 0x79C5024, arbcnt 1548, arbsts 0x1

brbaddr 0x79C56A4, brbcnt 1548, brbsts 0x1

rcbaddr 0x0

DMA transmit registers

atbaddr 0x0, atbcnt 0, atbsts 0x0

btbaddr 0x0, btbcnt 0, btbsts 0x0

tcbaddr 0x0

Special character registers

schr1 0x00, schr2 0x00, schr3 0x00, schr4 0x00

scrl 0x0, scrh 0x0, lnxt 0x11

Driver context information

Context structure 0x88141870, Register table 0x40800400

Serial Interface Control 5:1 Register (0x40800806) is 0x0

Adaptor Flags 0x0

Serial Modem Control Register (0x40800808) is 0x18

Receive static buffer 0x880DDFFC

Receive particle buffers 0x84D47880, 0x84D478C0

Transmit DMA buffers 0x0, 0x0, 0x0, 0x0

Transmit packet with particles 0x0, first word is 0x0

Interrupt rates (per second) transmit 0, receive 0, modem 0

True fast-switched packets 0

Semi fast-switched packets 0

Transmitter hang count 0

Residual indication count 0

Bus error count 0

Aborted short frames count 0

CRC short frames count 0

Tx DMA low threshold count 0

Error counters

CTS deassertion failures 0

Nested interrupt errors transmit 0, receive 0, modem 0

R2#show int serial 1/1

Serial1/1 is down, line protocol is down

Hardware is CD2430 in sync mode

Internet address is 155.1.0.1/30

MTU 1500 bytes, BW 128 Kbit/sec, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/0/32 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 96 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 40 interface resets

0 unknown protocol drops

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=down DSR=down DTR=up RTS=up CTS=down

New Member

Re: Problems connecting routers

Router3 - DCE Side

interface Serial1/3

ip address 155.1.0.2 255.255.255.252

clock rate 64000

R3#show controllers serial 1/3

CD2430 Slot 1, Port 3, Controller 0, Channel 3, Revision 19

Channel mode is synchronous serial

idb 0x84FEF208, buffer size 1524, V.35 DCE cable, clockrate 64000

Global registers

rpilr 0x2, rir 0x0, risr 0x0, rfoc 0x0, rdr 0x0

tpilr 0x1, tir 0x0, tisr 0x0, tftc 0x0, tdr 0x2

mpilr 0x3, mir 0x0, misr 0x0

bercnt 0xFF, stk 0x0

Per-channel registers for channel 3

Option registers

0x02 0x00 0x42 0x67 0x60 0x00 0x00

Command and status registers

cmr 0xC0, ccr 0x00, csr 0xC8, msvr-rts 0x11, msvr-dtr 0x11

Clock option registers

rcor 0x86, rbpr 0x01, tcor 0xC0, tbpr 0x11

Interrupt registers

ier 0x89, livr 0x0C, licr 0x0C

DMA buffer status 0x00

DMA receive registers

arbaddr 0x79CF324, arbcnt 1548, arbsts 0x1

brbaddr 0x79CECA4, brbcnt 1548, brbsts 0x1

rcbaddr 0x0

DMA transmit registers

atbaddr 0x0, atbcnt 0, atbsts 0x0

btbaddr 0x0, btbcnt 0, btbsts 0x0

tcbaddr 0x0

Special character registers

schr1 0x00, schr2 0x00, schr3 0x00, schr4 0x00

scrl 0x0, scrh 0x0, lnxt 0x11

Driver context information

Context structure 0x88144E64, Register table 0x40800400

Serial Interface Control 5:1 Register (0x4080080E) is 0x80

Adaptor Flags 0x0

Serial Modem Control Register (0x40800810) is 0x1D

Receive static buffer 0x84F739BC

Receive particle buffers 0x84FF0DC0, 0x84FF0D80

Transmit DMA buffers 0x0, 0x0, 0x0, 0x0

Transmit packet with particles 0x0, first word is 0x0

Interrupt rates (per second) transmit 0, receive 0, modem 0

True fast-switched packets 0

Semi fast-switched packets 0

Transmitter hang count 0

Residual indication count 0

Bus error count 0

Aborted short frames count 0

CRC short frames count 0

Tx DMA low threshold count 0

Error counters

CTS deassertion failures 0

Nested interrupt errors transmit 0, receive 0, modem 0

R3#show int serial 1/3

Serial1/3 is down, line protocol is down

Hardware is CD2430 in sync mode

Internet address is 155.1.0.2/30

MTU 1500 bytes, BW 128 Kbit/sec, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/0/32 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 96 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 49 interface resets

0 unknown protocol drops

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=down RTS=down CTS=up

Now the connection does not come up at all. I cant get it to go up or down.

Any advise?

New Member

Re: Problems connecting routers

Ok figured it out. BAD Serial card!!

What a waste of time.

Hall of Fame Super Bronze

Re: Problems connecting routers

Thanks for posting the resolution of your problem, it makes the forum more useful.

Rated accordingly.

__

Edison.

177
Views
5
Helpful
5
Replies
CreatePlease to create content