Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Problems with Cisco 887 3G functionality

Hi,

I have a question about the configuration of the 3G functionality on the cisco 887 router. The 3G connection should be the primary connection, because I don't have a direct internet connection. I make use of a data card of KPN NL. On the internet I found some information about the configuration of the 3G module, but won't get a 3G connection. If I look to the gsm profiles I see that the profile is still inactive. Can someone help me with the configuration of the 3G functionality and tell me how to activate the gsm profile?

Many thanks,

Frits

Everyone's tags (3)
3 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

Problems with Cisco 887 3G functionality

Hi Frits,

Make sure the SIM card is not locked with a pin code, you can check from the router with

sh cell 0 security

If the output contains "SIM Status = Locked" then  type  cellular 0 gsm sim unlock [current pin code] to unlock the card.

When  you are sure there is no PIN, you can use the following template:

cellular 0/0/0 gsm profile create 1 office.vodafone.nl ipv4 pap vodafone vodafone

interface Cellular0/0/0

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer in-band

dialer string gsm

dialer-group 1

async mode interactive

ppp authentication pap callin

ppp chap refuse

ppp pap sent-username vodafone password 0 vodafone

end

dialer-list 1 protocol ip list 1

!

chat-script gsm "" "atdt*98*1#" TIMEOUT 30 "CONNECT"

line 0/0/0

exec-timeout 0 0

password vodafone

script dialer gsm

login

modem InOut

no exec

rxspeed 7200000

txspeed 2000000

ip route 0.0.0.0 0.0.0.0 Cellular0/0/0 permanent

Silver

Problems with Cisco 887 3G functionality

Hi Frits,

OTASP activation is used only for CDMA cards (used in USA and India, mostly). In your case, being KPN NL, I assume is a GSM card.

The configuration you applied seems correct, except for the modem line.

You need to enable "modem inout" and associate the chat script under the line used by your modem. In your config, it should be line 3, but you can double check it with a "show line".

For example:

line 3

exec-timeout 0 0

script dialer gsm

login

modem InOut

no exec

After that, you can enable these debugs:

- deb ppp nego

- deb chat

- deb dialer

In show cellular I see that the modem can already connect to KPN, with a good RSSI (-70), so once corrected the config you shouldn't have problems.

Let me know if it works

Cheers

Marco

Silver

Re: Problems with Cisco 887 3G functionality

OK, you can see that right now the profile is active, so IOS and modem are connected. You also got an IP address from the Telco:

Profile Information

====================

Profile 1 = ACTIVE

Data Transmitted = 13179 bytes, Received = 0 bytes

Profile 1, Packet Session Status = ACTIVE

        IP address = 188.206.51.54

For the debugs, change logging buffered to debugging instead of warnings, restart the cell link and check in show log.

If you try to ping from the cell interface (e.g. 8.8.8.8, google's DNS), it should work, can you try?

If you are trying to ping from the lan, the IP NAT config is incomplete, so it won't work.

Can you add the following:

interface vlan1

  ip nat inside

ip nat inside source list 23 interface cellular0 overload

(you have already access-list 23 configured, it will allow only lan's IP subnet)

Cheers

Marco

8 REPLIES
Hall of Fame Super Silver

Problems with Cisco 887 3G functionality

Hello Fritz,

the exact procedure is carrier dependent and hardware dependent

have a look at configuration guide about activation of the modem see

http://www.cisco.com/en/US/docs/routers/access/1800/1861/software/feature/guide/mrwls_evdo.html#wp1495984

there are also some older threads with answers from Cisco engineer Vespignani

Hope to help

Giuseppe

New Member

Problems with Cisco 887 3G functionality

Hi Frits,

Make sure the SIM card is not locked with a pin code, you can check from the router with

sh cell 0 security

If the output contains "SIM Status = Locked" then  type  cellular 0 gsm sim unlock [current pin code] to unlock the card.

When  you are sure there is no PIN, you can use the following template:

cellular 0/0/0 gsm profile create 1 office.vodafone.nl ipv4 pap vodafone vodafone

interface Cellular0/0/0

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer in-band

dialer string gsm

dialer-group 1

async mode interactive

ppp authentication pap callin

ppp chap refuse

ppp pap sent-username vodafone password 0 vodafone

end

dialer-list 1 protocol ip list 1

!

chat-script gsm "" "atdt*98*1#" TIMEOUT 30 "CONNECT"

line 0/0/0

exec-timeout 0 0

password vodafone

script dialer gsm

login

modem InOut

no exec

rxspeed 7200000

txspeed 2000000

ip route 0.0.0.0 0.0.0.0 Cellular0/0/0 permanent

New Member

Re: Problems with Cisco 887 3G functionality

Hi Giuseppe & pk21,

I think the activation of the modem still need to be done, but the command for activation is not working. I have tried the following command: cellular 0 cdma activate otasp *22899

I already unlocked the SIM card, and followed your template. The SIM card that I'm using is from KPN NL, and I received the following login information:

APN: internet

username: internet

password:

When I'm creating the gsm profile I need to enter a password as well, so I also entered internet as password.

Please find attached config file and cellular info.

Silver

Problems with Cisco 887 3G functionality

Hi Frits,

OTASP activation is used only for CDMA cards (used in USA and India, mostly). In your case, being KPN NL, I assume is a GSM card.

The configuration you applied seems correct, except for the modem line.

You need to enable "modem inout" and associate the chat script under the line used by your modem. In your config, it should be line 3, but you can double check it with a "show line".

For example:

line 3

exec-timeout 0 0

script dialer gsm

login

modem InOut

no exec

After that, you can enable these debugs:

- deb ppp nego

- deb chat

- deb dialer

In show cellular I see that the modem can already connect to KPN, with a good RSSI (-70), so once corrected the config you shouldn't have problems.

Let me know if it works

Cheers

Marco

New Member

Re: Problems with Cisco 887 3G functionality

Hi Marco,

I have added the config for line 3, but still no internet connection available.

The debug commands are enabled, but didn't show any feedback (if I'm right). In the logging I see that the Cellular0 modem is inserted and that the modem is up.

New config file and cellular 0 interface added.

UPDATE: Now I see that my gsm profile is active, so there is a connection, only there is no internet. (both LED's are solid blue, not blinking anymore)

Silver

Re: Problems with Cisco 887 3G functionality

OK, you can see that right now the profile is active, so IOS and modem are connected. You also got an IP address from the Telco:

Profile Information

====================

Profile 1 = ACTIVE

Data Transmitted = 13179 bytes, Received = 0 bytes

Profile 1, Packet Session Status = ACTIVE

        IP address = 188.206.51.54

For the debugs, change logging buffered to debugging instead of warnings, restart the cell link and check in show log.

If you try to ping from the cell interface (e.g. 8.8.8.8, google's DNS), it should work, can you try?

If you are trying to ping from the lan, the IP NAT config is incomplete, so it won't work.

Can you add the following:

interface vlan1

  ip nat inside

ip nat inside source list 23 interface cellular0 overload

(you have already access-list 23 configured, it will allow only lan's IP subnet)

Cheers

Marco

New Member

Problems with Cisco 887 3G functionality

You were right first I was only able to ping from the cell interface to the DNS of Google. After adding the commands to my config, just as you said, the internet connection was also established on the connected devices. So everthing is working fine now.

Thanks a lot for all your help!

Silver

Problems with Cisco 887 3G functionality

Cool! I'm glad it worked

Cheers

Marco

3673
Views
15
Helpful
8
Replies
CreatePlease to create content