Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problems with DHCP - windows Vista

I'm having trouble getting my Vista clients to accept DHCP from the router.  XP are working fine.

I have attached the config - I suspect I may need a newer version or the IOS.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Problems with DHCP - windows Vista

Hi,

Before implementing vista on this environment; have you not checked this thing ?

I will check for router commands, please provide me your router information. router to L3 switch connectivity and L3 switch to LAN connectivity.

Thanks

Jigar

10 REPLIES
New Member

Re: Problems with DHCP - windows Vista

Hello,

The problem occurs with DHCP flag in Vista.

To resolve this issue yourself, disable the DHCP  BROADCAST flag in Windows Vista. To do this, follow these steps:

click on start - run - type cmd - type regedit
locate
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}
create new -  click DWORD (32 bit) value
in box - type DhcpConnEnableBcastFlagToggle - press enter
right click on DhcpConnEnableBcastFlagToggle - modify - value data box - type  1 - click ok
close regedit

by doing this Windows Vista will first try to obtain an IP address by using the BROADCAST flag in DHCP Discover packets. If that fails, it will try to obtain an IP address without using the BROADCAST flag in DHCP Discover packets.

HTH

Jigar Dave

New Member

Re: Problems with DHCP - windows Vista

Many thanks for your response.

This is a managed network so not that easy to change all the PC's - is there an updated version of the IOS or command I can enter to negate this on the switch?

Thanks

Rob

New Member

Re: Problems with DHCP - windows Vista

Hi,

Before implementing vista on this environment; have you not checked this thing ?

I will check for router commands, please provide me your router information. router to L3 switch connectivity and L3 switch to LAN connectivity.

Thanks

Jigar

New Member

Re: Problems with DHCP - windows Vista

It a system I have inherited! Routers are Cisco 1800

New Member

Re: Problems with DHCP - windows Vista

Hi,

I tried MS KB 928233 - and this doesn't resolve it.  Also this affects Windows 7 which works differently.

I am at a complete loss as to why they won't received DHCP addresses from the switch.  XP is working fine.

New Member

Re: Problems with DHCP - windows Vista

I also see this from the Vista client and response from switch

1w6d: DHCPD: Sending DHCPOFFER to client 0100.1d92.0650.5e (192.168.200.172).
1w6d: DHCPD: creating ARP entry (192.168.200.172, 001d.9206.505e).
1w6d: DHCPD: unicasting BOOTREPLY to client 001d.9206.505e (192.168.200.172).
1w6d: DHCPD: DHCPREQUEST received from client 0100.1d92.0650.5e.
1w6d: DHCPD: Sending DHCPACK to client 0100.1d92.0650.5e (192.168.200.172).
1w6d: DHCPD: creating ARP entry (192.168.200.172, 001d.9206.505e).
1w6d: DHCPD: unicasting BOOTREPLY to client 001d.9206.505e (192.168.200.172).
1w6d: DHCPD: DHCPDISCOVER received from client 0100.1d92.0650.5e on interface Vlan200.

New Member

Re: Problems with DHCP - windows Vista

I managed to resolve this - nothing to do with DHCP broadcasts.

I removed the subnet mask from the default gateway and it works fine on Vista and 7 now.

New Member

Re: Problems with DHCP - windows Vista

rasoftware,

please share what you mean exactly that 'you removed subnet mask from the gateway'

thank you in advance.

New Member

Re: Problems with DHCP - windows Vista

Wow that was a nice find.

Now i know why it sometimes worked with me and sometimes didn't after reconfiging my router

ip dhcp pool pool2
   network 10.2.0.0 255.255.255.0
   dns-server 10.2.0.0 255.255.255.0
   default-router 10.2.0.1 255.255.255.0 <-------------- I'm pretty sure he is refering to that subnet mask.

ip dhcp pool pool2
   network 10.2.0.0 255.255.255.0
   dns-server 10.2.0.0 255.255.255.0
   default-router 10.2.0.1

BTW MS is POS

New Member

Re: Problems with DHCP - windows Vista

That's the one.

For some reason XP is ok with this in the DHCP response but rightly Vista/7 rejects this.

It was a system I inherited so not a config I would normally do.

Hope this helps anyone with similar issues.

The DHCP broadcast is resolved in 12.2 I believe

2768
Views
7
Helpful
10
Replies