Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Problems with IOS upgrade

I'm having some issues with upgrading my IOS with regards to my Catalyst 4506 switches.

Just to recap, prior to performing the IOS upgrade, I did a "show version" command to see where the old IOS was located, however in the bootflash: line, I didn't see any image filepath. It was blank.

I also did a "show run | include boot system" to see if there were any boot commands that have been entered and I got nothing.

Anyway I decided to just to upload the new IOS to the switch and I issued the "boot system flash bootflash:<new IOS filenaem> command, followed by the "write memory" command and finally reloading the switch.

Unfortunately when the reload was completed, the device was (and is) still pointing to the older IOS instead of the new one.

Any ideas why this might be the case? I didn't delete the older IOS either as it is still in the switch's bootflash.

5 REPLIES

Re: Problems with IOS upgrade

Cisco Employee

Re: Problems with IOS upgrade

Hi Prashant,

Can you please post your config register value?

"sh version" should give you the same.

Regards,

Ankur

New Member

Re: Problems with IOS upgrade

hi ankur, yeap I think the problem lies in the config register. Currently the config register for the affected device is set at 0x2101 instead of 0x2102 i think that is the root of my problem, will set it accordingly and check.

Thank you.

Cisco Employee

Re: Problems with IOS upgrade

Hi Prashant,

Yes you got it right once it is set to 0x2102 it will check the boot feild and will boot with the image which is specified in boot feild parameter.

Regards,

Ankur

*Pls rate all helpfull post

New Member

Re: Problems with IOS upgrade

i rekon above post were pretty helpful now one thing to add.....even u added a new ios and even the config register is 2102.....still i believe the older ios would be loaded all the time....it is because of the fact that router loads by default the first available ios present now inorder to load the new ios u have to do bootflash command......hope it solves the issue.....regards

117
Views
0
Helpful
5
Replies