Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Problems with isdn pri line

ive configured cisco 2811 routers, each with a WIC installed. Router "A" has a multiport WIC installed (2 ports) and router "B" has a single port WIC installed.

Both configurations are the same, except for the router with the dual-port WIC which have an extra controller and serial interface.

this is how it looks:

no ftp-server write-enable

isdn switch-type primary-net5

!

!

!

controller E1 0/0/0

channel-group 0 unframed

!

!

controller E1 0/0/1

channel-group 0 unframed

!

!

interface Loopback1

ip address 192.168.1.1 255.255.255.0

!

interface FastEthernet0/0

ip address 154.x.x.10 255.255.0.0

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:0

ip address 192.168.10.1 255.255.255.0

encapsulation ppp

!

!

interface Serial0/0/0:0

ip address 192.168.10.1 255.255.255.0

encapsulation ppp

!

The ISDN line "should" be ready for use but i get "line down, protocol down" on both routers serial interface...

sadly im home and have no way of troubleshooting on this right now, but is there something obvious that i wrongly configured or missing. i pasted the relevant part of the config.

i did a little test before i left the site, i took an already working ISDN line cable from a NT box, and plugged it into my WIC port2 and immedialy the line and protocol went up/up, the same happent in the other end. i took and unplugged a random ISDN "cable" and plugged it into that router as well and same thing happent "line and protocol went up/up" in a 1sec.

im not strong on WAN and ISDN so when the custumer said that the new isdn line (PRI) was the same as the old, i simply copied the command "isdn switch-type primary-net5" on to the new router...

what im looking for is if i did something worng that causes the interfaces to stay down/down or maybe its the ISP who did not prepare the ISDN line as promised or maybe its a patch/cable problem.

ive found some good debugging/troubleshooting commands ill use on tuesday when i can enter the site, but i really hope this is not my fault. obvisouly.

4 REPLIES
New Member

Re: Problems with isdn pri line

Hi Thomas

I don't know if this is the answer to your problem but whenever I have configured PRI lines in the past I have always specified the timeslots configured as quite often not all 31 channels are purchased from the carrier. The command for this is as follows.

Controller E1 1/0

pri-group timeslots 1-12

I suspect that your problem is related to a physical issue rather than the timeslots but you may need this later.

Let me know if this helps

Martin

Re: Problems with isdn pri line

Hello Thomas,

in addition to Martin´s post, can you do a ´show controllers e1´ on your router when the non-working modem is connected ? I guess the fact that your interfaces go up/up with a working ISDN line shows that the configuration is fine. Just be aware that with the ´channel-group 0 unframed´ command, all 32 channels are used for data. I would check first if your provider can get to their modem (or you can reset the modem yourself and see what happens). One other thing you could try is to toggle the framing on the E1 controller, that is, set it to ´framing no-crc4´ and then back to ´framing crc4´.

HTH,

GNT

New Member

Re: Problems with isdn pri line

Hi martin, let me show you the original configuration as it was before i added the new WIC (with 2 ports)

------------------------------------

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Hoersholm

!

boot-start-marker

boot-end-marker

!

enable secret xxxx

enable password xxxx

!

no network-clock-participate wic 0

no network-clock-participate aim 0

no network-clock-participate aim 1

no aaa new-model

ip subnet-zero

!

!

ip cef

!

!

no ftp-server write-enable

isdn switch-type primary-net5

!

!

!

controller E1 0/0/0

channel-group 0 unframed

!

!

interface Loopback1

ip address 192.168.2.1 255.255.255.0

!

interface FastEthernet0/0

ip address 192.100.200.10 255.255.0.0

duplex auto

speed auto

!

intesh runrface FastEthernet0/1

no ip address

shutdown

duplex auto

speed autosh

!

interface Serial0/0/0:0

ip address 192.168.20.1 255.255.255.0

encapsulation ppp

!

ip classless

ip route 154.151.x.x.255.0.0 Serial0/0/0:0

ip route 192.168.10.0 255.255.255.0 Serial0/0/0:0

ip route 192.168.1.0 255.255.255.0 Serial0/0/0:0

ip route 192.100.0.0 255.255.0.0 FastEthernet0/0

ip http server

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

password xxxx

login

!

scheduler allocate 20000 1000

!

end

---------------------------------------

as you can see they have no timeslot commands added or linecode or anything. all i did was to add the new WIC with 2 ports. and after all, the new WIC port is workign fine in the old NT box. any timeslot command would be seen in "sh run" right?

something im missing or is this an issue with the new NT box?

GNT,

yes im very curious to try "sh controller e1" on tuesday when i can enter the site. I did try the old NT on the new WIC 1 port, which worked fine, but im also curious to try the new NT on the old WIC 0 port. if WIC 0 (which is working fine now) goes down/down when connecting to the new NT line, it has to be the new NT box that has a problem as i see it.

Re: Problems with isdn pri line

Hello,

I would agree, the config looks ok. What you could do even before getting to the site is contact your provider and have them check the connectivity to their modem, they can do that remotely and should be able to see it. If there is a problem, they can already start working on it, which probably saves you some time...

Regards,

GNT

121
Views
0
Helpful
4
Replies
CreatePlease to create content