Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Process sequencing

Please,

When you try many process like PBR, NAT, ROUTING, IPSEC, GRE, ARP ETC..

For example i know that nat is running before nat.

I need information about sequence of this process, means the first process , second, third and ... ?

Do you have a document about real sequence for all process ?

Regards.

6 REPLIES
New Member

Re: Process sequencing

i make a mistake, i would like to say that "nat is running before ipsec".

Regards.

Silver

Re: Process sequencing

This is a very important concept to understand especially if you want to do un-orthodox tricks with NAT. I am sure you will find the information in this link helpful as it shows the correct order of various processes in both directions; for in -> out and from out -> in:

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080133ddd.shtml

New Member

Re: Process sequencing

i need more information. The sequence is not explain with more detail.

i have a router with this configuration:

RTA:

int e0/0

ip nat in

ip address 192.168.1.1 255.255.255.0

ip address 196.201.1.2 255.255.255.0 sec

int e0/1

ip nat out

ip policy route-map internet

ip address 192.161.2.2 255.255.255.0

ip route 0.0.0.0 0.0.0.0 196.201.1.1 name ISP2

ip nat pool fiber-internet 196.161.2.1 192.161.2.1 prefix-length 29

ip nat inside source route-map internet pool fiber-internet overload

route-map internet permit 5

match ip address 104

set ip next-hop 192.161.2.1

route-map internet permit 5

match ip address 103

access-list 103 permit ip 192.168.1.0 0.0.0.255 any

access-list 104 permit ip host 192.168.1.3 any

Is with configuation when 192.168.1.3 try to join internet to go to isp 1 (the nat is take in account)

after translation to 192.161.2.1 (inside global address).

When other host than will use isp 2 with ip address 196.201.1.1 (inside global address)

if it not correct which configuartion i can try ??

Regards.

Silver

Re: Process sequencing

Can you please explain what you are trying to achieve and what does your setup look like? I am interested to know how your inside network is connected to both ISPs.

New Member

Re: Process sequencing

Good day,

the set up i give to you, is an case study.

I want to understand the different step take by router which make nat+PBR like you can see on the exmaple.

Regards.

Silver

Re: Process sequencing

Does this case study come with a topology diagram? I am asking for additional details as there are a couple of confusing, and possibly erroneous configuration statements (not applied to the correct interface), in the configs you have put here.

If you provide a link to this case study I can better explain all the steps to you.

252
Views
3
Helpful
6
Replies