Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Proposal for load balancing Internet connections - could this work ?

Hi,

Could this idea work ??

In the attached diagram 2 x 4Mbit internet pipes have been obtained from 1 ISP. Both in active / active mode.

Outgoing Traffic:

The 2 CE routers at the customer site both have full BGP IP tables for the internet. They pass a default route to the ASA's (or the ASA's simply point a default route to the directly connected CE Router). The 2 CE routers both provide the same customer address space and connect to the ASA's on the same subnet / Vlan.

The ASA's connect to our core routers over Dot1q trunks and perform NAT for our internal 172.16.0.0 address range into the IS provided customer address space for the Internet.

The ASA's participate in OSPF routing with the MA core routers and carry out a default information originate, or the Core routers simply use a default route pointing to the ASA's over each Dot1q trunk.

Each core router then has an equal cost path through each CE router to get out onto the internet.

Incoming Traffic:

Because BGP cannot load balance in the ISP cloud, incoming traffic will only ever take one path back to the customer site (which ever BGP metric is used - weight, pref, MED etc).

Therefore, configure static routes within the ISP cloud on the aggregate router for the 2 ISP CE Routers.

2 Static routes are configured pointing to the customer internal network via each CE router.

This should then load balance incoming traffic over each CE router.

Thanks in advance.

3 REPLIES
New Member

Re: Proposal for load balancing Internet connections - could thi

I think you could load balance the internal traffic at the siwtch to the two ISP routers:

Sample

interface GigabitEthernet3/3

description "GE to ncores1"

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 177,240-247

switchport mode trunk

channel-group 5 mode on

!

interface Vlan245

ip address 172.16.245.3 255.255.255.0

no ip redirects

no ip unreachables

no ip igmp snooping explicit-tracking

no ipv6 mld snooping explicit-tracking

no ipv6 mld snooping

glbp 245 ip 117.16.245.1

glbp 245 priority 108

glbp 245 preempt

!

interface Vlan246

ip address 172.16.246.3 255.255.255.0

no ip redirects

no ip unreachables

no ip igmp snooping explicit-tracking

no ipv6 mld snooping explicit-tracking

no ipv6 mld snooping

glbp 246 ip 172.16.246.1

glbp 246 priority 110

glbp 246 preempt

New Member

Re: Proposal for load balancing Internet connections - could thi

Hi,

I think this would only load balance outgoing traffic - by using GLBP.

I need to know if my solution using static routes in the ISP cloud pointing to our customer assigned address space wuld achieve load balancing for incoming traffic ?

Can anyone help ?

New Member

Re: Proposal for load balancing Internet connections - could thi

Hi,

Can anyone help me out with this ?

446
Views
0
Helpful
3
Replies
CreatePlease login to create content