Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Protocol routing over second link

Is it possible to route http traffic over a DSL connection while all other traffic routes over a T1? I have a customer who is asking that all their users web traffic route over the DSL line instead of the T1, but all other traffic must go over the T1. I looked for examples of port based route maps, but came up blank. I remember something years back when the blaster came about where I was able to dump all netbios to a null interface, but cant remember how I did it.

5 REPLIES

Re: Protocol routing over second link

A not-so-elegant way (IMO) would be to use policy based routing using the precedence on HTTP traffic (which you would have to change with QoS/NBAR).

http://www.cisco.com/en/US/products/ps6599/products_white_paper09186a00800a4409.shtml#wp14040

New Member

Re: Protocol routing over second link

Well thats a start showing it can be done, but again, no basic examples of what to do. More importantly has anyone successfully done it?

New Member

Re: Protocol routing over second link

Well thats a start showing it can be done, but again, no basic examples of what to do. More importantly has anyone successfully done it?

Hall of Fame Super Bronze

Re: Protocol routing over second link

Here is a sample config

interface fx/x

description incoming interface

ip address 192.168.1.1 255.255.255.0

ip policy route-map HTTP

ip access-list extended HTTP

permit tcp any any eq 80

permit tcp any any eq 443

route-map HTTP permit 10

match ip address name HTTP

set ip next-hop [dsl_gateway]

route-map HTTP permit 20

ip route 0.0.0.0 0.0.0.0 [T1_Gateway]

_________

Packets not matching the destination Port 80 and 443 (HTTPS) will use the normal IP route.

The problem you may face is the NAT.

Can you post a portion of your config that we can work from?

HTH,

__

Edison.

New Member

Re: Protocol routing over second link

Excellent, this was the part I was missing that I couldn't locate.

route-map HTTP permit 10

match ip address name HTTP

set ip next-hop [dsl_gateway

Thanks, I will give it a try and hopefully will work. The DSL modem/router should already be setup for NAT, so that shouldn't affect it, but I wont know until I dig into the router and see how they currently have the DSL setup. We normally use DSL/Cable for backup purposes only using a GRE tunnel with EIGRP runnign over that. If they arent setup that way, then this should work OK, if they are, then this will not work since the router/modem will be bridged and will cause havoc if I enable NAT.

108
Views
0
Helpful
5
Replies
CreatePlease to create content