Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PUBLIC IPS NATING

Hi i got recently job as a network admin and i am new to this .now our company is shifting from one isp to another isp .the new isp gave us a public ip xx.xx.228.130 as costumer ip . later our manager requested for some more ips den they added xx.xx.236.72/29 pool to our previous ip. now my task is to give configure these ips on a 800 series router and give rdp connection to a server. i have connected the isp connection to router WAN port . can any one please tell me next what i need to do , how should i do NATing .does the WAN interface on router has all the ips if so how to divide dem and NAT. reply me soon

thankyou

1 ACCEPTED SOLUTION

Accepted Solutions

PUBLIC IPS NATING

Hello

Can you post your running config or the wan router?

You will need to nat your lan ip range (private) to a isp public adddress either with a range of public ips or to just one

example:

interface FastEthernet0/0

description LAN

ip address 172.16.1.1 255.255.255.0

ip nat inside

interface FastEthernet0/1

description IPS WAN

ip address 20.20.20.5 255.255.255.248

ip nat outside

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 20.20.20.6

access-list 1 permit 172.16.1.0 0.0.0.255

ip nat inside source list 1 interface FastEthernet0/1 overload

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.
7 REPLIES

PUBLIC IPS NATING

Hi,

Your ISP might have already routed those new IPs to your network. You need to use one of those IPs to NAT the server ip.

Refer to below link with necessary examples..

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094e77.shtml

Google for more examples. For RDP you need to open port 3389.

If you still experience issues with this, post your router config, someone will check on that.

Thx

MS

New Member

PUBLIC IPS NATING

thanks for replying mvsheik123

my router wan interface has a ip xx.xx.228.130 and 6 ips from pool XX.XX.236.72/29 binded to it , now i just need to NAT one of thee public ip to my server to provide rdp ,how should i do .there are 4 lan ports on my router.

New Member

PUBLIC IPS NATING

And also my public ip is class A , so should i use class A private ip or any class ip . my company uses class C private ip addresses to servers (192.168.100.xx)

PUBLIC IPS NATING

Hello

Can you post your running config or the wan router?

You will need to nat your lan ip range (private) to a isp public adddress either with a range of public ips or to just one

example:

interface FastEthernet0/0

description LAN

ip address 172.16.1.1 255.255.255.0

ip nat inside

interface FastEthernet0/1

description IPS WAN

ip address 20.20.20.5 255.255.255.248

ip nat outside

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 20.20.20.6

access-list 1 permit 172.16.1.0 0.0.0.255

ip nat inside source list 1 interface FastEthernet0/1 overload

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.

PUBLIC IPS NATING

Hi Mohammad,

You can use any class ip internally (as they are pvt Ips).  Also, you connect you LAN switch directly to the router port or thru firewall? Also, as Paul suggested, can you post the router config?

Thx

MS

New Member

PUBLIC IPS NATING

thankyou i will post my running config tomrw , another thing which type of nating should i use ( static , dynamic ,pat)

and hw many public ips i have for xx.xx.228.130 ( it is the isp interface connected to router wan ) and xx.xx.236.72/29 binded to this interface

Re: PUBLIC IPS NATING

Hello

Sounds like dynamic nat is the way to go

Once we have your config we can advise you

Res
Paul

Sent from Cisco Technical Support iPad App

Please don't forget to rate any posts that have been helpful. Thanks.
168
Views
5
Helpful
7
Replies
CreatePlease login to create content