Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

QOS Assistance

In the below class map can some one explain is the default classs required ?

I am matching everything under AF2x.. Any suggestions is highly appreciated..

____________________________________________________________________
  Policy Map pmmpls5
    Class cm_voice
      set dscp ef
    police cir 8000
      conform-action transmit
      exceed-action set-dscp-transmit af41
      priority 8
    Class cm_traffic_control
    police cir percent 20
      conform-action set-dscp-transmit af31
      exceed-action set-dscp-transmit af21
    Class cm_af4x
      set dscp af41
      bandwidth 18000
    Class cm_af3x
      set dscp af31
      bandwidth remaining 50
    Class cm_af2x
      set dscp af21
      bandwidth remaining 30
    Class cm_be
      set dscp default
      bandwidth remaining 20

  Policy Map Link_Shaper
    Class class-default
      Average Rate Traffic Shaping
      cir 95%
      service-policy pmmpls5
_______________________________________________________________________

Class Map match-any cm_voice
  description Voice Traffic
  Match  dscp ef
  Match ip  precedence 5
  Match ip  rtp 16384 16383
  Match access-group name acl_voice

Class Map match-any cm_traffic_control
  description Exchange Traffic
  Match access-group name acl_traffic_control

Class Map match-any cm_af4X
  description Video Traffic
  Match ip  precedence 6
  Match ip  precedence 7
  Match ip  precedence 4
  Match ip  dscp cs6
  Match ip  dscp cs7
  Match access-group name acl_af4x
  Match protocol telnet
  Match protocol citrix
  Match protocol h323
  Match protocol tftp

Class Map match-any cm_af3X
  Match protocol sqlnet
  Match protocol sqlserver
  Match access-group name acl_af3x

Class Map match-any cm_af2X
  Match access-group name acl_af2x

Class Map match-any cm_be
  Match access-group name acl_be

Class Map match-any class-default
  Match any
________________________________________________________________________

ip access-list extended acl_voice
remark Voice siganllaing and real time traffic
permit tcp any any range 2000 2002
permit tcp any any range 1718 1731
permit tcp any range 1718 1731 any
permit udp any any eq 2427
permit tcp any any eq 2428
permit udp any any eq 5036
permit udp any any eq 5060
permit udp any any eq 5004
permit udp any any eq 4569
permit tcp any any range 11000 11999
permit ip host X.X.X.X any
permit ip host X.X.X.X any

ip access-list extended acl_traffic_control
remark Exchange Traffic
permit ip host X.X.X.X any
permit ip host X.X.X.X any

ip access-list extended acl_af4x
remark Video and Telepresence Traffic
permit ip any host X.X.X.X
permit ip any host X.X.X.X
permit ip any host X.X.X.X
permit ip any X.X.X.X
permit ip any X.X.X.X
permit ip any X.X.X.X

ip access-list extended acl_af3x
remark WHQ AD and Kronos Traffic
deny  ip any X.X.X.X
permit ip any X.X.X.X
permit ip any X.X.X.X
permit ip any X.X.X.X

ip access-list extended acl_af2x
remark Any Traffic
permit ip any any

__________________________________________________________________________________________________________________________

Regards Vinayak
Everyone's tags (1)
4 REPLIES

QOS Assistance

1] I see that you have mixed "bandwidth" and "bandwidth remaining percent / bandwidth percent" . You cannot configure this together in same policy. It will give you an error.

2] Is this configuration going to be on sub-interface ?

New Member

Re: QOS Assistance

1) I want assure 18 meg to cm_af4x..Is there any other way of doing it?

2) No..it will be applied over physcal interface

Regards Vinayak

Re: QOS Assistance

1] You can you policing there as there is not option or you can calculate all the "remaining percentages" and convert them for "bandwidth" only command set.

2] CBWQ is not supported on subinterfaces , Only shaping is supported on the subinterfaces. So class-map with class-default is necessary as all it does is tricks the router that its actually just using shapping.

E.G.

policy-map PARENT

class class-default

shape average 100

service-policy pmmpls5

Shaping to 100% percent means traffic is sent as is.

*EDIT*

I see that you changed it to physical interface.

So no need for another class-default class map.

Super Bronze

Re: QOS Assistance

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

In the below class map can some one explain is the default classs required ?

I am matching everything under AF2x.. Any suggestions is highly appreciated..

Yes and no.  You always have a default class, even if you don't explicitly define it.

Since you match "everything" in cm_af2x you would think nothing would fall into class-default, but you didn't really match everything, you only matched any IP.

350
Views
0
Helpful
4
Replies