Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS (CBWFQ) on Cisco 1812

Hello

i'm working with a Cisco 1812 Router for my Diploma Thesis.

One of the targets is to realize a QoS Situation.

The main idea behind is to stress 2 Ports with incoming traffic

and to sort the traffic on 1 outgoing port.

I've marked the packets with Diffserv under IxChariot. To match

them i've created 4 Access-lists. 2 for each Incoming Port. 2 Lists,

because i'm working with IPv6 and IPv4. I've put each Access-list into

one Traffic Class. Attached all this traffic-classes with one

policy to the outgoing Interface. The 2 Input Interfaces are WAN

Interfaces. The outgoing Interface is a VLAN Interface attached

to one of the switchports of the internal 8-port switch.

After testing the configuration, i've realized, that the access-lists,

have matched the packets correctly, but the service-policy wasn't

able to handle the bandwidth regarding to the definitions within

the traffic classes. At least i tried to give one IPv6 Traffic ab better

bandwidth than the other. Before i've tried the same with only IPv4, with

the same result - wasn't able to handle the service-policy.

Could you please be so kind and take a closer look at my configuration?

Best regards,

Terence Steve

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname RouterB

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

!

!

ip cef

no ip dhcp use vrf connected

!

!

no ip ips deny-action ips-interface

!

ipv6 unicast-routing

!

!

!

!

class-map match-all classv62

match access-group name background

class-map match-all classv61

match access-group name excellent

class-map match-all class2

match access-group 102

class-map match-all class1

match access-group 101

!

!

policy-map policy1

class class1

class class2

class classv61

bandwidth percent 70

class classv62

bandwidth percent 5

class class-default

!

!

!

!

!

interface BRI0

no ip address

shutdown

!

interface FastEthernet0

ip address 192.168.1.1 255.255.255.0

ip access-group 101 in

duplex auto

speed auto

ipv6 address 2001:DB8:1::/48 eui-64

ipv6 traffic-filter excellent in

ipv6 rip process1 enable

no shutdown

!

interface FastEthernet1

ip address 192.168.2.1 255.255.255.0

ip access-group 102 in

duplex auto

speed auto

ipv6 address 2001:DB8:2::/48 eui-64

ipv6 traffic-filter background in

ipv6 rip process1 enable

no shutdown

!

interface FastEthernet2

switchport access vlan 2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface FastEthernet9

!

interface Vlan1

no ip address

!

interface Vlan2

ip address 192.168.3.1 255.255.255.0

ipv6 address 2001:DB8:3::/48 eui-64

service-policy output policy1

!

router rip

version 2

network 192.168.1.0

network 192.168.2.0

network 192.168.3.0

!

ip classless

!

!

no ip http server

no ip http secure-server

!

access-list 101 permit ip host 192.168.1.2 host 192.168.3.2 dscp cs5

access-list 102 permit ip host 192.168.2.2 host 192.168.3.2 dscp cs1

ipv6 router rip process1

!

!

!

!

!

ipv6 access-list excellent

permit ipv6 host 2001:DB8:1:0:215:2BFF:FEBE:DE84 host 2001:DB8:3:0:215:2BFF:FEBE:DE83 dscp cs5

!

ipv6 access-list background

permit ipv6 host 2001:DB8:2:0:215:2BFF:FEBE:DE85 host 2001:DB8:3:0:215:2BFF:FEBE:DE83 dscp cs1

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

no scheduler allocate

end

4 REPLIES
Hall of Fame Super Gold

Re: QoS (CBWFQ) on Cisco 1812

Hi, a LAn interface is never congested hence QoS never kicks in. And even i it was congested, a 1812 route can't keep up with wire-speed fastethernet trafic.

Either you configure a parent/child type of policy-map to shape first, or you do your testing on a low speed interface. Typically, back-to-back serial interfaces are used for the purpose.

New Member

Re: QoS (CBWFQ) on Cisco 1812

Are you sure, that a 1812 can't handle it? Because i've meassured an output around 80MBit/s (goodput). IxChariot shows the result as 2x40MBits/s (2 Streams).

But i will follow your advise and i'm going to

check it with a chield policy in combination with shaping.

New Member

Re: QoS (CBWFQ) on Cisco 1812

Shaping has no effect. Has anyone else an idea?

New Member

Re: QoS (CBWFQ) on Cisco 1812

I've found a solution by myself. Just changed the outgoing VLAN with one ingoing WAN interface. Now it works.

507
Views
0
Helpful
4
Replies