cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
456
Views
10
Helpful
3
Replies

Qos configuration with Rate-limit

ravichandrantg
Level 1
Level 1

Hi,

I have currently configured priority queuing with high,medium,low and normal criteria matching accesslist on my serial interface connecting a remote site.

The current bandwidth on the serial LL is 1 Mbps, i would like to reduce the same to 512 Kbps.

In order to test that i would like to configure the interface with rate-limit.

If i apply rate-limit on the Serial interface for 512 Kbps whether priority queing will be effected after the traffic reaches 512 Kbps.

Please clarify.

Regards

Ravi

1 Accepted Solution

Accepted Solutions

royalblues
Level 10
Level 10

You should actually use a nested policy map, wherein the overall bandwidth is policed or shaped as per your needs

eg.

policy-map WAN-child

class VOICE

priority percent 20

policy-map WAN-parent-policy

class class-default

shape average 512000 ---- you can also police

service-policy WAN-child

This would ensure your overall CAR still respecting priority for LLQ

HTH, rate if it does

Narayan

View solution in original post

3 Replies 3

royalblues
Level 10
Level 10

You should actually use a nested policy map, wherein the overall bandwidth is policed or shaped as per your needs

eg.

policy-map WAN-child

class VOICE

priority percent 20

policy-map WAN-parent-policy

class class-default

shape average 512000 ---- you can also police

service-policy WAN-child

This would ensure your overall CAR still respecting priority for LLQ

HTH, rate if it does

Narayan

mheusing
Cisco Employee
Cisco Employee

Hi,

Assuming your router does support it, hierarchical QoS policies would be exactly what you need. One policy is used to shape the rate down to a configurable rate and the second poicy would then prioritize traffic within the defined bandwidth.

Example:

class-map match-all Mytraffic1

match ip address 101

! specify ACL 101 to match traffic for priority queue

class-map match-all Mytraffic2

match ip address 102

! specify ACL 102 to match other important traffic

policy-map Shape512k

class class-default

shape average 512000

service-policy output Prio

policy-map Prio

class Mytraffic1

priority 128

class MyTraffic2

bandwidth 200

class class-default

fair-queue

random-detect

Interface Serial0

bandwidth 512

ip address 10.1.1.1 255.255.255.252

service-policy output shape512k

You have to adjust the example config to your environment and also could use many more classes than depicted.

In case you add a "rate-limit" command to the interface per class, you would drop traffic, if it increases above the specified rate, regardless of the available capacity at this moment. In the above config MytrafficX will get minimum guarantees and thus might be allowed to get the full shaped bandwidth, if no other traffic is present.

The example above follows current best practice. For further reading have a look at "Enterprise QoS Solution Reference Network Design Guide Version 3.3"

http://www.cisco.com/application/pdf/en/us/guest/netsol/ns432/c649/ccmigration_09186a008049b062.pdf

Hope this helps! Please rate all posts.

Regards, Martin

Thanks , this exactly match my requirement

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card