Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

QOS/COS on a T1 to T3 connection

Hello.

I am needing some advice on how to setup the following.

I have in the field T1 connected to a MPLS network coming back to a T3. The T1s are conjested with Lotus Notes, Oracle and Voip traffic. The field routers are 2821 with Call Manager plus they have a 16-port 10/100 module within the router. In my configuration, I have applied CBWFQ for the traffic going out of the serial port. But I need to apply a service-policy for the input since we get killed with Notes and Oracle traffic. I really need help on this..

I did create a serivce-poicy for input but I got this error when appling the policy so I know I got it wrong.

SFRTR01(config-if)#service-policy input abs-traffic-in

CBWFQ : Can be enabled as an output feature only

One more question, Right now we are only using 9Meg of the 4Meg pipe at the corporate office but will I need to put a serivce-policy on this????

Config from field.

!

ip nbar port-map custom-02 tcp 7777

ip nbar port-map custom-01 tcp 8000

ip cef

!

class-map match-any voice-traffic

match protocol rtp

match protocol h323

match protocol skinny

class-map match-any web-outbound

match protocol http

class-map match-any business-traffic

match protocol notes

match protocol netbios

class-map match-any oracle-traffic

match protocol custom-02

match protocol custom-01

class-map match-any oracle-http-traffic

match protocol http url "*compass*"

match protocol http url "*abs2000*"

match protocol http url "*gems*"

match protocol http url "*livelink*"

!

policy-map abs-traffic-in

class voice-traffic

priority percent 10

class oracle-traffic

bandwidth percent 50

random-detect

class oracle-http-traffic

bandwidth percent 10

random-detect

class business-traffic

class web-outbound

policy-map abs-traffic-out

class voice-traffic

set ip precedence 2

priority percent 10

class oracle-traffic

set ip precedence 2

bandwidth percent 50

random-detect

class oracle-http-traffic

set ip precedence 2

bandwidth percent 10

random-detect

class business-traffic

set ip precedence 0

class web-outbound

set ip precedence 0

!

interface Serial0/3/0

bandwidth 1544

ip address x.x.x.x 255.255.252

ip nbar protocol-discovery

service-module t1 timeslots 1-24

service-policy output abs-traffic-out

!

interface FastEthernet1/0

switchport mode trunk

switchport voice vlan 2

!

interface Vlan1

description ***Data Vlan***

ip address XXX

ip inspect Webfilter in

!

interface Vlan2

description ***Voice Vlan***

ip address xxx

!

router ospf 1

router-id 172.27.250.122

log-adjacency-changes

network x.x.x0 0.0.0.255 area 2

network x.x.x0 0.0.0.255 area 2

network x.x.x.120 0.0.0.3 area 0

!

2 REPLIES
New Member

Re: QOS/COS on a T1 to T3 connection

CBWFQ can be performed only on packets exiting the interface.

hieu

Gold

Re: QOS/COS on a T1 to T3 connection

I assume your issue is traffic leaving the main site with the t3 going to the remote site.

As stated above you can only use most these options outbound. You can police the traffic inbound but it doesn't always help because the traffic already used to bandwidth to get to the site before it is dropped. The only reason it partially works is because of how TCP does packet retranmission.

The best options is talk to your provider and see what they can offer. Since you are running VoIP I hope you have at lease some committed or gold bandwidth.

You should be able to mark your packet to correspond to a quality of service model they provide. This will allow them to queue the packets on their routers as they are being sent on the t1 to your remote site. This also solve the problem of any to any traffic where you cannot determine from moment to moment where traffic is coming from. As long as its is consitantly marked the provider will give preference to the traffic you want.

Another not so good option is to shape the traffic as it leaves the main router on the t3. This will only work if there is little traffic between the hub sites.

What you basically do is build a shaper class for each site. You match destination ip to place the data in the correct class which you then shape to a t1. This in effect makes your t3 look like a group of channelized t1's. Withing each of these classes you can apply a quality of service to limit the traffic. This tends to be complex to maintain and gets almost impossible if you have redundant pathing to the remote sites. This may be your only option if your mpls network you bought is all best effort with no commitments

133
Views
0
Helpful
2
Replies
CreatePlease to create content