Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QOS for Polycom Video Conference

Setup:

Site A Cisco 2911 -- 2 T1 WIC.  One going to Site B 1841 another going to Site C 1841.

I am looking for a way to setup a Polycom QOS, judging by several forum posts about this, would it be better to create an access list with the Polycom IPs to limit the bandwidth to 512Kbps?  Or if not, could someone send a link for Polycom QOS configs?  What is happening is when noone else is using the connection except for the video conference, after about an hour with the T1 not being 100 % utilized, the 2911 GE0/0 interface will start developing input queue errors.  What I usually have to do is reboot the router at night and that alleviates the problem since regular data traffic will not cause this problem.

2911 running config:

Current configuration : 3529 bytes

!

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec localtime show-timezone year

service password-encryption

!

hostname

!

boot-start-marker

boot-end-marker

!

card type t1 0 0

card type t1 0 1

card type t1 0 2

!

no aaa new-model

clock timezone gmt -5

clock summer-time cdt recurring

no network-clock-participate wic 0

no network-clock-participate wic 1

no network-clock-participate wic 2

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

multilink bundle-name authenticated

!

!

!

!

license udi pid CISCO2911/K9 sn FTX1513ALLS

!

!

!

!

controller T1 0/0/0

cablelength long 0db

channel-group 0 timeslots 1-24

!

controller T1 0/0/1

clock source internal

cablelength long 0db

channel-group 0 timeslots 1-24

!

controller T1 0/1/0

clock source internal

cablelength long 0db

channel-group 3 timeslots 1-24

!

controller T1 0/1/1

clock source internal

cablelength long 0db

channel-group 2 timeslots 1-24

!

controller T1 0/2/0

cablelength long 0db

channel-group 0 timeslots 1-24

!

controller T1 0/2/1

clock source internal

cablelength long 0db

channel-group 0 timeslots 1-24

!

buffers middle permanent 200

buffers middle max-free 230

buffers middle min-free 50

buffers big permanent 75

buffers big max-free 200

buffers big min-free 15

buffers verybig permanent 20

buffers verybig max-free 20

buffers tune automatic

!

!

!

!

interface Multilink1

ip address 192.168.200.1 255.255.255.252

ip flow ingress

ip flow egress

load-interval 30

ppp multilink

ppp multilink group 1

ppp multilink fragment disable

no cdp enable

hold-queue 4000 out

!

interface GigabitEthernet0/0

ip address 10.10.3.1 255.255.240.0

ip flow ingress

ip flow egress

duplex full

speed auto

no cdp enable

hold-queue 240000 in --- Just changed it...used to be 3000

hold-queue 240000 out  --- Same thing but used to be 4096

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

no fair-queue

hold-queue 40 out

!

interface Serial0/0/1:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

no fair-queue

hold-queue 40 out

!

interface Serial0/1/0:3

ip address 192.168.1.2 255.255.255.0

ip flow ingress

ip flow egress

load-interval 60

no fair-queue

hold-queue 200 in

hold-queue 4000 out

!

interface Serial0/1/1:2

ip address 192.168.8.2 255.255.255.0

ip flow ingress

ip flow egress

load-interval 30

no fair-queue

hold-queue 200 in

hold-queue 4096 out

!

interface Serial0/2/0:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

no fair-queue

!

interface Serial0/2/1:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

no fair-queue

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

ip flow-cache timeout active 1

ip flow-export source GigabitEthernet0/0

ip flow-export version 5

ip flow-export destination

!

ip route 0.0.0.0 0.0.0.0 10.10.18.1

ip route 10.10.1.0 255.255.255.0 192.168.1.1

ip route 10.10.5.0 255.255.255.0 192.168.8.1

ip route 10.10.9.0 255.255.254.0 192.168.200.2

!

logging trap notifications

logging

!

!

snmp-server community

snmp-server community

!

control-plane

!

!

line con 0

logging synchronous

line aux 0

line vty 0 4

session-timeout 60

privilege level 15

logging synchronous

login

transport input telnet

!

scheduler allocate 20000 1000

end

1 REPLY
Super Bronze

QOS for Polycom Video Conference

Disclaimer

The    Author of this posting offers the information contained within this    posting without consideration and with the reader's understanding that    there's no implied or expressed suitability or fitness for any  purpose.   Information provided is for informational purposes only and  should not   be construed as rendering professional advice of any kind.  Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In    no event shall Author be liable for any damages whatsoever  (including,   without limitation, damages for loss of use, data or  profit) arising  out  of the use or inability to use the posting's  information even if  Author  has been advised of the possibility of such  damage.

Posting

For a live video stream, you might define a QoS service policy to place it into LLQ.  Or, you might provision the policy to give in enough priority where it's almost treated like LLQ.

Unclear why you would want to limit the Polycom traffic to 512 Kbps.  Live video streams often don't well tolerate excessive delay or much packet loss.

You could identify the Polycom traffic in several way.  I vaguely recall Polycoms might support tagging their packets with different markings; might only be a choice of IP Prec, but that's usable too.

As to your input queue error, that's difficult to say without much more in detail.  Might be a bug.

1214
Views
0
Helpful
1
Replies