Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS for voice on a multi-link frame relay interface / subinterface

Hello,

My question is in regards to QoS on an MFR interface/subinterfaces. We have a remote site with two bundled T1's terminating on a 2951 router for a total bandwidth of 3072. The circuit is provided by Paetec and the subinterfaces are designated for internet and MPLS traffic respectively. The issue we are facing is with outbound voice quality. It seems that no matter how we apply QoS, either to the main MFR interface or the MFR subinterfaces, voice packets do not seem to be prioritized. We tried FRTS, which slowed the entire link down to a crawl, we tried applying a class map to the main interface as well as a service policy, none of which seemed to affect anything. Please see below for current partial configuration. Any input will be greatly appreciated.

class-map match-all VOICE

match ip dscp ef

class-map match-any SIGNALING

match ip dscp af31

match ip dscp cs3

class-map match-all AZ-SERVERS

match access-group 10

!

!

policy-map VOICE-POLICY

class VOICE

    priority 640

class SIGNALING

    bandwidth 64

  set dscp af41

class AZ-SERVERS

    police 1000000

class class-default

    fair-queue

!

!

!

!

!        

interface Loopback1

no ip address

!

interface Tunnel1

no ip address

!

interface MFR1

no ip address

ip flow ingress

ip flow egress

load-interval 30

frame-relay lmi-type ansi

service-policy output VOICE-POLICY

!

interface MFR1.501 point-to-point

description => Internet via PAETEC

ip vrf forwarding internet

ip address 63.255.X.X 255.255.255.252
ip flow ingress
ip flow egress
no cdp enable

frame-relay interface-dlci 501 IETF  

!

interface MFR1.502 point-to-point

description => MPLS VPN via PAETEC

ip address 63.253.X.X 255.255.255.252
ip flow ingress
ip flow egress
no cdp enable
frame-relay interface-dlci 502 IETF

4 REPLIES
New Member

QoS for voice on a multi-link frame relay interface / subinterfa

MAte...

some tips:

-You should configure the policy-map in the Point to point links.

-MAke sure the packets are coming already marked, as your just matching it. (ip flow for checking)

- To conform with the acquired bandwidth, i would make a nested policy map shaping everything.. like:

policy-map SHAPE

class class-default

shape average 3072 (bc standard) (be 0)

service-policy VOICE-POLICY

You can also create another policy map to police the VOICE class (action drop) 

policy-map policeVoip

police 640000 conform-action transmit exceed-action drop

----

class VOICE

    priority 640

    servicy-policy policeVoip

And lastly, remember that voip packets that exceed the priority configured limit will NOT have strict priority (it may get dropped as just another junk traffic)

I hope this helps

Please, rate useful posts.

QoS for voice on a multi-link frame relay interface / subinterfa

For this to work as desired, you need to assign the policy only to interface MFR1.502.

It is pretty useless to run qos on an Internet connection because the priority will not be granted in the rest of the path.

Please provide the output of sh policy-map after making the above change.

I am especially curious about the bandwidth values listed in the output.

regards,

Leo

New Member

QoS for voice on a multi-link frame relay interface / subinterfa

I definitely agree, we've tried that as well. Unfortunatley, you can't apply a policy map containing elements of CBWFQ to sub interfaces.

QoS for voice on a multi-link frame relay interface / subinterfa

OK, sounds logical.

Have you tried to remove the fair-queue from the default policy then?

Try to replace it with a bandwidth statement.

regards,

Leo

720
Views
0
Helpful
4
Replies