Cisco Support Community
Community Member

QoS For VOIP - Non Cisco PBX

Greetings, im currently in the process of configuring a QoS policy between two sites connected using ADSL2 links and IPSEC/GRE tunnels.

The phone system, an NEC SV8100 is located at the head office and serves local phones it is also connected to an ISDN PRI, the branch office houses 10 IP phones which are registered with the NEC system via the GRE/IPSEC tunnel, i have been informed that the phones use SIP for call setup and teardown on port 5060,5070 and 5080.

NEC IP Address:

NEC VOIP Media Address:

Intersite Codec: G729

DSL Connection: 8000Kbps/792Kbps

Im very much aware of how i would do this with a Cisco PBX as i deploy CME all the time but could i check that the following policy is suitable for intersite voice traffic please, i intend to replicate this at the head office also on an ADSL2 circuit.

Branch Office

ip access-list extended voiceTraffic
  permit udp any any eq 5060
  permit udp any any eq 5070
  permit udp any any eq 5080
  permit ip any host
  permit ip any host


class-map match-any callTraffic
match access-group name voiceTraffic
policy-map callTraffic
class callTraffic
    priority 256
policy-map GLOBAL
class class-default
    shape average 792000
  service-policy callTraffic


interface Tunnel0
bandwidth 8000
ip address
ip mtu 1420
ip nbar protocol-discovery
qos pre-classify
tunnel source Dialer1
tunnel destination x.x.x.x
tunnel path-mtu-discovery
crypto map bhxmap


interface Dialer1
description WAN Interface
mtu 1492
bandwidth 792
tx-ring-limit 3
crypto map bhxmap
service-policy output GLOBAL


router eigrp 1
passive-interface Dialer1
passive-interface Vlan1
no auto-summary
eigrp stub connected summary

Hall of Fame Super Gold

Re: QoS For VOIP - Non Cisco PBX

Do you have the ADSL interface in the router ? That would be much better.

Also, you can pretty much disregard signalling, and try using a DSCP match, maybe they are sane and use EF:

Community Member

Re: QoS For VOIP - Non Cisco PBX

I do have an ATM interface on the router, i can if needs be created a subinterface and apply the policy there, i have also since been given the DSCP settings from the PBX engineer, 40 and 48 apparently.


CreatePlease to create content