Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

QOS for Voip

We have a dedicated T1 to a remote site. I want to make sure that we have the proper QOS setup. Right now all we have are policy maps that set dscp values. For example:

class voice-s0/0

bandwidth remaining percent 70

set dscp ef

class voice is defined as protocol rtp audio

Our phone sys is an ip office 406

Thanks,

9 REPLIES
New Member

Re: QOS for Voip

Is that your policy-map? What is your class-map?

You will also want to match your control traffic. I don't know what an IP office 406 is but you will need to mark and matching your control packets or you will experience a lot of delays in pick-ups, hang-ups, transfers, etc.

Re: QOS for Voip

Diff serv QoS is a per hop behavior meaning the qos configuration is required end to end for it to properly work.

Voice should generally be assigned to the LLQ (low latency Queuing) using the priority command. Your configuration is just setting the DSCP bit but you need to make sure your VoIP gets always the appropriate bandwidth.

The best possible way would be to set the DSCP bit at the ingress and prioritise this traffic on the egress.

eg. Say your vocie subnet range is 10.10.10.0/24 you can do something like this

class-map match-all voice

match ip rtp 16384 16383-----> matches RTP audio or

Match access group name voice

ip access-list extended voice

permit udp 10.10.10.0 0.0.0.255 any eq range 16384 32767

class-map match-all voice-wan

match ip dscp ef

policy-map ingress

class voip

set ip dscp ef

policy-map WAN

class voice-wan

priority percent 25 ---(depends upon the BW u want to assign)

class class-default

fair-queue

interface fa0/1

service-policy input ingress

interface s0/0

sevice-policy output WAN

HTH, rate if it does

Narayan

Re: QOS for Voip

Hi, [Pls Rate if Helps]

You can design as below:

class-map match-any VoIP

match access-group 100

class-map match-any RTP

match ip precedence 5

match ip precedence 4

policy-map low_level_QoS_backbone

!!Define Voice as Low Level QOS

class RTP

priority 2000

class class-default

fair-queue

!!Define a Top Level QOS Backbone

policy-map top_level_QoS_backbone_

class class-default

shape average

service-policy low_level_QoS_backbone

policy-map Marking

class VoIP

set ip precedence 5

!!ACL

access-list 100 permit ip any

INFO:policy-map low_level_QoS_backbone as CHILD QOS policy & policy-map top_level_QoS_backbone_ as PARENT QOS Policy.

INFO:policy-map low_level_QoS_backbone as VOICE Traffic & policy-map top_level_QoS_backbone_ as DATA Traffic with total availaible Bandwidth.

PLS RATE if HELPS

Best Regards,

Guru Prasad R

New Member

Re: QOS for Voip

Here is my qos config maybe give you guys a better idea:

ip nbar port-map custom-01 udp 5900 5500

ip nbar port-map custom-01 tcp 5900 5500

class-map match-any SDMVoice-FastEthernet0/0.2

match protocol rtp audio

class-map match-any SDMVoice-FastEthernet0/0.4

match protocol rtp audio policy-map SDM-Pol-FastEthernet0/0.2

class SDMManage-FastEthernet0/0.2

--More-- bandwidth remaining percent 3

set dscp cs2

class SDMVoice-FastEthernet0/0.2

priority percent 70

set dscp ef

class SDMRout-FastEthernet0/0.2

bandwidth remaining percent 3

set dscp cs6

class SDMTrans-FastEthernet0/0.2

bandwidth remaining percent 33

set dscp af21

class SDMSignal-FastEthernet0/0.2

bandwidth remaining percent 40

set dscp cs3

class SDMBulk-FastEthernet0/0.2

bandwidth remaining percent 20

set dscp default

policy-map SDM-Pol-FastEthernet0/0.4

class SDMManage-FastEthernet0/0.4

bandwidth remaining percent 3

set dscp cs2

class SDMVoice-FastEthernet0/0.4

priority percent 70

--More-- set dscp ef

class SDMRout-FastEthernet0/0.4

bandwidth remaining percent 3

set dscp cs6

class SDMTrans-FastEthernet0/0.4

bandwidth remaining percent 33

set dscp af21

class SDMSignal-FastEthernet0/0.4

bandwidth remaining percent 40

set dscp cs3

class SDMBulk-FastEthernet0/0.4

bandwidth remaining percent 20

set dscp default

New Member

Re: QOS for Voip

Your policy-map class names don't match class-map class names.

New Member

Re: QOS for Voip

They look like they do to me. Am I missing something here?

New Member

Re: QOS for Voip

hi

plz send full rouoter config (running config) as we can not see class defination and policy map,

i suppose u r using SDM tools , it is easy to config with it but it make the easy config very diffcult , also if u can attach ur topology as well as specify what traffic u want to mark

regards

New Member

Re: QOS for Voip

Below is more of my config. Please take a look.

Thanks

New Member

Re: QOS for Voip

policy map voice-out

class voice

priority x(x -b.w in kbps , it beter to use b.w in kbps for voice, take the voip b.w calculator (cisco site))

shape average >>>>>>>>in case u r using FR on ur T1

class-map match-any voice

match ip rtp audio>>>>>>>>>> if u have newer nbar, u can download them free( u can use " any" also)

match ip dscf ef>>>>>>>>>>> (ip phone(cisco) etc should be marking audio call as ef)

match ip precedence 5 >>>>>for awaya ip phone

on the respective router interface ( serial)

service-policy output voice-out

176
Views
0
Helpful
9
Replies